Bug 718420

Summary: gnome-shell crashes when doing Alt-Tab with alternate-tab extension
Product: [Fedora] Fedora Reporter: Michal Ambroz <rebus>
Component: gnome-shell-extensionsAssignee: Rahul Sundaram <metherid>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: medium    
Version: 15CC: akos.ladanyi, a.kriegl, awilliam, buraksunan, Christopher.Heerschap, juhani.jaakola, julien.fabius, maxamillion, metherid, michel, mike.reid, otaylor, pikachu.2014, psycardis, samkraju, walters
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: i686   
OS: Linux   
See Also: https://bugzilla.redhat.com/show_bug.cgi?id=677424
https://bugzilla.redhat.com/show_bug.cgi?id=696522
https://bugzilla.redhat.com/show_bug.cgi?id=698939
https://bugzilla.redhat.com/show_bug.cgi?id=702848
https://bugzilla.redhat.com/show_bug.cgi?id=704201
https://bugzilla.redhat.com/show_bug.cgi?id=712754
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-11-21 17:32:57 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Michal Ambroz 2011-07-02 14:07:19 EDT
Description of problem:
After "yum udate" the gnome-shell crashes each time Alt-Tab key combination is ressed to switch windows with the extension enabled for the alternate tab handling.



Version-Release number of selected component (if applicable):
gnome-shell-3.0.2-4.fc15.i686
gnome-shell-extensions-alternate-tab-3.0.2-1.g63dd27cgit.fc15.noarch

How reproducible:
100%

Steps to Reproduce:
1. update to current version of gnome-shell
2. install extension gnome-shell-extensions-alternate-tab.noarch
3. restart gnome-shell (Alt-F2 , r) 
4. use Alt-Tab to switch windows
  
Actual results:
St-ERROR **: st_widget_get_theme_node called on the widget [0xa039360 ShellGe
nericContainer.switcher-list] which is not in the stage.
aborting.

Expected results:
Windows should be switching using the alternate switcher as it was before ugrade of gnome-shell.
Comment 1 Juhani Jaakola 2011-07-26 11:30:07 EDT
I have the same error as well on two laptops that I have upgraded from Fedora 14. I have the same versions. This is a really annoying bug, because I use Alt-Tab very often.
Comment 2 andreas kriegl 2011-07-28 09:34:17 EDT
The same thing happens here. Very annoying.
Comment 3 Michal Ambroz 2011-07-28 11:06:13 EDT
I have got still the same versions, but Alt-Tab started working for me over the weekend after doing "yum update".

I have got still the same versions of gnome-shell and the extension:
gnome-shell-3.0.2-4.fc15.i686
gnome-shell-extensions-alternate-tab-3.0.2-1.g63dd27cgit.fc15.noarch

... so the issue was probably related to some 3rd library, which got updated recently.

Best regards
Michal Ambroz
Comment 4 Mike Reid 2011-08-17 17:39:33 EDT
The extension was working for me when I installed it a few weeks ago (which would have been in a similar time-frame as Michal's comment), but after an update in the past few days is now crashing every time, presumably because a library has changed again. 

I have the same versions as in Michal's comment. 

Mike
Comment 5 Michal Ambroz 2011-08-25 14:46:30 EDT
Hello,
this is really strange. I had to reinstall the machine from a scratch and Alt-Tab is not working for me again. Still the same versions of gnome-shell and extensions. I fail to detect the race condition, which is triggering this annoying bug.

$ rpm -qa|grep gnome-shell
gnome-shell-3.0.2-4.fc15.i686
gnome-shell-extensions-common-3.0.2-1.g63dd27cgit.fc15.noarch
gnome-shell-extensions-alternate-tab-3.0.2-1.g63dd27cgit.fc15.noarch

Error in the .xsession-errors:
St-ERROR **: st_widget_get_theme_node called on the widget [0xa700090 ShellGenericContainer.switcher-list ("mambroz@mixer:~")] which is not in the stage.
aborting...
Comment 6 Michal Ambroz 2011-08-25 15:07:27 EDT
Could be duplicate of 696522
Comment 7 Michal Ambroz 2011-08-29 11:25:23 EDT
Added links to other bug reports most probably triggered by the same issue to "See Also".
Comment 8 Juhani Jaakola 2011-09-01 04:32:16 EDT
Alt-Tab seems to work with these versions:

$ rpm -qa|grep gnome-shell
gnome-shell-extension-alternate-tab-3.0.2-3.20110630git939994d0.fc15.noarch
gnome-shell-extension-places-menu-3.0.2-3.20110630git939994d0.fc15.noarch
gnome-shell-3.0.2-4.fc15.i686
gnome-shell-extension-common-3.0.2-3.20110630git939994d0.fc15.noarch
gnome-shell-extension-alternative-status-menu-3.0.2-3.20110630git939994d0.fc15.noarch
Comment 9 Juhani Jaakola 2011-09-28 07:06:41 EDT
Now after recent updates Alt-Tab crashes gnome-shell again! Command "rpm -qa|grep gnome-shell" shows exactly the same versions as in my previous post on 2011-09-01 04:32:16 EDT.

This is very annoying!
Comment 10 Chris Heerschap 2011-10-14 11:53:23 EDT
Also seeing this bug.  Default Alt-Tab (grouped icons requiring Alt-~) is bad, but crashing the shell with the Alt-Tab works logically is worse.  Gnome 3 has a whole bunch of awesome, but plenty of annoying.

When I saw the error, I had the following gnome-shell-extension* packages installed:

gnome-shell-extension-alternate-tab.noarch
    3.0.2-3.20110630git939994d0.fc15                   @updates
gnome-shell-extension-alternative-status-menu.noarch
    3.0.2-3.20110630git939994d0.fc15                   @updates
gnome-shell-extension-common.noarch
    3.0.2-3.20110630git939994d0.fc15                   @updates

I've also noticed there are two almost identical packages available via yum:

> yum list gnome-shell-extension*alternate-tab
Available Packages
gnome-shell-extension-alternate-tab.noarch
    3.0.2-3.20110630git939994d0.fc15                         updates
gnome-shell-extensions-alternate-tab.noarch
    3.0.0-5.6d56cfgit.fc15                                   fedora 

I've installed the older plural ("extensions") from the fedora repo, we'll see how this one goes.
Comment 11 Adam Williamson 2011-11-21 17:29:37 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Adam Williamson 2011-11-21 17:31:16 EST
*** Bug 696522 has been marked as a duplicate of this bug. ***
Comment 13 Adam Williamson 2011-11-21 17:32:57 EST
seems like the abrt reports are mostly hitting 698939, so let's use that as the master bug.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 698939 ***
Comment 14 brksnn 2011-12-08 04:14:42 EST
Hi Guys, 

I also trying to solve the same error, however system doesnt let me to do it. firstly, I tried to remove "gnome-shell-extension-alternate-tab". Then it was removed. Secondly, I tried to install older version ""gnome-shell-extensions-alternate-tab", but it gives me that response;

[root@brksnn ~]# yum install gnome-shell-extensions-alternate-tab
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: linus.iyte.edu.tr
 * livna: rpm.livna.org
 * rpmfusion-free: mirror.yandex.ru
 * rpmfusion-free-updates: mirror.yandex.ru
 * rpmfusion-nonfree: mirror.de.leaseweb.net
 * rpmfusion-nonfree-updates: mirror.de.leaseweb.net
 * updates: ftp.uni-erlangen.de
Setting up Install Process
Package gnome-shell-extensions-alternate-tab is obsoleted by gnome-shell-extension-alternate-tab, trying to install gnome-shell-extension-alternate-tab-3.0.2-3.20110630git939994d0.fc15.noarch instead
Resolving Dependencies
--> Running transaction check
---> Package gnome-shell-extension-alternate-tab.noarch 0:3.0.2-3.20110630git939994d0.fc15 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                  Arch   Version                          Repository
                                                                           Size
================================================================================
Installing:
 gnome-shell-extension-alternate-tab
                          noarch 3.0.2-3.20110630git939994d0.fc15 updates 8.3 k

Transaction Summary
================================================================================
Install       1 Package(s)

Total download size: 8.3 k
Installed size: 8.4 k
Is this ok [y/N]: N
Exiting on user Command
Complete!


Looking forward to help!