Bug 696522 - [abrt] gnome-shell-3.0.0.2-2.fc15: st_widget_get_theme_node: Process /usr/bin/gnome-shell was killed by signal 6 (SIGABRT)
[abrt] gnome-shell-3.0.0.2-2.fc15: st_widget_get_theme_node: Process /usr/bin...
Status: CLOSED DUPLICATE of bug 698939
Product: Fedora
Classification: Fedora
Component: gnome-shell-extensions (Show other bugs)
15
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
abrt_hash:bbcbfeddde48ecf08a0a50103a8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-14 04:28 EDT by Julien Fabius
Modified: 2011-11-21 17:34 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-21 17:31:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: event_log (18.20 KB, text/plain)
2011-04-14 04:28 EDT, Julien Fabius
no flags Details
File: dsos (33.33 KB, text/plain)
2011-04-14 04:28 EDT, Julien Fabius
no flags Details
File: backtrace (51.32 KB, text/plain)
2011-04-14 04:28 EDT, Julien Fabius
no flags Details
File: maps (37.55 KB, text/plain)
2011-04-14 04:28 EDT, Julien Fabius
no flags Details

  None (edit)
Description Julien Fabius 2011-04-14 04:28:24 EDT
abrt version: 2.0.0
comment: Alt + Tab make gnome-shell crash
executable: /usr/bin/gnome-shell
cmdline: /usr/bin/gnome-shell
component: gnome-shell
kernel: 2.6.38.2-9.fc15.i686
crash_function: st_widget_get_theme_node
architecture: i686
reason: Process /usr/bin/gnome-shell was killed by signal 6 (SIGABRT)
uid: 500
package: gnome-shell-3.0.0.2-2.fc15
username: julien
os_release: Fedora release 15 (Lovelock)
time: 1302767475
rating: 4

Text file: event_log, 18634 bytes
Binary file: smaps, 222275 bytes
Binary file: coredump, 263667712 bytes
Text file: dsos, 34135 bytes
Text file: backtrace, 52549 bytes
Text file: maps, 38455 bytes
Comment 1 Julien Fabius 2011-04-14 04:28:27 EDT
Created attachment 491990 [details]
File: event_log
Comment 2 Julien Fabius 2011-04-14 04:28:30 EDT
Created attachment 491991 [details]
File: dsos
Comment 3 Julien Fabius 2011-04-14 04:28:32 EDT
Created attachment 491992 [details]
File: backtrace
Comment 4 Julien Fabius 2011-04-14 04:28:35 EDT
Created attachment 491993 [details]
File: maps
Comment 5 Dan Winship 2011-04-14 15:29:51 EDT
It looks like this crash happened when using Alt+Tab, but we can't figure out exactly where in that code it's crashing. Were you running a lot of apps at the time? (Enough so that they wouldn't all easily fit into the Alt+Tab window.)
Comment 6 Julien Fabius 2011-04-16 10:18:26 EDT
For example : I'm using Libreoffice, Pidgin, gnome-terminal and firefox. Not a lot of apps. I tried with two console, it crash.

I installed gnome-tweak-tool in order to change gnome-shell theme. If I'm not wrong, the bug appeared at this moment. Although I put back the default theme, alt + tab doesn't work anymore, even if I remove the package.

(sorry for the bad english)
Comment 7 Julien Fabius 2011-04-17 10:59:55 EDT
It was the gnome-shell-extension-alternate-tab that crashed gnome-shell. I removed it and it works again.
Comment 8 Timur Kristóf 2011-04-17 13:05:59 EDT
gnome-shell-extensions-alternate-tab works for me, how can you be sure that it is what caused the crash?
Comment 9 Julien Fabius 2011-04-17 15:54:19 EDT
I don't understand : I tried to reinstall the package and now it works. 
However when it was installed, It didn't works !

There may be a link, but I couldn't change the wallpaper, and now I can.

What component can I put now ? (I'm new in bug reports)
Comment 10 talonx 2011-08-30 02:38:30 EDT
Same here. I have this extension and it was running fine. But then GNOME 3 started crashing after I ran a yum update. I've tried uninstalling the extension and reinstalling many times. It's always the same behaviour - GNOME 3 crashes on Alt-Tab when the extension is present, and works fine when it's not.

This is obviously a problem with the extension. It's a very helpful extension (the default GNOME 3 window-switching behaviour being unusable), so please fix it.
Comment 11 Adam Williamson 2011-11-21 17:31:16 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 718420 ***
Comment 12 Adam Williamson 2011-11-21 17:34:04 EST

*** This bug has been marked as a duplicate of bug 698939 ***

Note You need to log in before you can comment on or make changes to this bug.