Bug 698939 - [abrt] gnome-shell-3.0.0.2-2.fc15: st_widget_get_theme_node: Shell sometimes crashes when hitting alt-tab with alternate-tab extension installed
[abrt] gnome-shell-3.0.0.2-2.fc15: st_widget_get_theme_node: Shell sometimes ...
Status: CLOSED DUPLICATE of bug 761129
Product: Fedora
Classification: Fedora
Component: gnome-shell-extensions (Show other bugs)
15
i686 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
abrt_hash:436f8606b6b5da569a239779437...
: CommonBugs, Triaged
: 696522 702848 704201 712754 718420 720101 720470 722796 723330 727257 728788 728789 730048 730063 733041 733087 733226 733950 735653 736369 738906 751644 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-22 07:14 EDT by Igor Katalnikov
Modified: 2012-03-30 10:18 EDT (History)
35 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-30 10:18:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: event_log (20.03 KB, text/plain)
2011-04-22 07:14 EDT, Igor Katalnikov
no flags Details
File: build_ids (5.37 KB, text/plain)
2011-04-22 07:14 EDT, Igor Katalnikov
no flags Details
File: dsos (31.36 KB, text/plain)
2011-04-22 07:14 EDT, Igor Katalnikov
no flags Details
File: maps (34.82 KB, text/plain)
2011-04-22 07:14 EDT, Igor Katalnikov
no flags Details
File: backtrace (45.32 KB, text/plain)
2011-04-22 07:14 EDT, Igor Katalnikov
no flags Details
Smolt hardware profile (2.37 KB, text/plain)
2011-04-23 06:00 EDT, Igor Katalnikov
no flags Details
File: backtrace (88.73 KB, text/plain)
2012-03-29 16:44 EDT, Matthew Coolbeth
no flags Details

  None (edit)
Description Igor Katalnikov 2011-04-22 07:14:06 EDT
abrt version: 2.0.1
comment: Unexplained
architecture: i686
cmdline: /usr/bin/gnome-shell
component: gnome-shell
executable: /usr/bin/gnome-shell
kernel: 2.6.38.2-9.fc15.i686
crash_function: st_widget_get_theme_node
uid: 500
reason: Process /usr/bin/gnome-shell was killed by signal 6 (SIGABRT)
package: gnome-shell-3.0.0.2-2.fc15
username: igor
os_release: Fedora release 15 (Lovelock)
time: 1303465269
rating: 4

Text file: event_log, 20509 bytes
Text file: build_ids, 5496 bytes
Binary file: coredump, 188420096 bytes
Text file: dsos, 32117 bytes
Text file: maps, 35652 bytes
Text file: backtrace, 46411 bytes

environ
-----
XDG_SESSION_ID=1
HOSTNAME=music.lan
IMSETTINGS_INTEGRATE_DESKTOP=yes
SHELL=/bin/bash
TERM=dumb
HISTSIZE=1000
XDG_SESSION_COOKIE=c2a8e24788c45ff6a29a5b9400000016-1303465034.609339-1410347876
IMSETTINGS_MODULE=none
USER=igor
USERNAME=igor
MAIL=/var/spool/mail/igor
PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/igor/bin
DESKTOP_SESSION=gnome
QT_IM_MODULE=xim
PWD=/home/igor
XMODIFIERS=@im=none
LANG=en_US.utf8
GDM_LANG=en_US.utf8
GDMSESSION=gnome
HISTCONTROL=ignoredups
HOME=/home/igor
SHLVL=1
LOGNAME=igor
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-nReXUqlX6x,guid=52835e81f8805626fe5025e800000028
'LESSOPEN=||/usr/bin/lesspipe.sh %s'
WINDOWPATH=1
XDG_RUNTIME_DIR=/run/user/igor
DISPLAY=:0
G_BROKEN_FILENAMES=1
XAUTHORITY=/var/run/gdm/auth-for-igor-hhy4hw/database
_=/usr/bin/gnome-session
GNOME_DESKTOP_SESSION_ID=this-is-deprecated
SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1107,unix/unix:/tmp/.ICE-unix/1107
ORBIT_SOCKETDIR=/tmp/orbit-igor
GNOME_KEYRING_CONTROL=/tmp/keyring-6HUqXf
SSH_AUTH_SOCK=/tmp/keyring-6HUqXf/ssh
GPG_AGENT_INFO=/tmp/keyring-6HUqXf/gpg:0:1
DESKTOP_AUTOSTART_ID=10b2a1d881eda2246d130346503652191700000011070000
Comment 1 Igor Katalnikov 2011-04-22 07:14:10 EDT
Created attachment 494186 [details]
File: event_log
Comment 2 Igor Katalnikov 2011-04-22 07:14:12 EDT
Created attachment 494187 [details]
File: build_ids
Comment 3 Igor Katalnikov 2011-04-22 07:14:15 EDT
Created attachment 494188 [details]
File: dsos
Comment 4 Igor Katalnikov 2011-04-22 07:14:18 EDT
Created attachment 494189 [details]
File: maps
Comment 5 Igor Katalnikov 2011-04-22 07:14:21 EDT
Created attachment 494190 [details]
File: backtrace
Comment 6 Igor Katalnikov 2011-04-22 08:07:38 EDT
Package: gnome-shell-3.0.0.2-2.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Pressing Alt + Tab causes crash
Comment 7 Igor Katalnikov 2011-04-23 06:00:58 EDT
Created attachment 494409 [details]
Smolt hardware profile

Anomaly disappeared after removing "pci=use_crs" from grub.conf (IBM/Lenovo BIOS).
Comment 8 Igor Katalnikov 2011-04-25 06:22:12 EDT
Package: gnome-shell-3.0.0.2-2.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Cresh after pressing Alt + Tab (Reappeared)
Comment 9 Cyril Biencourt 2011-04-28 06:34:16 EDT
Package: gnome-shell-3.0.1-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Try to switching task using Ctrl + Tab
Comment 10 vishy 2011-05-03 13:16:43 EDT
Package: gnome-shell-3.0.1-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
ALT+TAB crashed gnome-shell
Comment 11 Igor Katalnikov 2011-05-06 03:39:31 EDT
Says here:

gnome-shell-extensions-alternate-tab.noarch 3.0.1-1.f016b9git.fc15 @updates-testing

Lets you use classic Alt+Tab (window-based instead of app-based) in GNOME Shell. GNOME Shell groups multiple instances of the same application together. This extension disables grouping.

This package does not work in my case. No crash after removing it but no nice real time animated windows ether.

Ctrl + Tab does zilch.
Comment 12 Jean-François Fortin Tam 2011-05-21 09:32:06 EDT
Package: gnome-shell-3.0.1-4.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Installed the gnome-shell-extensions-alternate-tab package, relogged in, and whenever you do alt+tab the shell crashes.
Comment 13 Eric Blake 2011-05-22 08:57:16 EDT
Package: gnome-shell-3.0.1-4.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
I installed gnome-shell-extensions-alternate-tab, then rebooted.  Now every time I try to 'alt-tab', gnome-shell crashes instead of cycling through windows.
Comment 14 akanashiro 2011-05-23 01:38:53 EDT
Package: gnome-shell-3.0.1-4.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Usando Gnome-Shell alternat tab
Comment 15 Alessandro Nazzani 2011-06-01 04:03:35 EDT
Package: gnome-shell-3.0.2-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Pressing Alt-Tab after installing gnome-shell-extensions-alternate-tab seems to cause this crash. I also see a dialog saying "Oh no, something gone wrong" (more or less) after which the session is closed. I had to uninstall that extension (unfortunately, as I don't quite like the new Alt-Tab behaviour in Gnome3).
Comment 16 Vladimir 2011-06-04 11:03:36 EDT
Package: gnome-shell-3.0.2-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Alt+Tab
Comment 17 Vladimir 2011-06-04 11:04:16 EDT
Package: gnome-shell-3.0.2-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Alt+Tab
Comment 18 Vladimir 2011-06-04 12:50:51 EDT
Package: gnome-shell-3.0.2-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Alt+Tab
Comment 19 Vladimir 2011-06-04 15:39:00 EDT
Package: gnome-shell-3.0.2-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Alt+Tab
Comment 20 Sam Varshavchik 2011-06-12 12:03:29 EDT
Package: gnome-shell-3.0.2-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Pressing alt-tab crashes gnome-shell. Nouveau driver. NV43 chipset.
Comment 21 Sam Varshavchik 2011-06-12 12:16:28 EDT
After uninstalling gnome-shell-extensions-alternate-tab, ALT-Tab no longer crashes gnome-shell for me.
Comment 22 Andre Cruz 2011-06-13 00:22:49 EDT
Package: gnome-shell-3.0.2-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Type <Ctrl> + <Tab>
Comment 23 Adam Hough 2011-06-13 11:02:49 EDT
Package: gnome-shell-3.0.2-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
1: Hit the keys Alt-tab
2: crash
Comment 24 Adam Hough 2011-06-13 11:37:39 EDT
Removed gnome-shell-extensions-alternate-tab and Alt-Tab no longer crashes gnome-shell.
Comment 25 adriano 2011-06-20 09:54:13 EDT
Package: gnome-shell-3.0.2-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
alt+tab with gnome-shell-extensions-alternate-tab
Comment 26 Jussi Eloranta 2011-06-27 07:07:16 EDT
Package: gnome-shell-3.0.2-4.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Suddenly the mouse focus is stuck to one window only. Can't activate others. Clicking and trying to restart gnome-shell lead to it crashing completely.
The mouse focus problem has started to appear every few hours now. I did not see this in the past so this is probably cause by some recent changes.
Comment 27 Alessandro Nazzani 2011-06-28 02:53:48 EDT
Package: gnome-shell-3.0.2-4.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Alt-tabbed (with alternatetab extension installed, but was working fine before yesterday)
Comment 28 Steven Stern 2011-07-04 00:05:58 EDT
Package: gnome-shell-3.0.2-4.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Pressed Alt-Tab, boom.
Comment 29 Hakan BAYIK 2011-11-13 08:57:17 EST
Package: gnome-shell-3.2.1-2.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
Trying to add an gnome-shell-extension
Comment 30 Arthur Rodrigues 2011-11-19 22:01:00 EST
Package: gnome-shell-3.2.1-2.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
I was using the chrome web browser and, when I opened some video from youtube, the screen got black and then the login screen appeared again...
Comment 31 Adam Williamson 2011-11-21 17:32:57 EST
*** Bug 718420 has been marked as a duplicate of this bug. ***
Comment 32 Adam Williamson 2011-11-21 17:33:54 EST
*** Bug 702848 has been marked as a duplicate of this bug. ***
Comment 33 Adam Williamson 2011-11-21 17:34:04 EST
*** Bug 696522 has been marked as a duplicate of this bug. ***
Comment 34 Adam Williamson 2011-11-21 17:34:13 EST
*** Bug 704201 has been marked as a duplicate of this bug. ***
Comment 35 Adam Williamson 2011-11-21 17:34:24 EST
*** Bug 712754 has been marked as a duplicate of this bug. ***
Comment 36 Adam Williamson 2011-11-21 17:35:52 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 37 Adam Williamson 2011-11-21 17:37:58 EST
There are some interesting recent changes in upstream git, particularly:

http://git.gnome.org/browse/gnome-shell-extensions/commit/extensions/alternate-tab?id=afa8ccd07fde8fa1581ec45551ad67d192c3c912

Rahul, it may be interesting to try backporting some of the upstream fixes...
Comment 38 Mohamed El Morabity 2011-11-21 17:41:46 EST
(In reply to comment #37)
> There are some interesting recent changes in upstream git, particularly:
> 
> http://git.gnome.org/browse/gnome-shell-extensions/commit/extensions/alternate-tab?id=afa8ccd07fde8fa1581ec45551ad67d192c3c912
> 
> Rahul, it may be interesting to try backporting some of the upstream fixes...
I'm just backporting this patch, as well some others to definitively make this extension work with GS 3.2.1.
Comment 39 Adam Williamson 2011-11-21 18:15:18 EST
well, the bug is affecting F15 as well as F16, so we can't simply backport all the 3.2-adjustment patches for the F15 package, I presume.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 40 Andrew Mc 2011-11-29 01:20:30 EST
Am experiencing the same bug on an up-to-date, clean installation of Fedora 16 x86_64 on a Dell Vostro 1500, with Nvidia graphics using Nouveau driver only (hardware info below)

Whenever alt+tab is pressed, gnome-shell is still able to launch applications, however no clicks or key presses register in any of the open applications, nor can any applications be closed.

After disabling the extension, and reverting to the standard alt+tab behaviour, this behaviour disappears.

Distribution: Fedora release 16 (Verne)
Kernel: Linux 3.1.1-2.fc16.x86_64
Architecture: x86_64
RAM:         4049804 kB
Graphics: 01:00.0 VGA compatible controller: nVidia Corporation G84 [GeForce 8600M GT] (rev a1)

Uptime:  08:17:23 up 46 min,  3 users,  load average: 0.01, 0.07, 0.17
Comment 41 Adam Williamson 2011-12-02 15:43:53 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 42 Owen Taylor 2012-01-18 13:24:35 EST
I'm going to mark a number of Fedora 15 crashes with the same backtrace as duplicates - for many of them I know that that user was alt-tabbing, for some of them I know the alternative alt-tab was installed, in other cases, it's just a guess.

But what I can say with some certainty is that crashes with this backtrace are no longer occurring with Fedora 16 so it should be safe to assume that all the crashes were this problem; if not, any other problem has been fixed anyways.
Comment 43 Owen Taylor 2012-01-18 13:25:01 EST
*** Bug 720470 has been marked as a duplicate of this bug. ***
Comment 44 Owen Taylor 2012-01-18 13:25:08 EST
*** Bug 722796 has been marked as a duplicate of this bug. ***
Comment 45 Owen Taylor 2012-01-18 13:25:16 EST
*** Bug 723330 has been marked as a duplicate of this bug. ***
Comment 46 Owen Taylor 2012-01-18 13:25:24 EST
*** Bug 727257 has been marked as a duplicate of this bug. ***
Comment 47 Owen Taylor 2012-01-18 13:25:32 EST
*** Bug 728788 has been marked as a duplicate of this bug. ***
Comment 48 Owen Taylor 2012-01-18 13:25:41 EST
*** Bug 728789 has been marked as a duplicate of this bug. ***
Comment 49 Owen Taylor 2012-01-18 13:25:50 EST
*** Bug 730048 has been marked as a duplicate of this bug. ***
Comment 50 Owen Taylor 2012-01-18 13:25:59 EST
*** Bug 730063 has been marked as a duplicate of this bug. ***
Comment 51 Owen Taylor 2012-01-18 13:26:06 EST
*** Bug 733041 has been marked as a duplicate of this bug. ***
Comment 52 Owen Taylor 2012-01-18 13:26:19 EST
*** Bug 733087 has been marked as a duplicate of this bug. ***
Comment 53 Owen Taylor 2012-01-18 13:26:29 EST
*** Bug 733226 has been marked as a duplicate of this bug. ***
Comment 54 Owen Taylor 2012-01-18 13:26:42 EST
*** Bug 733950 has been marked as a duplicate of this bug. ***
Comment 55 Owen Taylor 2012-01-18 13:26:54 EST
*** Bug 735653 has been marked as a duplicate of this bug. ***
Comment 56 Owen Taylor 2012-01-18 13:27:03 EST
*** Bug 736369 has been marked as a duplicate of this bug. ***
Comment 57 Owen Taylor 2012-01-18 13:27:10 EST
*** Bug 738906 has been marked as a duplicate of this bug. ***
Comment 58 Owen Taylor 2012-01-18 13:27:24 EST
*** Bug 751644 has been marked as a duplicate of this bug. ***
Comment 59 Owen Taylor 2012-01-18 13:28:14 EST
*** Bug 720101 has been marked as a duplicate of this bug. ***
Comment 60 Matthew Coolbeth 2012-03-29 16:44:18 EDT
Using alt-tab switcher provided by a shell extension which allows alt-tabbing to windows in another application. (the popular one)

backtrace_rating: 4
Package: gnome-shell-3.2.2.1-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)
Comment 61 Matthew Coolbeth 2012-03-29 16:44:28 EDT
Created attachment 573794 [details]
File: backtrace
Comment 62 abrt-bot 2012-03-30 10:18:14 EDT
Backtrace analysis found this bug to be similar to bug #761129, closing as duplicate.

Bugs which were found to be similar to this bug: 
  gjs: bug #761129
  gnome-shell: bug #702848, bug #720101

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 761129 ***

Note You need to log in before you can comment on or make changes to this bug.