Bug 728229

Summary: RuntimeError: XOpenDisplay failed
Product: Red Hat Enterprise Linux 6 Reporter: Hendrik Brueckner <brueckner>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Release Test Team <release-test-team>
Severity: medium Docs Contact:
Priority: low    
Version: 6.1CC: bcl, bugproxy, cristian.ciupitu, dmaxel, erikina, flokip, foxmulder881, frankly3d, jfrieben, jkachuck, jlaska, johannbg, jonathan, jreiser, justin, meyering, pknirsch, rbergero, sandro, ultima.ratio.regum69, vanmeeuwen+fedora, v.plessky
Target Milestone: rcKeywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: anaconda_trace_hash:bb3ba0ab6a88ef1fadfba2dbcc0c80fa426826a74e8304634cdf9b9b5043636e AcceptedBlocker
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 663294 Environment:
Last Closed: 2011-10-05 15:03:43 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 663294    
Bug Blocks:    

Description Hendrik Brueckner 2011-08-04 13:05:36 UTC
+++ This bug was initially created as a clone of Bug #663294 +++

The following was filed automatically by anaconda:
anaconda 15.11 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/account_gui.py", line 91, in setCapsLockLabel
    if _isys.isCapsLockEnabled():
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/account_gui.py", line 72, in getScreen
    self.setCapsLockLabel()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1285, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1205, in nextClicked
    self.setScreen ()
SystemError: error return without exception set

Comment 1 Hendrik Brueckner 2011-08-04 13:06:46 UTC
Please also integrate the problem fix from Bug #663294 to the RHEL6 version of anaconda as our test team runs in the same issue.

Thanks and kinds,
Hendrik

Comment 2 Chris Lumens 2011-08-04 14:04:24 UTC

*** This bug has been marked as a duplicate of bug 698282 ***

Comment 4 Joseph Kachuck 2011-10-05 15:04:18 UTC

*** This bug has been marked as a duplicate of bug 698282 ***

Comment 5 Joseph Kachuck 2011-10-05 15:05:28 UTC
Hello,
From looking at this I am unable to confirm if 698282, is the same as the patch in 663294. Would you be able to confirm?

Thank You
Joe Kachuck