Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 698282 - Crash after selecting timezone
Crash after selecting timezone
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.1
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
: OtherQA
: 706931 722451 728229 (view as bug list)
Depends On:
Blocks: 684953
  Show dependency treegraph
 
Reported: 2011-04-20 11:11 EDT by Andrew Overholt
Modified: 2012-02-27 15:10 EST (History)
11 users (show)

See Also:
Fixed In Version: anaconda-13.21.122-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
KVM on F15 x86_64 (qemu 0.14.0-7.fc15.x86_64)
Last Closed: 2011-12-06 05:32:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback (59.11 KB, text/plain)
2011-04-20 11:50 EDT, Andrew Overholt
no flags Details
Anaconda error messages displayed with the failure. (91.31 KB, text/plain)
2011-11-02 05:31 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1565 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2011-12-05 19:39:12 EST

  None (edit)
Description Andrew Overholt 2011-04-20 11:11:42 EDT
Description of problem:
Using a live image of a 6.1 candidate (20110413.1-Workstation-x86_64-Live), I tried to "Install to hard drive" and anaconda crashed.

Version-Release number of selected component (if applicable):
anaconda-13.21.112-1.el6.x86_64

How reproducible:
I haven't tried again yet but will comment back here if it happens again.

Steps to Reproduce:
1. Boot the above live image in a virtual machine on x86_64 F15 host
2. Double-click "Install to hard drive" desktop icon
3. Go through the screens up until the storage part (I think) and it crashes.
  
Actual results:
Crash (see attached .xml file).

Expected results:
No crash.

Additional info:
I have CapsLock set to be an additional Ctrl key on my host; I can't imagine that causing this problem but I thought I'd toss that out there.
Comment 1 Andrew Overholt 2011-04-20 11:19:40 EDT
Step 3. above should read "Go through the screens up to picking a timezone and choose Toronto; press next -> crash"
Comment 2 Andrew Overholt 2011-04-20 11:19:55 EDT
Oh, and I can reliably reproduce it.
Comment 4 Chris Lumens 2011-04-20 11:40:46 EDT
Could you attach the traceback?  I don't see it here.
Comment 5 Andrew Overholt 2011-04-20 11:50:48 EDT
Created attachment 493523 [details]
traceback

Sorry, forgot to attach it initially.
Comment 6 Chris Lumens 2011-04-20 12:09:55 EDT
Is that all you have to do to reproduce this?  We've seen it before (especially in Fedora) but have never been able to reproduce it to figure it out.
Comment 7 Andrew Overholt 2011-04-20 13:05:35 EDT
Yup, I can make it happen every time.
Comment 8 Brian Lane 2011-04-21 01:31:48 EDT
This looks like you are hitting the same problem as bug 663294, is your network serving up a DHCP hostname? You can also try running xhost + before running liveinst.

This was fixed in F15 by commit 900756cad358f443028ecbec0882651dbba5e433
Comment 9 Andrew Overholt 2011-04-21 10:08:51 EDT
My virtual network is evidently not serving up DHCP hostnames.  Running xhost + before running liveinst lets me get past the crash and to the "enter the root password" page.  Thanks.
Comment 10 David Cantrell 2011-04-25 13:57:41 EDT
This is the same as bug #663294 from Fedora.  The fix is to cherry-pick b5f46d92a3dfd790650920859312e9bf505c80be on rhel6-branch.  That patch is:

commit b5f46d92a3dfd790650920859312e9bf505c80be
Author: Chris Lumens <clumens@redhat.com>
Date:   Wed Dec 15 10:20:36 2010 -0500

    Raise an exception if X*Display functions fail (#663294).

diff --git a/pyanaconda/isys/isys.c b/pyanaconda/isys/isys.c
index 392a42c..e28fcad 100644
--- a/pyanaconda/isys/isys.c
+++ b/pyanaconda/isys/isys.c
@@ -603,6 +603,7 @@ static PyObject * doIsCapsLockEnabled(PyObject * s, PyObject * args) {
     XkbStateRec state;
 
     if ((d = XOpenDisplay(NULL)) == NULL) {
+        PyErr_SetString(PyExc_RuntimeError, "XOpenDisplay failed");
         return NULL;
     }
 
@@ -610,6 +611,7 @@ static PyObject * doIsCapsLockEnabled(PyObject * s, PyObject * args) {
     XkbGetState(d, XkbUseCoreKbd, &state);
 
     if (XCloseDisplay(d)) {
+        PyErr_SetString(PyExc_RuntimeError, "XCloseDisplay failed");
         return NULL;
     }
Comment 11 Chris Lumens 2011-04-25 14:02:01 EDT
That fixes part of it.  The other part is in comment #8.
Comment 12 Chris Lumens 2011-05-23 10:14:19 EDT
*** Bug 706931 has been marked as a duplicate of this bug. ***
Comment 13 RHEL Product and Program Management 2011-05-23 10:39:36 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.
Comment 15 Chris Lumens 2011-07-18 09:55:15 EDT
*** Bug 722451 has been marked as a duplicate of this bug. ***
Comment 18 Chris Lumens 2011-08-04 10:04:24 EDT
*** Bug 728229 has been marked as a duplicate of this bug. ***
Comment 19 Alexander Todorov 2011-08-05 11:34:34 EDT
(In reply to comment #7)
> Yup, I can make it happen every time.

Hi Andrew,
I wasn't able to reproduce. Can you give some more details about your network configuration and how exactly you created the virtual guest.
Comment 20 Andrew Overholt 2011-08-08 10:51:04 EDT
(In reply to comment #19)
> (In reply to comment #7)
> > Yup, I can make it happen every time.
> 
> Hi Andrew,
> I wasn't able to reproduce. Can you give some more details about your network
> configuration and how exactly you created the virtual guest.

I don't have it set up anymore but it was just a simple virt-manager-created network and guest with the defaults.
Comment 21 IBM Bug Proxy 2011-10-04 08:30:35 EDT
------- Comment From sachinp@in.ibm.com 2011-10-04 08:20 EDT-------
I tried this with RHEL 6.2 Beta1 release and can still recreate the problem.

anaconda 13.21.140 exception report
Traceback (most recent call first):
File "/usr/lib/anaconda/iw/account_gui.py", line 91, in setCapsLockLabel
if _isys.isCapsLockEnabled():
File "/usr/lib/anaconda/iw/account_gui.py", line 72, in getScreen
self.setCapsLockLabel()
File "/usr/lib/anaconda/gui.py", line 1470, in setScreen
new_screen = self.currentWindow.getScreen(anaconda)
File "/usr/lib/anaconda/gui.py", line 1391, in nextClicked
self.setScreen ()
RuntimeError: XOpenDisplay failed
Comment 23 Joseph Kachuck 2011-10-05 11:04:18 EDT
*** Bug 728229 has been marked as a duplicate of this bug. ***
Comment 25 David Cantrell 2011-10-10 15:38:42 EDT
Both Brian Lane and I have tried to reproduce this on KVM guests using the RHEL 6.2 Beta live image.  Installation works fine for both of us.  The patch that fixes the issue originally reported has been there since 21-Feb-2011.  The first build that included the fix was done on 21-Jul-2011 and was anaconda-13.21.122-1.  Moving back to ON_QA.
Comment 26 Georg Markgraf 2011-10-12 07:55:35 EDT
David,
please confirm that the fix for this BZ (System x)also apply for the System z related bug "728229" that has been marked duplicate to this System x bug.
Comment 27 David Cantrell 2011-10-12 10:06:33 EDT
(In reply to comment #26)
> David,
> please confirm that the fix for this BZ (System x)also apply for the System z
> related bug "728229" that has been marked duplicate to this System x bug.

It's the same bug.  Same code base, same fix on all platforms.
Comment 28 Joseph Kachuck 2011-10-12 10:35:43 EDT
Hello,
This is fixed in anaconda-13.21.122-1.

Thank You
Joe Kachuck
Comment 29 IBM Bug Proxy 2011-11-02 05:31:02 EDT
------- Comment From sachinp@in.ibm.com 2011-11-02 05:24 EDT-------
This problem can still be recreated against snap3.

architecture: s390x
cmdline: /usr/bin/python /usr/bin/anaconda
component: Cannot get package and component for file /usr/bin/anaconda
executable: /usr/bin/anaconda
kernel: 2.6.32-211.el6.s390x
package: Cannot get package and component for file /usr/bin/anaconda
release: Cannot get release name.
other involved packages:

anaconda 13.21.146 exception report
Traceback (most recent call first):
File "/usr/lib/anaconda/iw/account_gui.py", line 91, in setCapsLockLabel
if _isys.isCapsLockEnabled():
File "/usr/lib/anaconda/iw/account_gui.py", line 72, in getScreen
self.setCapsLockLabel()
File "/usr/lib/anaconda/gui.py", line 1470, in setScreen
new_screen = self.currentWindow.getScreen(anaconda)
File "/usr/lib/anaconda/gui.py", line 1391, in nextClicked
self.setScreen ()
RuntimeError: XOpenDisplay failed

I have attached the complete anaconda error messages.
Comment 30 IBM Bug Proxy 2011-11-02 05:31:11 EDT
Created attachment 531293 [details]
Anaconda error messages displayed with the failure.


------- Comment (attachment only) From sachinp@in.ibm.com 2011-11-02 05:25 EDT-------
Comment 32 errata-xmlrpc 2011-12-06 05:32:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1565.html

Note You need to log in before you can comment on or make changes to this bug.