Bug 729964

Summary: [abrt] yum-3.4.3-4.fc16: auto-update-debuginfo.py:41:enable_debuginfo_repos:TypeError: hasattr expected 2 arguments, got 1
Product: [Fedora] Fedora Reporter: Mads Kiilerich <mads>
Component: yumAssignee: Seth Vidal <skvidal>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: ffesti, hadfieldster, james.antill, kmaraas, maxamillion, pmatilai, tla, vonbrand, xeno, zpavlas
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:0cd44c51aeaaa33ef338eb5332a7a9c667e13bf1
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-08-16 05:18:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mads Kiilerich 2011-08-11 12:16:54 UTC
abrt version: 2.0.5
cmdline:        /usr/bin/python /usr/bin/yum update --skip-broken
comment:        Happens on all yum invocations after updating to yum-plugin-auto-update-debug-info-1.1.31-1.fc16.noarch
executable:     /usr/bin/yum
kernel:         3.0.1-2.fc16.x86_64
reason:         auto-update-debuginfo.py:41:enable_debuginfo_repos:TypeError: hasattr expected 2 arguments, got 1
time:           Thu Aug 11 14:15:28 2011
uid:            0
username:       root

backtrace:
:auto-update-debuginfo.py:41:enable_debuginfo_repos:TypeError: hasattr expected 2 arguments, got 1
:
:Traceback (most recent call last):
:  File "/usr/bin/yum", line 29, in <module>
:    yummain.user_main(sys.argv[1:], exit_code=True)
:  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
:    errcode = main(args)
:  File "/usr/share/yum-cli/yummain.py", line 140, in main
:    result, resultmsgs = base.doCommands()
:  File "/usr/share/yum-cli/cli.py", line 458, in doCommands
:    self._getTs(needTsRemove)
:  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 101, in _getTs
:    self._getTsInfo(remove_only)
:  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 112, in _getTsInfo
:    pkgSack = self.pkgSack
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 892, in <lambda>
:    pkgSack = property(fget=lambda self: self._getSacks(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 673, in _getSacks
:    self.repos.populateSack(which=repos)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 265, in populateSack
:    self.doSetup()
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 72, in doSetup
:    self.ayum.plugins.run('prereposetup')
:  File "/usr/lib/python2.7/site-packages/yum/plugins.py", line 184, in run
:    func(conduitcls(self, self.base, conf, **kwargs))
:  File "/usr/lib/yum-plugins/auto-update-debuginfo.py", line 121, in prereposetup_hook
:    enable_debuginfo_repos(yb, conduit)
:  File "/usr/lib/yum-plugins/auto-update-debuginfo.py", line 41, in enable_debuginfo_repos
:    if opts is not None and hasattr(opts.repos) :
:TypeError: hasattr expected 2 arguments, got 1
:
:Local variables in innermost frame:
:conduit: <yum.plugins.PreRepoSetupPluginConduit instance at 0x24749e0>
:yb: <weakproxy at 0x230c158 to YumBaseCli at 0x230ba90>
:args: ['update']
:mdrs: set([])
:opts: <Values at 0x23f6cb0: {'skipbroken': True, 'verbose': None, 'errorlevel': None, 'color': None, 'repos': [], 'assumeno': None, 'conffile': '/etc/yum/yum.conf', 'exclude': [], 'enableplugins': [], 'nogpgcheck': None, 'cacheonly': None, 'rpmverbosity': None, 'disableplugins': [], 'sleeptime': None, 'version': None, 'releasever': None, 'obsoletes': None, 'debuglevel': None, 'disableexcludes': [], 'showdupesfromrepos': None, 'assumeyes': None, 'disablepresto': False, 'installroot': None, 'quiet': None, 'tolerant': None, 'setopts': [], 'noplugins': None}>

smolt_data:
:
:
:General
:=================================
:UUID: 0bfc48e7-5093-4faf-8426-fcb77b3b929d
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 6117.92
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i3 CPU         540  @ 3.07GHz
:CPU Stepping: 5
:CPU Family: 6
:CPU Model Num: 37
:Number of CPUs: 4
:CPU Speed: 3059
:System Memory: 7969
:System Swap: 10047
:Vendor: Apple Inc.
:System: iMac11,2 1.0
:Form factor: All In One
:Kernel: 3.0.1-2.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Permissive
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:11361:32902:32902) pci, None, HOST/PCI, Core Processor QuickPath Architecture Generic Non-core Registers
:(32902:11521:32902:32902) pci, None, HOST/PCI, Core Processor QuickPath Architecture System Address Decoder
:(32902:64:0:0) pci, None, HOST/PCI, Core Processor DRAM Controller
:(32902:65:32902:0) pci, pcieport, PCI/PCI, Core Processor PCI Express x16 Root Port
:(32902:11536:32902:32902) pci, None, HOST/PCI, Core Processor QPI Link 0
:(32902:11537:32902:32902) pci, None, HOST/PCI, Core Processor QPI Physical 0
:(4172:33342:0:0) pci, None, PCI/PCI, XIO2213A/B/XIO2221 PCI Express to PCI Bridge
:(32902:11539:32902:32902) pci, None, HOST/PCI, Core Processor Reserved
:(32902:15152:32902:29296) pci, i801_smbus, SERIAL, 5 Series/3400 Series Chipset SMBus Controller
:(32902:15138:32902:29296) pci, ahci, STORAGE, 5 Series/3400 Series Chipset 6 port SATA AHCI Controller
:(32902:15106:32902:29296) pci, None, PCI/ISA, 5 Series Chipset LPC Interface Controller
:(32902:15154:32902:0) pci, None, NONE, 5 Series/3400 Series Chipset Thermal Subsystem
:(5348:5764:5348:5764) pci, tg3, ETHERNET, NetXtreme BCM5764M Gigabit Ethernet PCIe
:(32902:15163:32902:29296) pci, None, USB, 5 Series/3400 Series Chipset USB Universal Host Controller
:(32902:9294:32902:29296) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:15156:32902:29296) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15164:32902:29296) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(5772:42:4203:143) pci, ath9k, NETWORK, AR928X Wireless Network Adapter (PCI-Express)
:(32902:15174:32902:29296) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 3
:(32902:15170:32902:29296) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 1
:(32902:15172:32902:29296) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 2
:(32902:15190:32902:29296) pci, HDA Intel, MULTIMEDIA, 5 Series/3400 Series Chipset High Definition Audio
:(32902:15158:32902:29296) pci, None, USB, 5 Series/3400 Series Chipset USB Universal Host Controller
:(4098:43576:4203:43576) pci, HDA Intel, MULTIMEDIA, RV710/730
:(4098:38024:4203:182) pci, None, VIDEO, N/A
:(32902:11538:32902:32902) pci, None, HOST/PCI, Core Processor Reserved
:(4172:33343:0:0) pci, firewire_ohci, FIREWIRE, XIO2213A/B/XIO2221 IEEE-1394b OHCI Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/VolGroup-lv_root / ext4 4096 4096 5160607 2535276 2482868 1310720 1103278 1103278
:/dev/sda4 /boot ext4 1024 1024 495844 393703 368103 128016 127715 127715
:/dev/sda1 WITHHELD vfat 512 512 403218 341333 341333 0 0 0
:

Comment 1 Kjartan Maraas 2011-08-11 18:22:06 UTC
Package: yum-3.4.3-4.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
Happens when running yum list or yum check-update at least

Comment 2 Mads Kiilerich 2011-08-11 18:45:21 UTC
Workaround:
rpm -e yum-plugin-auto-update-debug-info

I guess /usr/lib/yum-plugins/auto-update-debuginfo.py line 41 should have been:

    if opts is not None and hasattr(opts, 'repos'):

Comment 3 Zdeněk Pavlas 2011-08-12 07:26:12 UTC
*** Bug 730172 has been marked as a duplicate of this bug. ***

Comment 4 Zdeněk Pavlas 2011-08-12 07:28:19 UTC
*** Bug 730171 has been marked as a duplicate of this bug. ***

Comment 5 Stan Trzmiel 2011-08-12 20:39:56 UTC
Package: yum-3.2.29-8.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
An attempt to perform any operation (update, search, check-update) triggers this bug

Most likely to update of those two components:
Aug 12 11:02:34 Updated: yum-utils-1.1.31-1.fc15.noarch
Aug 12 11:02:37 Updated: yum-plugin-auto-update-debug-info-1.1.31-1.fc15.noarch

Comment 6 Steven Hadfield 2011-08-15 21:45:29 UTC
If you don't want to remove the package to get around this problem, you can disable the plugin until the bug is fixed by passing '--disableplugin=auto-update-debug-info' as another parameter to yum.

Comment 7 Tim Lauridsen 2011-08-16 05:18:38 UTC

*** This bug has been marked as a duplicate of bug 729982 ***