This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 734308

Summary: All the interface strings are not showed in localized ones
Product: [Fedora] Fedora Reporter: Cheng-Chia Tseng <pswo10680>
Component: setroubleshootAssignee: Daniel Walsh <dwalsh>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 19CC: aalam, dwalsh, hpeters, htaira, kassabon14, lijli, mgrepl, noriko, piotrdrag, swkothar
Target Milestone: ---Keywords: Reopened, Translation
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: F19L10nTestday
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-05-02 00:32:54 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 958376    
Bug Blocks:    
Attachments:
Description Flags
The screeshot of SELinux Alert Browser
none
partially not localized
none
Setroubleshoot for Malayalam (ml) none

Description Cheng-Chia Tseng 2011-08-30 00:13:42 EDT
Created attachment 520512 [details]
The screeshot of SELinux Alert Browser

Description of problem:
The setroubleshoot: framework po file on Transifex.net (https://www.transifex.net/projects/p/setroubleshoot/resource/framework/) has been translated for some time. However, all the interface strings of setroubleshoot does not showed the localized version for zh_TW. 
Other languages should be ckecked.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install f16 Nightly in local language from http://dl.fedoraproject.org/pub/alt/stage/f16-translation/
2. after installation, do update
3. execute sealert -b
  
Actual results:
All the interface strings are not showed in localized ones

Expected results:
All the interface strings should be showed in localized ones

Additional info:
Comment 1 Hedda Peters 2011-08-30 00:50:02 EDT
same here for de_DE, application is shown mostly still in English
Comment 2 Noriko Mizumoto 2011-08-30 23:36:28 EDT
Same for ja-JP, the following are appeared in English but translated in PO file at transifex.

'Would you like to receive alerts?'
'Yes' and 'No'
'Troubleshoot'
'Notify/Admin'
'Detalis'
'Ignore'
'List All Alerts'
'If you were trying to... Then this is the solution.'
Comment 3 Noriko Mizumoto 2012-03-08 00:25:42 EST
This bug still exists, and changed version to 17 from 16.
setroubleshoot-3.1.3-1.fc17.x86_64

The following strings have been translated in transfiex, but appears in English.
Please pull latest translation.

'Would you like to receive alerts?'
'Yes' and 'No'
'Troubleshoot'
'Notify/Admin'
'Detalis'
'Ignore'
'List All Alerts'
Comment 4 Daniel Walsh 2012-03-08 09:58:22 EST
I am putting out updates for translations once a week.

I just released setroubleshoot-3.1.4-1.fc17.x86_64 to stable and will be putting

setroubleshoot-3.1.5-1.fc17.x86_64 into testing, today.
Comment 5 Noriko Mizumoto 2012-03-09 21:38:38 EST
Hi,
Updated to setroubleshoot-3.1.6-1.fc17.x86_64

The reported strings still appear in English.
They have been localized on transifex.
https://fedora.transifex.net/projects/p/setroubleshoot/
Comment 6 Daniel Walsh 2012-03-10 06:21:39 EST
Noriko, any idea what is going wrong?
Comment 7 Noriko Mizumoto 2012-03-13 08:16:40 EDT
Daniel,
There is similar report from the another package maintainer at the bug#801232.
Besides, I and others have filed more bugs similar to this but no reply yet.
It is outside of my capability and need immediate attention.
Comment 8 Daniel Walsh 2012-03-13 08:53:28 EDT
Ok I added additional lanquages to  setroubleshoot-3.1.7-1.fc17.x86_64

 LANG=ja_JP sealert  -s

Now gives me translations.

 LANG=de_DE sealert  -s

Does not.

We do ship 

 rpm -ql setroubleshoot-server | grep locale/de
/usr/share/locale/de/LC_MESSAGES/setroubleshoot.mo
/usr/share/locale/de_CH/LC_MESSAGES/setroubleshoot.mo
Comment 9 Daniel Walsh 2012-03-13 09:26:26 EDT
I just created empty de_DE po files and pushed them to transifex,  So hopefully someone will translate.
Comment 10 Noriko Mizumoto 2012-03-13 09:39:55 EDT
Great news thanks, but I failed to yum update and unable to confirm.

Besides, I see translation completion dropped 98% from 100% for Japanese. It is good idea to give a notice to trans at list if this is string freeze break. So that all of translators will be aware and put their most effort to make it 100% back again.
Comment 11 Piotr Drąg 2012-03-13 09:42:50 EDT
de_DE is not a recognizable glibc locale. Please use de.po file, it should work. If not, then the bug is somewhere else.
Comment 12 Piotr Drąg 2012-03-13 09:49:42 EDT
Also eu_ES.po should be renamed to eu.po, and files bn_BD.po, cs_CZ.po, es_ES.po, fa_IR.po, ja_JP.po, lt_LT.po, ru_RU.po, ta_IN.po, vi_VN.po removed.
Comment 13 Daniel Walsh 2012-03-13 09:58:31 EDT
Is there a list of lanquages I should support?  Or a tool that I could execute within my configure/Makefiles to get this list.

Noriko, I ran update-po to get newer po files update, although I do not believe we have added any strings,  Not sure why the number dropped.  Only things I would be fixing at this point would be spelling/grammar mistakes.
Comment 14 Piotr Drąg 2012-03-13 10:23:57 EDT
(In reply to comment #13)
> Is there a list of lanquages I should support?  Or a tool that I could execute
> within my configure/Makefiles to get this list.
> 

I've tried to find a definitive list, but I've failed. You can use gtk+'s language list quite reliably:

http://git.gnome.org/browse/gtk+/tree/po/LINGUAS

(I'm not sure about az_IR and sr@ije codes as I have never seen them elsewhere, but the rest seems fine.)

> Noriko, I ran update-po to get newer po files update, although I do not believe
> we have added any strings,  Not sure why the number dropped.  Only things I
> would be fixing at this point would be spelling/grammar mistakes.

Any changes in strings, even the most minor ones, causes translations to be marked as fuzzy or untranslated.
Comment 15 Daniel Walsh 2012-03-13 11:17:22 EDT
Right, so the question is whether or not to ship with spelling or grammar mistakes, usually found by the translation team or fix them and break translations.
Comment 16 Noriko Mizumoto 2012-03-15 20:23:21 EDT
Thanks to Piotr, 'ja' is correct code to be pulled and others are same.
http://git.gnome.org/browse/gtk+/tree/po/LINGUAS

The matter is that there is no such strings reported above available to translate in provided POT/PO files...
https://fedora.transifex.net/projects/p/setroubleshoot/

Asking string freeze break in trans at list would usually get +1s, if it is reasonable.
Comment 17 The Old Man 2012-05-16 09:15:33 EDT
Still *a lot* of strings in English, though translated in Tx

One bug, bit OT here, but still ->

In SELinux Alert Browser, the buttons to browse alerts one by one have both 'volgende' in Dutch, meaning next.
This is *not* a translation error, left one should be 'previous' according to (untranslated, though translated in Tx) tip-tool, however, no singel word string 'previous' in Tx resources, must be in GUI-build code.
Comment 18 Daniel Walsh 2012-05-17 17:09:31 EDT
That previous button is a builtin button.  I am using glade with 
gtk-media-previous.  And I would have thought all of glade/gtk buttons have builtin translations?
Comment 19 Lijun Li 2012-07-09 05:03:13 EDT
The problem still exists in setroubleshoot-3.1.12-1.fc17.x86_64
Comment 20 Daniel Walsh 2012-07-25 13:42:58 EDT
I have finally figured this out and have checked in a fixed version into Rawhide.  Since then I found a couple of other problems, and fixed those, but now I need to wait for some translated strings to make sure it is working properly.  As soon as I have some and I am happy it is working, I will cut a new version for Fedora 17,Rawhide and RHEL6/RHEL7
Comment 21 Daniel Walsh 2012-07-25 13:43:41 EDT
BTW Fix is in setroubleshoot-3.1.14-1.fc18
Comment 22 Noriko Mizumoto 2013-04-11 22:03:28 EDT
During F19 L10N QA Test Day event, same problem has still been observed thus reported here. Now the version is reset to F19. If this needs to be filed in separate bug, please adivse.

F19 L10N QA Test Day 2013-04-11
setroubleshoot-3.2.4-1.fc19.x86_64
Comment 23 Daniel Walsh 2013-04-12 14:54:02 EDT
Noriko, please give me example? that you are currently seeing?
Comment 24 Noriko Mizumoto 2013-04-15 05:32:32 EDT
Created attachment 735851 [details]
partially not localized

Hi Daniel
Attached the screenshot taken. The strings not localized are same as reported with previous version.
Comment 25 Sweta Kothari 2013-04-19 05:15:18 EDT
Same issue for Gujarati (gu_IN).

The following strings have been translated in transfiex, but appears in English.
Please pull latest translation.

'Would you like to receive alerts?'
'Yes' and 'No'
'Troubleshoot'
'Notify/Admin'
'Detalis'
'Ignore'
'List All Alerts'
Comment 26 Ani Peter 2013-04-19 06:39:32 EDT
Created attachment 737564 [details]
Setroubleshoot for Malayalam (ml)

90% of setroubleshoot window in English.
Tested in setroubleshoot-3.2.5-1.fc19.x86_64

Thanks
Ani
Comment 27 Daniel Walsh 2013-04-19 11:16:25 EDT
Yes I am seeing this in all lanquages, although I am pretty sure nothing changed between F18 and F19.  Can someone check if this worked in F18?

Might be something has changed in the handling of glade?
Comment 28 Daniel Walsh 2013-04-19 11:26:31 EDT
Ok I found a fix.

 setroubleshoot-3.2.7-1.fc19
Comment 29 Fedora Update System 2013-04-19 11:35:27 EDT
setroubleshoot-3.2.7-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/setroubleshoot-3.2.7-1.fc19
Comment 30 Fedora Update System 2013-04-19 12:46:00 EDT
Package setroubleshoot-3.2.7-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing setroubleshoot-3.2.7-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6063/setroubleshoot-3.2.7-1.fc19
then log in and leave karma (feedback).
Comment 31 Fedora Update System 2013-04-20 15:49:25 EDT
Package setroubleshoot-3.2.8-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing setroubleshoot-3.2.8-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6063/setroubleshoot-3.2.8-1.fc19
then log in and leave karma (feedback).
Comment 32 Noriko Mizumoto 2013-05-01 00:38:34 EDT
Yum updated to setroubleshoot-3.2.8-1.fc19.x86_64.
Confirmed that the problem has been fixed, and the localized strings show up.

In order to make some translation to suit better in GUI, those have been modified in Transifex. It is much appreciated if you can pull latest file again and package.

Thanks a lot!
Comment 33 Fedora Update System 2013-05-02 00:32:56 EDT
setroubleshoot-3.2.8-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.