Bug 756107

Summary: [abrt] libreoffice-calc- ImplServerFontEntry::HandleFontOptions killed by signal 11 (SIGSEGV)
Product: [Fedora] Fedora Reporter: Milan Bouchet-Valat <nalimilan>
Component: libreofficeAssignee: Caolan McNamara <caolanm>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: caolanm, dtardon, erack, ltinkl, mstahl, sbergman
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:57d0b3dd178dfed1b874f3896d5a533ab1c261f7
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-01-10 09:38:21 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
File: dso_list
File: maps
File: backtrace
Document I was editing when the crash happened
PowerPoint 2007 file which is broken when editing masks none

Description Milan Bouchet-Valat 2011-11-22 12:22:55 EST
abrt version: 2.0.3
architecture:   x86_64
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/scalc.bin -calc file:///home/milan/Nanterre/Notes.ods
comment:        I tried starting Slideshow mode on a .pptx presentation I had just saved successfully.
component:      libreoffice
crash_function: ImplServerFontEntry::HandleFontOptions
executable:     /usr/lib64/libreoffice/program/scalc.bin
os_release:     Fedora release 15 (Lovelock)
package:        libreoffice-calc-
reason:         Process /usr/lib64/libreoffice/program/scalc.bin was killed by signal 11 (SIGSEGV)
time:           Tue Nov 22 18:04:54 2011
uid:            1000
username:       milan

backtrace:      Text file, 84251 bytes
dso_list:       Text file, 32260 bytes
maps:           Text file, 113081 bytes

:'LESSOPEN=||/usr/bin/lesspipe.sh %s'

:Nov 22 18:04:54 milan kernel: [459092.747610] scalc.bin[13779]: segfault at 0 ip           (null) sp 00007fffe1c81918 error 14 in scalc.bin[400000+2000]
:Nov 22 18:05:05 milan abrt[23444]: saved core dump of pid 13779 (/usr/lib64/libreoffice/program/scalc.bin) to /var/spool/abrt/ccpp-2011-11-22-18:04:54-13779.new/coredump (292696064 bytes)
Comment 1 Milan Bouchet-Valat 2011-11-22 12:23:01 EST
Created attachment 535127 [details]
File: dso_list
Comment 2 Milan Bouchet-Valat 2011-11-22 12:23:03 EST
Created attachment 535128 [details]
File: maps
Comment 3 Milan Bouchet-Valat 2011-11-22 12:23:06 EST
Created attachment 535129 [details]
File: backtrace
Comment 4 Caolan McNamara 2011-11-23 04:24:08 EST
crashing line is mpServerFont->SetFontOptions( mpFontOptions ); but we check for null mpServerFont earlier, so non trivial to see why this might crash.

Is there a particular document which crashed when you opened it ?, is so could you attach it here. i.e. the saved .pptx
Comment 5 Milan Bouchet-Valat 2011-11-23 07:22:32 EST
Created attachment 535454 [details]
Document I was editing when the crash happened

Here's the file, but the crash doesn't happen when I open it. It happened when I tried to show the slideshow.

I think something bigger was going on: the .pptx was looking good when I saved it (3 minutes after the crash), then the crash happened, and when I reopened it it was in the state you can see now. So the saved version doesn't contain what I was seeing when the crash happened.

The most interesting thing is that, before the crash, when I was editing slides masks, the fonts wouldn't change (size and family) on the screen. But they were changed in the background: after closing the masks, the slides had the correct font. The good news is, I'm able to reproduce that part of the problem: you just need to open the file I'm going to attach, and to edit the masks. That file comes from PowerPoint 2007.
Comment 6 Milan Bouchet-Valat 2011-11-23 07:23:15 EST
Created attachment 535456 [details]
PowerPoint 2007 file which is broken when editing masks
Comment 7 Caolan McNamara 2012-01-10 09:38:21 EST

*** This bug has been marked as a duplicate of bug 761009 ***