This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 756107 - [abrt] libreoffice-calc-3.3.3.1-7.fc15: ImplServerFontEntry::HandleFontOptions killed by signal 11 (SIGSEGV)
[abrt] libreoffice-calc-3.3.3.1-7.fc15: ImplServerFontEntry::HandleFontOption...
Status: CLOSED DUPLICATE of bug 761009
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:57d0b3dd178dfed1b874f3896d5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-22 12:22 EST by Milan Bouchet-Valat
Modified: 2012-01-10 09:38 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-10 09:38:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: dso_list (31.50 KB, text/plain)
2011-11-22 12:23 EST, Milan Bouchet-Valat
no flags Details
File: maps (110.43 KB, text/plain)
2011-11-22 12:23 EST, Milan Bouchet-Valat
no flags Details
File: backtrace (82.28 KB, text/plain)
2011-11-22 12:23 EST, Milan Bouchet-Valat
no flags Details
Document I was editing when the crash happened (13.28 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2011-11-23 07:22 EST, Milan Bouchet-Valat
no flags Details
PowerPoint 2007 file which is broken when editing masks (59.79 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2011-11-23 07:23 EST, Milan Bouchet-Valat
no flags Details

  None (edit)
Description Milan Bouchet-Valat 2011-11-22 12:22:55 EST
abrt version: 2.0.3
architecture:   x86_64
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/scalc.bin -calc file:///home/milan/Nanterre/Notes.ods
comment:        I tried starting Slideshow mode on a .pptx presentation I had just saved successfully.
component:      libreoffice
crash_function: ImplServerFontEntry::HandleFontOptions
executable:     /usr/lib64/libreoffice/program/scalc.bin
kernel:         2.6.38.5-22.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        libreoffice-calc-3.3.3.1-7.fc15
reason:         Process /usr/lib64/libreoffice/program/scalc.bin was killed by signal 11 (SIGSEGV)
time:           Tue Nov 22 18:04:54 2011
uid:            1000
username:       milan
xsession_errors: 

backtrace:      Text file, 84251 bytes
dso_list:       Text file, 32260 bytes
maps:           Text file, 113081 bytes

environ:
:ORBIT_SOCKETDIR=/tmp/orbit-milan
:XDG_SESSION_ID=1
:HOSTNAME=milan
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=13767
:GPG_AGENT_INFO=/tmp/keyring-wpZSIo/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=nautilus-13747-milan-libreoffice-0_TIME424434735
:HISTSIZE=1000
:XDG_SESSION_COOKIE=9e1782da896cc13ddd95ca060000000c-1320683997.445164-1978266012
:GJS_DEBUG_OUTPUT=stderr
:OLDPWD=/usr/lib64/libreoffice/program
:GNOME_KEYRING_CONTROL=/tmp/keyring-wpZSIo
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:USER=milan
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64
:SSH_AUTH_SOCK=/tmp/keyring-wpZSIo/ssh
:USERNAME=milan
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1379,unix/unix:/tmp/.ICE-unix/1379
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-calc.desktop
:MAIL=/var/spool/mail/milan
:PATH=/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/milan
:XMODIFIERS=@im=none
:KDE_IS_PRELINKED=1
:GNOME_KEYRING_PID=1371
:LANG=fr_FR.utf8
:GDM_LANG=fr_FR.utf8
:KDEDIRS=/usr
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/milan
:SHLVL=2
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=milan
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-5enxhtHI9J,guid=dfe06d5884d2861554d4f9b900000024
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/milan
:DISPLAY=:0.0
:G_BROKEN_FILENAMES=1
:XAUTHORITY=/var/run/gdm/auth-for-milan-k1bBjF/database
:_=/usr/lib64/libreoffice/program/scalc.bin

var_log_messages:
:Nov 22 18:04:54 milan kernel: [459092.747610] scalc.bin[13779]: segfault at 0 ip           (null) sp 00007fffe1c81918 error 14 in scalc.bin[400000+2000]
:Nov 22 18:05:05 milan abrt[23444]: saved core dump of pid 13779 (/usr/lib64/libreoffice/program/scalc.bin) to /var/spool/abrt/ccpp-2011-11-22-18:04:54-13779.new/coredump (292696064 bytes)
Comment 1 Milan Bouchet-Valat 2011-11-22 12:23:01 EST
Created attachment 535127 [details]
File: dso_list
Comment 2 Milan Bouchet-Valat 2011-11-22 12:23:03 EST
Created attachment 535128 [details]
File: maps
Comment 3 Milan Bouchet-Valat 2011-11-22 12:23:06 EST
Created attachment 535129 [details]
File: backtrace
Comment 4 Caolan McNamara 2011-11-23 04:24:08 EST
crashing line is mpServerFont->SetFontOptions( mpFontOptions ); but we check for null mpServerFont earlier, so non trivial to see why this might crash.

Is there a particular document which crashed when you opened it ?, is so could you attach it here. i.e. the saved .pptx
Comment 5 Milan Bouchet-Valat 2011-11-23 07:22:32 EST
Created attachment 535454 [details]
Document I was editing when the crash happened

Here's the file, but the crash doesn't happen when I open it. It happened when I tried to show the slideshow.

I think something bigger was going on: the .pptx was looking good when I saved it (3 minutes after the crash), then the crash happened, and when I reopened it it was in the state you can see now. So the saved version doesn't contain what I was seeing when the crash happened.

The most interesting thing is that, before the crash, when I was editing slides masks, the fonts wouldn't change (size and family) on the screen. But they were changed in the background: after closing the masks, the slides had the correct font. The good news is, I'm able to reproduce that part of the problem: you just need to open the file I'm going to attach, and to edit the masks. That file comes from PowerPoint 2007.
Comment 6 Milan Bouchet-Valat 2011-11-23 07:23:15 EST
Created attachment 535456 [details]
PowerPoint 2007 file which is broken when editing masks
Comment 7 Caolan McNamara 2012-01-10 09:38:21 EST

*** This bug has been marked as a duplicate of bug 761009 ***

Note You need to log in before you can comment on or make changes to this bug.