Bug 761009 - [abrt] libreoffice-core-3.4.4.2-3.fc16: X11SalGraphics::setFont: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.4.4.2-3.fc16: X11SalGraphics::setFont: Process /usr...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:b36138a9e81eafdf867b2363a08...
:
: 756107 761089 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-07 10:02 EST by Miloslav Trmač
Modified: 2012-01-10 09:38 EST (History)
7 users (show)

See Also:
Fixed In Version: libreoffice-3.4.4.2-6.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-23 17:22:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: dso_list (21.61 KB, text/plain)
2011-12-07 10:02 EST, Miloslav Trmač
no flags Details
File: environ (3.11 KB, text/plain)
2011-12-07 10:02 EST, Miloslav Trmač
no flags Details
File: backtrace (92.09 KB, text/plain)
2011-12-07 10:02 EST, Miloslav Trmač
no flags Details
File: maps (81.86 KB, text/plain)
2011-12-07 10:02 EST, Miloslav Trmač
no flags Details
The relevant files (1.61 MB, application/octet-stream)
2011-12-07 11:19 EST, Miloslav Trmač
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 766153 None None None Never
Launchpad 892904 None None None Never

  None (edit)
Description Miloslav Trmač 2011-12-07 10:02:33 EST
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --impress IV054/CRYPTO0901.ppt IV054/CRYPTO0902.ppt IV054/CRYPTO0903.ppt IV054/CRYPTO0904.ppt IV054/CRYPTO0905.ppt IV054/CRYPTO0906.ppt IV054/CRYPTO0907.ppt IV054/CRYPTO0908.ppt IV054/CRYPTO0909.ppt IV054/CRYPTO0910.ppt IV054/CRYPTO0911a.ppt IV054/CRYPTO0912.ppt IV054/CRYPTO0914.ppt --splash-pipe=7
comment:        Specified 13 ppt files to open on the command line
crash_function: X11SalGraphics::setFont
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.1.4-1.fc16.x86_64
pid:            10780
pwd:            /home/mitr/rh/prednasky
reason:         Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
time:           St 7. prosinec 2011, 15:46:10 CET
uid:            1000
username:       mitr

backtrace:      Text file, 94296 bytes
dso_list:       Text file, 22127 bytes
environ:        Text file, 3181 bytes
maps:           Text file, 83821 bytes

var_log_messages:
:Dec  7 15:46:10 kulicka kernel: [17401.297261] soffice.bin[10780]: segfault at 10 ip 00007f1edb47a37b sp 00007fff28162a40 error 4 in libvclplug_genlx.so[7f1edb3ee000+d6000]
:Dec  7 15:46:15 kulicka abrt[10843]: Saved core dump of pid 10780 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2011-12-07-15:46:10-10780 (275402752 bytes)
Comment 1 Miloslav Trmač 2011-12-07 10:02:37 EST
Created attachment 541989 [details]
File: dso_list
Comment 2 Miloslav Trmač 2011-12-07 10:02:39 EST
Created attachment 541990 [details]
File: environ
Comment 3 Miloslav Trmač 2011-12-07 10:02:41 EST
Created attachment 541991 [details]
File: backtrace
Comment 4 Miloslav Trmač 2011-12-07 10:02:43 EST
Created attachment 541992 [details]
File: maps
Comment 5 Miloslav Trmač 2011-12-07 10:35:47 EST
Package: libreoffice-core-3.4.4.2-3.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
?????????????????
Comment 6 Caolan McNamara 2011-12-07 11:04:15 EST
If you can reproduce it, please attach a reproducer. Looks like the kind of thing that needs a good valgrinding
Comment 7 Miloslav Trmač 2011-12-07 11:19:16 EST
Created attachment 542027 [details]
The relevant files

In two tries, ooimpress didn't crash again just by running it with the above command line.

However, in both cases it crashed using this procedure:
1. Focus the main slide pane.
2. Hold down Page Down until the last slide is displayed or the program crashes
3. If it didn't crash, close the current file using Ctrl-W and go to 1.

The behavior is somewhat random (once it crashed on the first file, once it crashed on the 2nd or third), but it crashes often enough.
Comment 8 Caolan McNamara 2011-12-09 07:16:18 EST
*** Bug 761089 has been marked as a duplicate of this bug. ***
Comment 9 Caolan McNamara 2011-12-09 07:41:28 EST
refuses to crash for me. will try valgrind
Comment 10 Caolan McNamara 2011-12-09 11:24:30 EST
Apparently a deleted font is getting handed back out from the font cache, annoying
Comment 12 Miloslav Trmač 2011-12-13 21:03:35 EST
Thanks!
Comment 13 Fedora Update System 2011-12-15 15:43:11 EST
libreoffice-3.4.4.2-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libreoffice-3.4.4.2-6.fc16
Comment 14 Fedora Update System 2011-12-16 14:59:13 EST
Package libreoffice-3.4.4.2-6.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.4.4.2-6.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-17186/libreoffice-3.4.4.2-6.fc16
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2011-12-23 17:22:17 EST
libreoffice-3.4.4.2-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Caolan McNamara 2012-01-10 09:38:21 EST
*** Bug 756107 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.