Bug 759063

Summary: [abrt] kernel: WARNING: at net/ipv4/tcp.c:1485 tcp_recvmsg+0x1bb/0x7f1()
Product: [Fedora] Fedora Reporter: Alexander Ploumistos <alex.ploumistos>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Unspecified   
Whiteboard: abrt_hash:798daae2435642e428951740ffcfb6bab447e775
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-03-01 10:54:15 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
File: smolt_data none

Description Alexander Ploumistos 2011-12-01 06:08:39 EST
libreport version: 2.0.7
abrt_version:   2.0.6
cmdline:        BOOT_IMAGE=/vmlinuz-3.1.2-1.fc16.i686 root=UUID=0b262248-e7bc-4e03-800a-1d058450b2f9 ro rd.md=0 rd.lvm=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8
comment:        I think the culprit is the nohwcrypt option I used for ath5k while trying to diagnose another problem, see bug 758543.
kernel:         3.1.2-1.fc16.i686
reason:         WARNING: at net/ipv4/tcp.c:1485 tcp_recvmsg+0x1bb/0x7f1()
time:           Thu 01 Dec 2011 12:36:21 PM EET

smolt_data:     Text file, 2818 bytes

backtrace:
:WARNING: at net/ipv4/tcp.c:1485 tcp_recvmsg+0x1bb/0x7f1()
:Hardware name: AOA150
:recvmsg bug: copied 20E0CB5F seq 20E0D0FF rcvnxt 20E7A65F fl 0
:Modules linked in: ppdev parport_pc lp parport fuse fcoe libfcoe libfc scsi_transport_fc scsi_tgt 8021q garp stp llc nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack coretemp xts gf128mul dm_crypt snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm r8169 snd_timer arc4 iTCO_wdt iTCO_vendor_support snd soundcore uvcvideo i2c_i801 videodev ath5k ath mac80211 sparse_keymap cfg80211 rfkill acerhdf microcode uinput serio_raw snd_page_alloc mii media joydev wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 1952, comm: wget Tainted: G        W   3.1.2-1.fc16.i686 #1
:Call Trace:
: [<c043c919>] warn_slowpath_common+0x7c/0x91
: [<c077ef73>] ? tcp_recvmsg+0x1bb/0x7f1
: [<c077ef73>] ? tcp_recvmsg+0x1bb/0x7f1
: [<c043c9b9>] warn_slowpath_fmt+0x33/0x35
: [<c077ef73>] tcp_recvmsg+0x1bb/0x7f1
: [<c079724b>] inet_recvmsg+0x56/0x68
: [<c0741051>] sock_aio_read+0xf6/0xfe
: [<c04eb01a>] do_sync_read+0x96/0xcf
: [<c04eb366>] ? rw_verify_area+0xd0/0xf3
: [<c04f8018>] ? poll_select_copy_remaining+0xba/0xd6
: [<c04eb6da>] vfs_read+0x94/0xd5
: [<c04eb75d>] sys_read+0x42/0x63
: [<c0811e1c>] syscall_call+0x7/0xb
: [<c081007b>] ? ipv6_hdr_cmp+0x3c/0x42
Comment 1 Alexander Ploumistos 2011-12-01 06:08:43 EST
Created attachment 539084 [details]
File: smolt_data
Comment 2 Josh Boyer 2011-12-01 07:45:41 EST
*** Bug 759068 has been marked as a duplicate of this bug. ***
Comment 3 Josh Boyer 2011-12-01 07:45:50 EST
*** Bug 759066 has been marked as a duplicate of this bug. ***
Comment 4 Dave Jones 2012-02-06 13:19:32 EST
Alex, have you been able to reproduce this on the current kernel updates ?
Comment 5 Alexander Ploumistos 2012-02-06 15:07:14 EST
I haven't tried the nohwcrypt option with any of the 3.2.x kernels, but I did get the same message with the last couple of 3.1.x kernels.

The thing is I should not need to use nohwcrypt, as my wireless adapter is not listed on the known bugs list among those affected, nor did I have any such problems with any of the 2.6 kernels ever since ath5k was first deployed.

Would you like me to test again?
Comment 6 Josh Boyer 2012-03-01 10:54:15 EST
(In reply to comment #5)
> I haven't tried the nohwcrypt option with any of the 3.2.x kernels, but I did
> get the same message with the last couple of 3.1.x kernels.
> 
> The thing is I should not need to use nohwcrypt, as my wireless adapter is not
> listed on the known bugs list among those affected, nor did I have any such
> problems with any of the 2.6 kernels ever since ath5k was first deployed.
> 
> Would you like me to test again?

It seems like your actually issues are being tracked in bug 758543 and being worked on as you said.  Lets close this out and if you see it again on a 3.2 kernel we'll get a new report.