Bug 768562

Summary: TurboGears2 quickstart creates a dep on repoze.who that cannot be satisfied in Fedora
Product: [Fedora] Fedora Reporter: Toshio Ernie Kuratomi <a.badger>
Component: TurboGears2Assignee: Luke Macken <lmacken>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: a.badger, dmalcolm, lmacken, pfrields
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-11 17:30:49 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Toshio Ernie Kuratomi 2011-12-16 21:28:01 EST
Description of problem:
A fresh paster quickstart on Fedora 16 creates a quickstart project which requirs a version of repoze.who that is not available in Fedora.

Version-Release number of selected component (if applicable):
TurboGears2-2.1.1-1.fc16.noarch

How reproducible:
Everytime

Steps to Reproduce:
1. paster quickstart tester
2. say yes to authorization
3. check what's in tester/tester*egg*/requires.txt
  
Actual results:

there will be an entry for repoze.who==1.0.19

Expected results:

an entry for a repoze.who that we ship in fedora 16.

Additional info:

Contents of requires.txt:

TurboGears2 >= 2.1.1
Mako
zope.sqlalchemy >= 0.4
repoze.tm2 >= 1.0a5
sqlalchemy
sqlalchemy-migrate
repoze.what-quickstart
repoze.what >= 1.0.8
repoze.what-quickstart
repoze.who-friendlyform >= 1.0.4
repoze.what-pylons >= 1.0
repoze.what.plugins.sql
repoze.who==1.0.19
tgext.admin >= 0.3.9
tw.forms

We could either upgrade repoze.who or patch the version requirement in TurboGears2.
Comment 1 Luke Macken 2013-01-11 17:30:49 EST

*** This bug has been marked as a duplicate of bug 759142 ***