This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 768562 - TurboGears2 quickstart creates a dep on repoze.who that cannot be satisfied in Fedora
TurboGears2 quickstart creates a dep on repoze.who that cannot be satisfied i...
Status: CLOSED DUPLICATE of bug 759142
Product: Fedora
Classification: Fedora
Component: TurboGears2 (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-16 21:28 EST by Toshio Ernie Kuratomi
Modified: 2013-01-11 17:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-11 17:30:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Toshio Ernie Kuratomi 2011-12-16 21:28:01 EST
Description of problem:
A fresh paster quickstart on Fedora 16 creates a quickstart project which requirs a version of repoze.who that is not available in Fedora.

Version-Release number of selected component (if applicable):
TurboGears2-2.1.1-1.fc16.noarch

How reproducible:
Everytime

Steps to Reproduce:
1. paster quickstart tester
2. say yes to authorization
3. check what's in tester/tester*egg*/requires.txt
  
Actual results:

there will be an entry for repoze.who==1.0.19

Expected results:

an entry for a repoze.who that we ship in fedora 16.

Additional info:

Contents of requires.txt:

TurboGears2 >= 2.1.1
Mako
zope.sqlalchemy >= 0.4
repoze.tm2 >= 1.0a5
sqlalchemy
sqlalchemy-migrate
repoze.what-quickstart
repoze.what >= 1.0.8
repoze.what-quickstart
repoze.who-friendlyform >= 1.0.4
repoze.what-pylons >= 1.0
repoze.what.plugins.sql
repoze.who==1.0.19
tgext.admin >= 0.3.9
tw.forms

We could either upgrade repoze.who or patch the version requirement in TurboGears2.
Comment 1 Luke Macken 2013-01-11 17:30:49 EST

*** This bug has been marked as a duplicate of bug 759142 ***

Note You need to log in before you can comment on or make changes to this bug.