Bug 810141

Summary: KeyError: 'fstypeCombo'
Product: [Fedora] Fedora Reporter: Miroslav Franc <mfranc>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 17CC: anaconda-maint-list, awilliam, cristian.ciupitu, gareth.k.jones, g.kaviyarasu, jonathan, lkocman, ohudlick, roysjosh, sam, vanmeeuwen+fedora, vondruch
Target Milestone: ---Keywords: CommonBugs
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:6466520264f49628e15d86921cb0f066a75141f7512c65ee1a1a7f7b1a20ad18 AcceptedNTH https://fedoraproject.org/wiki/Common_F17_bugs#anaconda-btrfs-crash
Fixed In Version: anaconda-18.3 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-03 15:44:31 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 752653    
Attachments:
Description Flags
File: anaconda-tb-u1xvMg none

Description Miroslav Franc 2012-04-05 05:19:20 EDT
libreport version: 2.0.10
cmdline:        /usr/bin/python  /usr/sbin/anaconda
executable:     /usr/sbin/anaconda
exnFileName:    /tmp/anaconda-tb-u1xvMg
hashmarkername: anaconda
kernel:         3.3.0-1.fc17.x86_64
other involved packages: 
product:        Fedora
release:        Cannot get release name.
time:           Thu 05 Apr 2012 11:15:42 AM CEST
version:        17-Beta

anaconda-tb-u1xvMg: Text file, 669192 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.18 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/lvm_dialog_gui.py", line 605, in editLogicalVolume
:    fmt_class = self.fsoptionsDict["fstypeCombo"].get_active_value()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1805, in editLVMLogicalVolume
:    vgeditor.editLogicalVolume(lv, isNew = isNew)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1668, in editCB
:    self.editLVMLogicalVolume(lv = device)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1195, in treeActivateCB
:    self.editCB()
:KeyError: 'fstypeCombo'
:
:
:I had f15, tried to install f17. Upon changing already existing logical volume to be mounted as /home, I recieved this traceback.

environ:
:LANG=en_US.UTF-8
:LC_NUMERIC=C
:TERM=linux
:BOOT_IMAGE=vmlinuz
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=0
:PYTHONPATH=/tmp/updates
:PWD=/
:GNOME_DISABLE_CRASH_DIALOG=1
:LIBUSER_CONF=/tmp/libuser.G6LaDm
:LVM_SUPPRESS_FD_WARNINGS=1
:initrd=initrd.img
:MALLOC_PERTURB_=204
:TZ=Europe/Prague
:GCONF_GLOBAL_LOCKS=1
:HOME=/tmp
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:PATH=/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:MALLOC_CHECK_=2
:DISPLAY=:1
Comment 1 Miroslav Franc 2012-04-05 05:19:27 EDT
Created attachment 575336 [details]
File: anaconda-tb-u1xvMg
Comment 2 Chris Lumens 2012-04-05 09:45:00 EDT
*** Bug 810154 has been marked as a duplicate of this bug. ***
Comment 3 Lubos Kocman 2012-04-10 01:58:38 EDT
The same thing happened to me with btrfs (done manually as there is no combo box option for btrfs)
Comment 4 Vít Ondruch 2012-04-20 06:19:02 EDT
Proposing as NTH for F17, since this is rather silly bug. BTRFS was supposed to be default FS for F17, but now, F17 is not possible to install on BTRFS at all.
Comment 5 Adam Williamson 2012-05-04 13:26:46 EDT
Discussed at 2012-05-04 NTH review meeting. Accepted as NTH as it's a clear visible anaconda bug with concrete consequences and can't be fixed with an update. Might even be considered a blocker.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Adam Williamson 2012-05-21 17:27:27 EDT
This isn't fixed in current RC, so let's commonbugs it at least. AIUI this happens if you try to edit an exist btrfs partition in the custom partitioning editor.
Comment 7 David Lehman 2012-05-21 17:36:19 EDT
(In reply to comment #4)
> Proposing as NTH for F17, since this is rather silly bug. BTRFS was supposed
> to be default FS for F17, but now, F17 is not possible to install on BTRFS
> at all.

The way to install with btrfs in F17 is to use kickstart:

  https://fedoraproject.org/wiki/Anaconda/Kickstart#btrfs
Comment 8 Sam Kingston 2012-05-30 01:07:41 EDT
This used to work with F16, how come the regression in F17?
Comment 9 Adam Williamson 2012-05-30 21:24:02 EDT
http://forums.theregister.co.uk/post/1427114 (I happened to write a detailed explanation earlier, figured I'd re-use it).
Comment 10 Sam Kingston 2012-05-30 21:48:05 EDT
(In reply to comment #9)
> http://forums.theregister.co.uk/post/1427114 (I happened to write a detailed
> explanation earlier, figured I'd re-use it).

Thanks Adam, that's quite informative. Strange that the "back-end" code was merged without the corresponding UI changes..

Am I correct in assuming the best way to install onto btrfs in f17 would be to manually set up the partitioning/volumes, install f16, and do an upgrade?
Comment 11 Adam Williamson 2012-05-30 22:08:19 EDT
You could just install F16 and use its btrfs to set up the partitioning/volumes (unless you want to use btrfs' native volume support rather than LVM), but sure. Or you can use a kickstart to install F17 with btrfs partitions.
Comment 12 Joshua Roys 2012-05-31 09:52:37 EDT
*** Bug 826805 has been marked as a duplicate of this bug. ***
Comment 13 Gareth Jones 2012-06-02 18:57:49 EDT
Is it possible to use Kickstart to install F17 on an *existing* Btrfs-RAID?  I'm trying to use kickstart with lines like:

    # Encrypted mirrored /home.
    part btrfs.home1 --noformat --encrypted --fstype=btrfs --onpart=sda6
    part btrfs.home2 --noformat --encrypted --fstype=btrfs --onpart=sdb4
    btrfs /home --noformat btrfs.home1 btrfs.home2

I get an Ananconda error on the first btrfs line that reads "... specified nonexistant BTRFS volume  in btrfs command", with a double space between "volume" and "in" as if something is missing.  The volumes are definitely formatted though.

(Sorry if it's inappropriate to ask that here, but I haven't had any luck searching elsewhere and most relevent pages link back here, so if there is a problem it might help other people as well!)
Comment 14 Chris Lumens 2012-08-03 15:44:31 EDT
The code this bug resulted from is no longer present as of anaconda-18.3.  Please test with F18 and if you see similar problems, open a new bug.  Thanks.