Bug 815156

Summary: qemu-common update re-enabled ksm and ksmtuned which I had disabled
Product: [Fedora] Fedora Reporter: Tom Horsley <horsley1953>
Component: qemuAssignee: Fedora Virtualization Maintainers <virt-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: amit.shah, berrange, cfergeau, crobinso, dwmw2, itamar, knoel, liebundartig, pbonzini, rh-bugzilla, scottt.tw, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-09 18:59:27 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tom Horsley 2012-04-22 20:11:32 EDT
Description of problem:

I have loads of memory and few virtual machines. I have no need for ksm and
ksmtuned services wasting time trying to optimize something that I don't need
optimized, so I disabled both these services.

I just got a new update of the qemu-common package, and it seems to
have explicitly re-enabled these services which I had turned off. It should
leave them in the state the system administrator set them to.


Version-Release number of selected component (if applicable):
qemu-common-1.0-15.fc17.x86_64

How reproducible:
I only did the update once, but I have no reason to believe it wouldn't do
it again.

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
services re-enabled that I had explicitly disabled.

Expected results:
leave my system configuration alone.

Additional info:
Comment 1 Paolo Bonzini 2012-04-23 04:03:00 EDT
This is probably due to conversion to systemd.

The question is not whether it would do the same again on the same update, but whether it will do it on the next update.

What version were you running before?  Assuming it was 0.15.0-6 or earlier, please try downgrading to 1.0-12.fc17 and then upgrading again to 1.0-15.fc17.
Comment 2 Tom Horsley 2012-04-23 05:26:07 EDT
The ksm.service and ksmtuned.service were already systemd controlled when I first turned them off. The previous version of qemu-common on my system was from an update back on Apr 18:

Apr 18 17:54:52 Updated: 2:qemu-common-1.0-11.fc17.x86_64
Comment 3 Tom Horsley 2012-04-24 19:03:39 EDT
And the new qemu-common update I just got today (qemu-common-1.0-17.fc17.x86_64)
has re-enabled the ksm and ksmtuned services yet again, so it does indeed appear to happen every time.
Comment 4 Cole Robinson 2012-07-10 07:57:46 EDT
*** Bug 827942 has been marked as a duplicate of this bug. ***
Comment 5 Tom Horsley 2012-07-29 13:16:44 EDT
Just to continue the data collection, the latest update just re-enabled
the ksm services again:

qemu-common-1.0-18.fc17.x86_64
Comment 6 Cole Robinson 2012-07-29 18:18:31 EDT
*** Bug 786920 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2012-07-30 07:24:53 EDT
qemu-1.0.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/qemu-1.0.1-1.fc17
Comment 8 Fedora Update System 2012-07-30 18:28:30 EDT
Package qemu-1.0.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-1.0.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11302/qemu-1.0.1-1.fc17
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-08-01 14:46:59 EDT
qemu-0.15.1-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-11305/qemu-0.15.1-7.fc16
Comment 10 Fedora Update System 2012-08-01 14:50:35 EDT
qemu-0.15.1-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-11305/qemu-0.15.1-7.fc16
Comment 11 Fedora Update System 2012-08-09 18:59:27 EDT
qemu-0.15.1-7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-08-09 19:01:26 EDT
qemu-1.0.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.