This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 817298

Summary: ipw2x00: backport patch for nl80211 cipher suite reporting
Product: [Fedora] Fedora Reporter: Dan Williams <dcbw>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: awilliam, danw, dcbw, fedora, gansalmon, itamar, jonathan, kernel-maint, kparal, madhu.chinakonda, mads, mihkel, mishu, robatino, sgruszka, tflink
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedNTH RejectedBlocker
Fixed In Version: kernel-2.6.43.5-2.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 815331 Environment:
Last Closed: 2012-05-04 18:50:31 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 815331    
Bug Blocks: 752653    

Description Dan Williams 2012-04-28 14:46:31 EDT
+++ This bug was initially created as a clone of Bug #815331 +++

Created attachment 579506 [details]
NM applet

Description of problem:
In Fallback Mode all the encrypted wifi networks are greyed out and you can't click on them, therefore you can't connect. See screenshot. In gnome-shell mode it works.

Version-Release number of selected component (if applicable):
NetworkManager-0.9.4.0-6.git20120403.fc17.i686
NetworkManager-glib-0.9.4.0-6.git20120403.fc17.i686
NetworkManager-gnome-0.9.4.0-6.git20120403.fc17.i686
NetworkManager-gtk-0.9.4.0-6.git20120403.fc17.i686
NetworkManager-openconnect-0.9.3.997-1.fc17.i686
NetworkManager-openvpn-0.9.3.997-1.fc17.i686
NetworkManager-pptp-0.9.3.997-1.fc17.i686
NetworkManager-vpnc-0.9.3.997-1.fc17.i686


How reproducible:
I logged out and in, I pushed wifi switch on and off, still broken

--- Additional comment from kparal@redhat.com on 2012-04-23 07:53:08 EDT ---

Proposing as F17 Blocker, it fails criteria requiring network access.

--- Additional comment from mihkel@punga.ee on 2012-04-24 05:00:04 EDT ---

Similar behavior of NM in LXDE spin - all WPA networks are grayed out.
WEP networks seem selectable.

Manually adding WPA2 wireless network works (automatic reconnection afterwards and everything ok). 

NetworkManager-0.9.4.0-6.git20120403.fc17.i686
(ipw2200)

--- Additional comment from kparal@redhat.com on 2012-04-24 06:48:07 EDT ---

I have to note I also use ipw2200 driver (using fixed kernel provided in bug 802106 comment 20). Maybe it can be related.

--- Additional comment from mihkel@punga.ee on 2012-04-24 09:31:44 EDT ---

yes indeed! I've connected an old external wireless adapter to the same machine (pcmcia rt2500pci) and NM works as expected - i.e. WPA networks are visible and clickable and configured correctly by NM.

(except network is not connected on boot - I have to right-click NM to disable/enable wireless to have NM connect to saved network...)

1 more thing I noticed now - NM shows no Signal Strength bars nor connection speed with ipw2200 driver (iwconfig shows all these).
(and signal bars missing with aforementioned "test-ipw2200.fc16" and F17 kernel both).

--- Additional comment from kparal@redhat.com on 2012-04-24 09:45:16 EDT ---

I can confirm that a colleague of mine who has a different wifi card model has no problem connecting to WPA networks in the fallback mode, menu items are not greyed out. This bug seems to be affected by just ipw2200 (and maybe some more) models.

--- Additional comment from danw@redhat.com on 2012-04-24 12:30:07 EDT ---

Appears to be a kernel driver bug, and an update has already been submitted.

*** This bug has been marked as a duplicate of bug 802106 ***

--- Additional comment from kparal@redhat.com on 2012-04-25 05:03:37 EDT ---

No, reopening. I was using the fixed kernel from bug 802106 comment 20. This is not a duplicate. Maybe it's another bug in ipw2200 driver. But it doesn't appear in gnome shell, just in fallback mode, that's suspicious.

--- Additional comment from danw@redhat.com on 2012-04-27 11:38:28 EDT ---

(In reply to comment #7)
> it doesn't
> appear in gnome shell, just in fallback mode, that's suspicious.

Hm... it appears that nm-applet does some sanity-checking that gnome-shell doesn't do; nm-applet will gray out the network if your wireless card claims that it doesn't support the given encryption type.

what does

  nmcli dev list | grep WIFI-PROPERTIES

output? (If you have multiple wifi cards, do "nmcli dev list iface WHATEVER" to only list the properties of the ipw2200 card.)

--- Additional comment from dcbw@redhat.com on 2012-04-28 12:29:11 EDT ---

*** Bug 817147 has been marked as a duplicate of this bug. ***

--- Additional comment from dcbw@redhat.com on 2012-04-28 14:34:51 EDT ---

FYI I cannot reproduce the issue in Fallback mode with latest git NM on F15 using kernel 2.6.42.12.  The only machine I have that's capable of using an ipw2200 is only running F15.

The only thing that I can see causing this is improper device capabilities that the kernel provides.  That ipw2200 bug got fixed in the upstream kernel by the following patch:

http://www.spinics.net/lists/linux-wireless/msg88069.html

which needs to be backported to the affected kernels.  The suggested "nmcli dev list | grep WIFI-PROPERTIES" info would tell us whether that's the case or not.
Comment 1 Dan Williams 2012-04-28 14:48:00 EDT
Basically when nl80211 support got added to ipw2x00, cipher suite reporting failed to be added to the driver, which means it reports that it doesn't support any encryption to any nl80211 clients, like NetworkManager.

http://www.spinics.net/lists/linux-wireless/msg88069.html
Comment 2 Josh Boyer 2012-04-30 12:12:00 EDT
Stanislaw, does that look correct to you?
Comment 3 Stanislaw Gruszka 2012-04-30 12:44:57 EDT
Yes, ACK for patch.
Comment 4 Dan Williams 2012-04-30 13:31:37 EDT
*** Bug 815331 has been marked as a duplicate of this bug. ***
Comment 5 Josh Boyer 2012-04-30 15:29:56 EDT
Applied to F15-rawhide.
Comment 6 Kamil Páral 2012-05-02 07:01:37 EDT
Which kernel build should fix this?
Comment 7 Josh Boyer 2012-05-02 07:23:16 EDT
(In reply to comment #6)
> Which kernel build should fix this?

It hasn't been built yet.  Bodhi will leave a comment here when it's submitted as an update, as usual.
Comment 8 Fedora Update System 2012-05-02 18:11:34 EDT
kernel-3.3.4-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.3.4-3.fc17
Comment 9 Tim Flink 2012-05-03 10:45:41 EDT
This may be useless data now that there's a fix but I'll add it anyways. I got ahold of a smolt snapshot from a couple of weeks ago with the intention of getting some numbers for the number of ipw2200 devices out there.

F15
 268000 installs in SMOLT
 3516 installs listing a device using the ipw2200 driver

F16
 225490 installs in SMOLT
 2544 installs listing a device using the ipw2200 driver

Keep in mind that I'm not making any attempts at de-duplication of machines for these numbers. There are most certainly duplicate machines in smolt so take these numbers with a grain of salt.
Comment 10 Fedora Update System 2012-05-03 12:00:45 EDT
Package kernel-3.3.4-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.3.4-3.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7212/kernel-3.3.4-3.fc17
then log in and leave karma (feedback).
Comment 11 Adam Williamson 2012-05-03 14:25:49 EDT
Discussed at 2012-05-03 blocker review meeting. Rejected as a blocker: this only affects a fairly small amount of hardware (tflink calculated approx 1% of all installs, see comment #9), and only in fallback mode we believe. Accepted as NTH.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Fedora Update System 2012-05-03 17:59:13 EDT
kernel-3.3.4-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.3.4-3.fc16
Comment 13 Fedora Update System 2012-05-04 18:50:31 EDT
kernel-3.3.4-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Amazed 2012-05-05 10:30:45 EDT
I am now experiencing essentially the same problem in Fedora 16, using Xfce4.  Evidentally, this was not a problem confined to Gnome fallback mode.  I await kernel-3.3.4-3.fc16.
Comment 15 Fedora Update System 2012-05-05 21:27:56 EDT
kernel-3.3.4-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2012-05-08 16:57:31 EDT
kernel-2.6.43.5-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.43.5-2.fc15
Comment 17 Adam Williamson 2012-05-08 21:21:25 EDT
amazed: it would perhaps have been better to say 'not Shell' than 'only fallback'. anything that uses nm-applet would be affected, so probably fallback, lxde and xfce (but not shell or KDE).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 18 Fedora Update System 2012-05-15 19:23:43 EDT
kernel-2.6.43.5-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.