Bug 802106 - ipw2200 bg doesn't work in f17
ipw2200 bg doesn't work in f17
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
AcceptedNTH
:
: 811272 (view as bug list)
Depends On:
Blocks: F17Blocker/F17FinalBlocker F17Beta-accepted/F17BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-03-11 06:17 EDT by Mads Kiilerich
Modified: 2012-04-28 20:58 EDT (History)
20 users (show)

See Also:
Fixed In Version: kernel-3.3.4-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-28 20:58:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg (66.89 KB, text/plain)
2012-03-11 06:17 EDT, Mads Kiilerich
no flags Details
dmesg with debug (86.38 KB, text/plain)
2012-03-13 06:41 EDT, Mads Kiilerich
no flags Details
dmesg with -debug kernel (97.33 KB, text/plain)
2012-03-13 09:34 EDT, Mads Kiilerich
no flags Details
dmesg with -debug kernel and debug=0xff (104.24 KB, text/plain)
2012-03-13 11:32 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2012-03-11 06:17:03 EDT
Created attachment 569171 [details]
dmesg

Wireless on D510 doesn't work with f17 fully updated to -testing and kernel-PAE-3.3.0-0.rc6.git0.2.fc17.i686

[   15.584519] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
[   15.584524] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[   15.584706] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
[   45.475702] ipw2200: Failed to send TX_POWER: Already sending a command.
[   45.599030] ipw2200: Failed to send TX_POWER: Already sending a command.
[   45.721433] ipw2200: Failed to send TX_POWER: Already sending a command.
[   45.843648] ipw2200: Failed to send TX_POWER: Already sending a command.
[   45.965830] ipw2200: Failed to send TX_POWER: Already sending a command.
[   45.967390] ipw2200: Unable to initialize device after 5 attempts.
[   45.968907] ipw2200: failed to register network device
[   45.990126] ipw2200: probe of 0000:02:03.0 failed with error -5

after rmmod and modprobe it works and says

[  152.844468] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
[  152.844474] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[  152.844660] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
[  152.979315] ipw2200: Detected geography ZZD (13 802.11bg channels, 0 802.11a channels)

This machine used to work without any problems on f16.

http://www.smolts.org/client/show/pub_0ee17054-39dd-440a-8a15-98109cec9d28
Intel Corporation PRO/Wireless 2200BG Network Connection
Comment 1 Stanislaw Gruszka 2012-03-13 02:44:05 EDT
Please install kernel-debug on f17, and reload module with debug option

modprobe -r ipw2200
modprobe ipw2200 debug=0xff

and attach dmesg with debug messages.
Comment 2 Mads Kiilerich 2012-03-13 06:41:39 EDT
Created attachment 569633 [details]
dmesg with debug
Comment 3 Stanislaw Gruszka 2012-03-13 09:05:26 EDT
Please install kernel-debug first and boot into that kernel, otherwise module debug option has no effect.
Comment 4 Mads Kiilerich 2012-03-13 09:34:54 EDT
Created attachment 569682 [details]
dmesg with -debug kernel

Right, I was somehow tricked by -debug not being PAE ...

I can however not spot any relevant extra debug info when using the debug kernel.
Comment 5 Stanislaw Gruszka 2012-03-13 10:14:28 EDT
Debug info is there, at the end of dmesg after modprobe was done.

However seems that after module reload things went fine and we successfully associate, hmm wtf?

Let's increase debug verbosity and load module at start with debug option. To do this, proper line in modprobe config need to be added i.e:

echo "options ipw2200 debug=0xffffffff" >> /etc/modprobe.d/ipw2200.conf

Then pleas restart the system and attach dmesg again.
Comment 6 Mads Kiilerich 2012-03-13 11:32:23 EDT
Created attachment 569703 [details]
dmesg with -debug kernel and debug=0xff

I assume you meant debug=0xff, also in the modprobe configuration.

I guess the problem is related to the
ipw2200: Failed to send TX_POWER: Already sending a command.
messages, as if it starts probing too early.
Comment 7 Kamil Páral 2012-03-14 10:23:48 EDT
I have exactly the same problem. This is my Smolt profile:
http://www.smolts.org/client/show/pub_16f9c1c8-57a3-4340-ab63-bbcd234b4983

After googling a bit, this problem might be related to udev and it seems to effect number of people:

https://bbs.archlinux.org/viewtopic.php?id=134276
https://bbs.archlinux.org/viewtopic.php?pid=1046225#p1046225
https://bugs.archlinux.org/task/28097
https://bugs.archlinux.org/task/27938
Comment 8 Kamil Páral 2012-03-15 04:31:23 EDT
Proposing as F17Beta or F17Final blocker. All the networking criteria are broken. OTOH it can be worked around by using cable connection (provided that your hardware has ethernet card and you have the cable available).

We should probably make a guess how much widespread this wifi card is.
Comment 9 Mads Kiilerich 2012-03-15 06:35:45 EDT
(In reply to comment #8)
Another simple workaround for me is
  sudo rmmod ipw2200
  sudo modprobe ipw2200
Comment 10 Stanislaw Gruszka 2012-03-15 07:06:10 EDT
I still can not understand from debug messages how this problem happen. However, since modules reload help, it must be problem is caused by udev firmware loading changes. We need a ipw2x00 patch that change driver to use asynchronous firmware load like described in F-16 bug 783708 .
Comment 11 John W. Linville 2012-03-15 08:53:10 EDT
Maybe we should disable ipw2200 completely?
Comment 12 Stanislaw Gruszka 2012-03-15 09:19:00 EDT
Still there are ipw2200 devices here or there. I asked Stanislav Yakovlev for fixing this, let's wait for his answer:
http://marc.info/?l=linux-wireless&m=133180940927824&w=2
Comment 13 Adam Williamson 2012-03-16 13:57:01 EDT
Discussed at 2012-03-16 blocker review meeting. This is another 'breadth of impact' judgment call issue.

It clearly breaks the criterion "The installed system must be able to download and install updates with yum and the default graphical package manager in all release-blocking desktops" in the context of a system which can only possibly connect to a network via an ipw2200 wireless interface.

In a sense this is just like some new wireless adapter we don't yet support, but the fact that it used to work changes the equation a bit.

We don't have hard numbers on extant systems using ipw2200 adapters. We noted that it was extremely popular when it was current, but that's now four generations ago (3xxx, 4xxx, 5xxx and 6xxx all exist now). Tim Flink will try and get harder numbers out of smolt.

We agreed for now to accept this as NTH for Beta, but not blocker. We may consider it as a blocker for the final release, but that needs more data.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Kamil Páral 2012-03-18 08:37:22 EDT
In that case I'm adding Blocks:F17Blocker so that we don't forget about it.
Comment 15 Tim Flink 2012-03-20 12:45:39 EDT
(In reply to comment #13)
>  Tim Flink will try and get harder numbers out of smolt.

Unfortunately, there is no information on network adapter in the smolt data that I have.

If I'm understanding correctly, the ipw2200 adapter was bundled with certain intel based laptops. If we can figure out which CPUs are likely to have this adapter, we might be able to come up with some barely-reliable numbers but it looks like this particular avenue won't be going much of anywhere.
Comment 16 Peter Gückel 2012-03-20 13:26:40 EDT
My laptop has it:

INTEL PENTIUM M SONOMA 740

It is a COMPAQ NC6220 that I use all the time when I am travelling. That the wireless works is critically important to me.
Comment 17 LightDot 2012-03-29 13:01:57 EDT
I also have a laptop with Pentium M that has this adapter bundled. If I remember correctly, Intel® PRO/Wireless 2200BG (ipw2200) was a part of Intel Centrino and bundled with Banias and Dothan families of Pentium M CPUs.

The chipset was pretty popular in those days, I don't know how many other adapters (non-Centrino, 3rd party and such) had this chipset, but looking for those CPU types should give some idea about the user share.

Since this adapter was working for years now, it would be nice to have it work in F17 too or at least owners should be given a warning... It's not a "mee too" since I don't use Fedora on my Centrino laptop any more (left it on SL6 to enjoy a well deserved retirement and occasional use), just saying.
Comment 18 xnike 2012-04-08 12:42:32 EDT
I have an IBM Thinkpad x40 with adapter Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05) and also get same problem after moving to F17 (KDE).

Command `modprobe -r ipw2200 && modprobe ipw2200` makes adapter visible as p1p1 but only with WEP&LEAP security options. So I couldn't connect to my router with WPA2-PSK TKIP/AES.
Comment 19 Stanislaw Gruszka 2012-04-23 05:29:58 EDT
*** Bug 811272 has been marked as a duplicate of this bug. ***
Comment 20 Stanislaw Gruszka 2012-04-23 05:37:44 EDT
Stanislav posted a patch which should fix this bug:
http://marc.info/?l=linux-wireless&m=133486517923084&w=2

Fedora 16 test kernel is here (should be also installable on F-17):
http://koji.fedoraproject.org/koji/taskinfo?taskID=4008799
Comment 21 Kamil Páral 2012-04-23 07:41:32 EDT
I installed that kernel on F17 and wifi works. Great job, please push update for F17.
Comment 22 Mads Kiilerich 2012-04-23 07:44:06 EDT
+1
Comment 23 Stanislaw Gruszka 2012-04-24 03:00:36 EDT
Josh, please apply patch from comment 20 as fix for this bug and F-16 bug 783708 .
Comment 24 Mihkel Punga 2012-04-24 05:52:30 EDT
(In reply to comment #20)
> Fedora 16 test kernel is here (should be also installable on F-17):
> http://koji.fedoraproject.org/koji/taskinfo?taskID=4008799

yes, with this F16 kernel the ipw2200 comes up on boot also on Thinkpad R50e now - no more error messages.

(but NetworkManager still doesn't connect at boot - while on F17 kernel "modprobe -r ipw2200 && modprobe ipw2200" makes NM connect immediately?!)
Comment 25 Mihkel Punga 2012-04-24 05:57:15 EDT
(In reply to comment #18)
> I have an IBM Thinkpad x40 with adapter Intel Corporation PRO/Wireless 2200BG
> [Calexico2] Network Connection (rev 05) and also get same problem after moving
> to F17 (KDE).
> 
> Command `modprobe -r ipw2200 && modprobe ipw2200` makes adapter visible as p1p1
> but only with WEP&LEAP security options. So I couldn't connect to my router
> with WPA2-PSK TKIP/AES.

xnike, you probably can connect to WPA2 by adding wireless network by hand:
https://bugzilla.redhat.com/show_bug.cgi?id=815331
Comment 26 Kamil Páral 2012-04-24 06:45:59 EDT
(In reply to comment #24)
> (but NetworkManager still doesn't connect at boot - while on F17 kernel
> "modprobe -r ipw2200 && modprobe ipw2200" makes NM connect immediately?!)

You probably just need to edit that connection and check "Connect automatically". But anyway that's NM issue, the underlying ipw2200 bug has been fixed.
Comment 27 Josh Boyer 2012-04-24 08:43:44 EDT
(In reply to comment #23)
> Josh, please apply patch from comment 20 as fix for this bug and F-16 bug
> 783708 .

OK, will do.
Comment 28 Josh Boyer 2012-04-24 08:53:57 EDT
Committed to Fedora git.  Will be in the next submitted update.
Comment 29 Dan Winship 2012-04-24 12:30:07 EDT
*** Bug 815331 has been marked as a duplicate of this bug. ***
Comment 30 Dan Williams 2012-04-27 11:44:37 EDT
(In reply to comment #24)
> (but NetworkManager still doesn't connect at boot - while on F17 kernel
> "modprobe -r ipw2200 && modprobe ipw2200" makes NM connect immediately?!)

Because of bug 815091 which appears to be dbus/systemd failing to start wpa_supplicant when NM asks.
Comment 31 Fedora Update System 2012-04-27 19:05:29 EDT
kernel-3.3.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.3.4-1.fc17
Comment 32 Fedora Update System 2012-04-28 13:11:54 EDT
Package kernel-3.3.4-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.3.4-1.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6898/kernel-3.3.4-1.fc17
then log in and leave karma (feedback).
Comment 33 Fedora Update System 2012-04-28 20:58:07 EDT
kernel-3.3.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.