Bug 815331 - Encrypted wifi networks are greyed out and can't be selected in Fallback Mode
Encrypted wifi networks are greyed out and can't be selected in Fallback Mode
Status: CLOSED DUPLICATE of bug 817298
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
: 817147 (view as bug list)
Depends On:
Blocks: F17Blocker/F17FinalBlocker 817298
  Show dependency treegraph
 
Reported: 2012-04-23 07:52 EDT by Kamil Páral
Modified: 2012-05-02 07:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 817298 (view as bug list)
Environment:
Last Closed: 2012-04-30 13:31:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
NM applet (209.14 KB, image/png)
2012-04-23 07:52 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-04-23 07:52:20 EDT
Created attachment 579506 [details]
NM applet

Description of problem:
In Fallback Mode all the encrypted wifi networks are greyed out and you can't click on them, therefore you can't connect. See screenshot. In gnome-shell mode it works.

Version-Release number of selected component (if applicable):
NetworkManager-0.9.4.0-6.git20120403.fc17.i686
NetworkManager-glib-0.9.4.0-6.git20120403.fc17.i686
NetworkManager-gnome-0.9.4.0-6.git20120403.fc17.i686
NetworkManager-gtk-0.9.4.0-6.git20120403.fc17.i686
NetworkManager-openconnect-0.9.3.997-1.fc17.i686
NetworkManager-openvpn-0.9.3.997-1.fc17.i686
NetworkManager-pptp-0.9.3.997-1.fc17.i686
NetworkManager-vpnc-0.9.3.997-1.fc17.i686


How reproducible:
I logged out and in, I pushed wifi switch on and off, still broken
Comment 1 Kamil Páral 2012-04-23 07:53:08 EDT
Proposing as F17 Blocker, it fails criteria requiring network access.
Comment 2 Mihkel Punga 2012-04-24 05:00:04 EDT
Similar behavior of NM in LXDE spin - all WPA networks are grayed out.
WEP networks seem selectable.

Manually adding WPA2 wireless network works (automatic reconnection afterwards and everything ok). 

NetworkManager-0.9.4.0-6.git20120403.fc17.i686
(ipw2200)
Comment 3 Kamil Páral 2012-04-24 06:48:07 EDT
I have to note I also use ipw2200 driver (using fixed kernel provided in bug 802106 comment 20). Maybe it can be related.
Comment 4 Mihkel Punga 2012-04-24 09:31:44 EDT
yes indeed! I've connected an old external wireless adapter to the same machine (pcmcia rt2500pci) and NM works as expected - i.e. WPA networks are visible and clickable and configured correctly by NM.

(except network is not connected on boot - I have to right-click NM to disable/enable wireless to have NM connect to saved network...)

1 more thing I noticed now - NM shows no Signal Strength bars nor connection speed with ipw2200 driver (iwconfig shows all these).
(and signal bars missing with aforementioned "test-ipw2200.fc16" and F17 kernel both).
Comment 5 Kamil Páral 2012-04-24 09:45:16 EDT
I can confirm that a colleague of mine who has a different wifi card model has no problem connecting to WPA networks in the fallback mode, menu items are not greyed out. This bug seems to be affected by just ipw2200 (and maybe some more) models.
Comment 6 Dan Winship 2012-04-24 12:30:07 EDT
Appears to be a kernel driver bug, and an update has already been submitted.

*** This bug has been marked as a duplicate of bug 802106 ***
Comment 7 Kamil Páral 2012-04-25 05:03:37 EDT
No, reopening. I was using the fixed kernel from bug 802106 comment 20. This is not a duplicate. Maybe it's another bug in ipw2200 driver. But it doesn't appear in gnome shell, just in fallback mode, that's suspicious.
Comment 8 Dan Winship 2012-04-27 11:38:28 EDT
(In reply to comment #7)
> it doesn't
> appear in gnome shell, just in fallback mode, that's suspicious.

Hm... it appears that nm-applet does some sanity-checking that gnome-shell doesn't do; nm-applet will gray out the network if your wireless card claims that it doesn't support the given encryption type.

what does

  nmcli dev list | grep WIFI-PROPERTIES

output? (If you have multiple wifi cards, do "nmcli dev list iface WHATEVER" to only list the properties of the ipw2200 card.)
Comment 9 Dan Williams 2012-04-28 12:29:11 EDT
*** Bug 817147 has been marked as a duplicate of this bug. ***
Comment 10 Dan Williams 2012-04-28 14:34:51 EDT
FYI I cannot reproduce the issue in Fallback mode with latest git NM on F15 using kernel 2.6.42.12.  The only machine I have that's capable of using an ipw2200 is only running F15.

The only thing that I can see causing this is improper device capabilities that the kernel provides.  That ipw2200 bug got fixed in the upstream kernel by the following patch:

http://www.spinics.net/lists/linux-wireless/msg88069.html

which needs to be backported to the affected kernels.  The suggested "nmcli dev list | grep WIFI-PROPERTIES" info would tell us whether that's the case or not.
Comment 11 Dan Williams 2012-04-28 14:49:20 EDT
I cloned this bug as Bug 817298 for the kernel to track the backport there.  If we verify that is the actual problem, I may dupe this bug to the kernel bug.

In any case, please still provide the 'nmcli' output so we can minimally verify whether the kernel is the problem here.
Comment 12 Mihkel Punga 2012-04-28 16:17:54 EDT
yes, on e.g. Thinkpad R50e:
nmcli dev list | grep WIFI-PROPERTIES
WIFI-PROPERTIES.WEP:                    no
WIFI-PROPERTIES.WPA:                    no
WIFI-PROPERTIES.WPA2:                   no
WIFI-PROPERTIES.TKIP:                   no
WIFI-PROPERTIES.CCMP:                   no

F17 lxde spin;
kernel-3.3.4-1.fc17.i686 (from Bug 802106);
and defining by hand a NM wireless WPA2 network works ok still.
(but no Signal Strength bars, still)
Comment 13 Mads Kiilerich 2012-04-30 05:14:58 EDT
(In reply to comment #8)
>   nmcli dev list | grep WIFI-PROPERTIES

Confirmed:

WIFI-PROPERTIES.WEP:                    no
WIFI-PROPERTIES.WPA:                    no
WIFI-PROPERTIES.WPA2:                   no
WIFI-PROPERTIES.TKIP:                   no
WIFI-PROPERTIES.CCMP:                   no

Dell Latitude D510 with ipw2200 (reported as D600)

(Reporter on the duplicate Bug 817147)
Comment 14 Dan Williams 2012-04-30 13:31:37 EDT
(In reply to comment #13)
> (In reply to comment #8)
> >   nmcli dev list | grep WIFI-PROPERTIES
> 
> Confirmed:
> 
> WIFI-PROPERTIES.WEP:                    no
> WIFI-PROPERTIES.WPA:                    no
> WIFI-PROPERTIES.WPA2:                   no
> WIFI-PROPERTIES.TKIP:                   no
> WIFI-PROPERTIES.CCMP:                   no
> 
> Dell Latitude D510 with ipw2200 (reported as D600)
> 
> (Reporter on the duplicate Bug 817147)

Yep, that's the kernel driver cipher properties bug as described in bug 817298 which should get fixed soon.  I'm going to dupe this bug to the kernel bug here since that's the underlying problem.

*** This bug has been marked as a duplicate of bug 817298 ***
Comment 15 Kamil Páral 2012-05-02 07:03:12 EDT
Due to limited impact (encrypted wifi networks don't work with ipw2200 just using the fallback mode), I'm not transferring the blocker bug proposal to bug 817298.

Note You need to log in before you can comment on or make changes to this bug.