This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 825284

Summary: udev suspends keyboard/mouse with 3.5 kernel
Product: [Fedora] Fedora Reporter: Josh Boyer <jwboyer>
Component: udevAssignee: udev-maint
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: cristi.florescu, greno, harald, jonathan, lpoetter, patrick.melo, udev-maint, yian.papastergiou
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-06-08 19:57:52 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Josh Boyer 2012-05-25 10:51:26 EDT
Description of problem:

udev will set the power control for some HID devices to auto when it shouldn't when booting a 3.5 kernel with commit 54d3f8c63d6940966217b807972778fb17c3fa82 included.

Version-Release number of selected component (if applicable):

udev-182-3.fc18 (udev-182-1.fc17)

How reproducible:

Always

Steps to Reproduce:
1.  Install said kernel
2.  Boot
3.  Watch the laser on an optical mouse get turned off and remain off until you click a button.  Repeat.
  

Additional info:

Matthew and I debugged this issue this morning.  You can find the discussion here:

https://lkml.org/lkml/2012/5/25/193

I rebuilt my F17 udev to included Matthew's patch (a fixed version) and it indeed makes the mouse and keyboard function properly.

Rawhide is already on kernels with the above commit in it, so this is likely broken for others.  F17 will at some point be rebased to 3.5, so a fixed up udev is needed there as well.

I'd be happy to apply the patch to the Fedora packages and rebuild them if you want, but thought I'd file a bug before doing so.
Comment 1 Josh Boyer 2012-05-30 11:58:05 EDT
Is there some issue here that would prevent this patch from being added?
Comment 2 Josh Boyer 2012-05-30 19:52:09 EDT
(In reply to comment #1)
> Is there some issue here that would prevent this patch from being added?

OK.  I see that systemd-183 obsoletes/provides udev in rawhide now.  That's great, but the patch is still required and isn't in systemd-183 (went in 4 commits after).  This is still going to be needed in udev on F17, which I'm not sure will get upgraded to systemd-183.

So in summary, F17 udev-182 needs Matthew's patch, and systemd in rawhide needs it too.  Otherwise we're going to start getting reports against the kernel of people's keyboards and mice not responding.

BTW, I'm sure you already know but you need to do the package retirement on udev in the master branch too.
Comment 3 Lennart Poettering 2012-05-31 07:18:01 EDT
This is fixed in 184 which hit Rawhide yesterday.
Comment 4 Josh Boyer 2012-05-31 07:33:22 EDT
(In reply to comment #3)
> This is fixed in 184 which hit Rawhide yesterday.

Excellent.  Can I update udev in F17 then?
Comment 5 Josh Boyer 2012-05-31 11:00:32 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > This is fixed in 184 which hit Rawhide yesterday.
> 
> Excellent.  Can I update udev in F17 then?

Spoke with Kay on #fedora-devel today.  I'll get this fixed up for F17 and submit an update.
Comment 6 Kay Sievers 2012-05-31 11:03:02 EDT
(In reply to comment #4)
> Excellent.  Can I update udev in F17 then?

Sure, that would be great.

Go ahead, there is no maintainer "paperwork" involved, we share the maintenance
anyway between 2-4 people anyway.

Always feel free to just do any reasonable patches to the package.
Comment 7 Josh Boyer 2012-05-31 11:27:11 EDT
Fixed in git.  Build starting shortly.
Comment 8 Fedora Update System 2012-05-31 11:38:55 EDT
udev-182-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/udev-182-3.fc17
Comment 9 Fedora Update System 2012-06-01 12:53:08 EDT
Package udev-182-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing udev-182-3.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8679/udev-182-3.fc17
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-06-08 19:57:52 EDT
udev-182-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Josh Boyer 2012-06-11 08:20:46 EDT
*** Bug 829948 has been marked as a duplicate of this bug. ***
Comment 12 Josh Boyer 2012-10-17 10:55:41 EDT
*** Bug 867024 has been marked as a duplicate of this bug. ***
Comment 13 Josh Boyer 2013-03-14 15:27:12 EDT
*** Bug 847983 has been marked as a duplicate of this bug. ***