Bug 833047

Summary: Validation required for Application name.
Product: CloudForms Cloud Engine Reporter: Aziza Karol <akarol>
Component: aeolus-conductorAssignee: Angus Thomas <athomas>
Status: CLOSED DUPLICATE QA Contact: Rehana <aeolus-qa-list>
Severity: low Docs Contact:
Priority: unspecified    
Version: 1.0.0CC: dajohnso
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-11-27 16:54:55 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
app name
app launched none

Description Aziza Karol 2012-06-18 09:29:19 EDT
Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Crate a new application with special characters #$@()

Actual results:
application gets created with special characters.
I had given name as "#$@()" and it got launched with the name "-"
see attached screenshots

Expected results:
validation required for application name.special characters should not be allowed.

Additional info:
rpm -qa | grep aeolus
Comment 1 Aziza Karol 2012-06-18 09:30:45 EDT
Created attachment 592643 [details]
app name
Comment 2 Aziza Karol 2012-06-18 09:31:55 EDT
Created attachment 592644 [details]
app launched
Comment 3 Dave Johnson 2012-11-27 16:54:55 EST

*** This bug has been marked as a duplicate of bug 819839 ***