This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 833047 - Validation required for Application name.
Validation required for Application name.
Status: CLOSED DUPLICATE of bug 819839
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Angus Thomas
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 09:29 EDT by Aziza Karol
Modified: 2012-11-27 16:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-27 16:54:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
app name (227.08 KB, image/png)
2012-06-18 09:30 EDT, Aziza Karol
no flags Details
app launched (196.07 KB, image/png)
2012-06-18 09:31 EDT, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2012-06-18 09:29:19 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Crate a new application with special characters #$@()

  
Actual results:
application gets created with special characters.
I had given name as "#$@()" and it got launched with the name "-"
see attached screenshots


Expected results:
validation required for application name.special characters should not be allowed.

Additional info:
rpm -qa | grep aeolus
aeolus-conductor-daemons-0.8.30-1.el6_2.noarch
aeolus-configure-2.5.7-2.el6_2.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.8.30-1.el6_2.noarch
rubygem-aeolus-cli-0.3.3-2.el6_2.noarch
aeolus-conductor-doc-0.8.30-1.el6_2.noarch
aeolus-all-0.8.30-1.el6_2.noarch
Comment 1 Aziza Karol 2012-06-18 09:30:45 EDT
Created attachment 592643 [details]
app name
Comment 2 Aziza Karol 2012-06-18 09:31:55 EDT
Created attachment 592644 [details]
app launched
Comment 3 Dave Johnson 2012-11-27 16:54:55 EST

*** This bug has been marked as a duplicate of bug 819839 ***

Note You need to log in before you can comment on or make changes to this bug.