Bug 837520

Summary: Malformed fontconfig config file
Product: [Fedora] Fedora Reporter: Akira TAGOH <tagoh>
Component: khmeros-fontsAssignee: Parag Nemade <pnemade>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: fonts-bugs, gwync, pnemade, stefw
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: khmeros-fonts-5.0-13.fc18 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-07-05 10:16:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Akira TAGOH 2012-07-04 07:49:07 UTC
Description of problem:

Still no changes in the behavior in the latest version of fontconfig,
but it now warns when <test> contains multiple values or <alias> contains
multiple <family>s. this is because the behavior isn't intuitive and
doesn't work as expected necessarily. So you better consider to fix it
to make clearer what you want to do with it.

For solution, if you are expecting OR operator with that rule, add more
<match>s or <alias>es. if you are expecting AND operator with that rule,
just add more <test>s in that <match>.

Version-Release number of selected component (if applicable):
khmeros-fonts-5.0-12.fc17.src.rpm

How to reproducible:
always

Steps to Reproduce:
1. install the fonts package
2. fc-match

Actual results:
Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-base.conf", line 29: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-base.conf", line 41: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-base.conf", line 53: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-battambang.conf", line 16: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-bokor.conf", line 16: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-handwritten.conf", line 22: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-handwritten.conf", line 34: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-metal-chrieng.conf", line 16: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-muol.conf", line 29: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-muol.conf", line 41: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-muol.conf", line 53: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-siemreap.conf", line 16: Having multiple values in <test> isn't supported and may not works as expected

Expected results:
no warnings

Comment 1 Parag Nemade 2012-07-05 10:16:54 UTC
Fixed in khmeros-fonts-5.0-13.fc18

Comment 2 Parag Nemade 2012-07-05 10:18:13 UTC
*** Bug 837547 has been marked as a duplicate of this bug. ***

Comment 3 Akira TAGOH 2012-08-13 01:52:43 UTC
*** Bug 847340 has been marked as a duplicate of this bug. ***