Bug 847340 - Malformed fontconfig config file
Malformed fontconfig config file
Status: CLOSED DUPLICATE of bug 837520
Product: Fedora
Classification: Fedora
Component: abattis-cantarell-fonts (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cosimo Cecchi
Fedora Extras Quality Assurance
:
Depends On: 837521
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-10 11:40 EDT by Martin
Modified: 2014-09-14 20:03 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 837521
Environment:
Last Closed: 2012-08-12 21:52:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin 2012-08-10 11:40:59 EDT
Upgrading: abattis-cantarell-fonts-0.0.9-2.fc18.noarch                                                                                                             489/2664 
Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-base.conf", line 29: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-base.conf", line 41: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-base.conf", line 53: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-nhn-nanum-gothic.conf", line 8: Having multiple values in <test> isn't supported and may not works as expected

Same bug as below:



+++ This bug was initially created as a clone of Bug #837521 +++

Description of problem:

Still no changes in the behavior in the latest version of fontconfig,
but it now warns when <test> contains multiple values or <alias> contains
multiple <family>s. this is because the behavior isn't intuitive and
doesn't work as expected necessarily. So you better consider to fix it
to make clearer what you want to do with it.

For solution, if you are expecting OR operator with that rule, add more
<match>s or <alias>es. if you are expecting AND operator with that rule,
just add more <test>s in that <match>.

Version-Release number of selected component (if applicable):
nhn-nanum-fonts-3.020-1.fc17.src.rpm

How to reproducible:
always

Steps to Reproduce:
1. install the fonts package
2. fc-match

Actual results:
Fontconfig warning: "/etc/fonts/conf.d/65-0-nhn-nanum-brush.conf", line 8: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-nhn-nanum-gothic.conf", line 8: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-nhn-nanum-myeongjo.conf", line 8: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-nhn-nanum-pen.conf", line 8: Having multiple values in <test> isn't supported and may not works as expected

Expected results:
no warnings

--- Additional comment from dueno@redhat.com on 2012-07-04 04:57:17 EDT ---

*** Bug 837548 has been marked as a duplicate of this bug. ***

--- Additional comment from dueno@redhat.com on 2012-07-04 05:01:30 EDT ---

http://koji.fedoraproject.org/koji/buildinfo?buildID=329028
Comment 1 Akira TAGOH 2012-08-12 21:52:43 EDT
(In reply to comment #0)
> Upgrading: abattis-cantarell-fonts-0.0.9-2.fc18.noarch                      
> 489/2664 
> Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-base.conf", line 29:
> Having multiple values in <test> isn't supported and may not works as
> expected
> Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-base.conf", line 41:
> Having multiple values in <test> isn't supported and may not works as
> expected
> Fontconfig warning: "/etc/fonts/conf.d/65-0-khmeros-base.conf", line 53:
> Having multiple values in <test> isn't supported and may not works as
> expected
> Fontconfig warning: "/etc/fonts/conf.d/65-0-nhn-nanum-gothic.conf", line 8:
> Having multiple values in <test> isn't supported and may not works as
> expected

As you cloned from Bug#837521 and one of them has already been fixed in nhn-nanum-fonts-3.020-3.fc18, who owns /etc/fonts/conf.d/65-0-nhn-nanum-gothic.conf. and others has also already been fixed in khmeros-base-fonts-5.0-13.fc18. see Bug#837520.

*** This bug has been marked as a duplicate of bug 837520 ***

Note You need to log in before you can comment on or make changes to this bug.