Bug 840146

Summary: [abrt]: [103510.260527] WARNING: at net/wireless/mlme.c:490 cfg80211_mlme_disassoc+0x114/0x120 [cfg80211]()
Product: [Fedora] Fedora Reporter: Garrett Holmstrom <gholms>
Component: kernelAssignee: John W. Linville <linville>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: gansalmon, hanpingtian, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:9c86163cb83f730b522af098bcdff9c0bf7909bb
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-07-16 17:12:51 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Warning backtraces from wireless hang none

Description Garrett Holmstrom 2012-07-13 17:01:54 EDT
libreport version: 2.0.10
cmdline:        BOOT_IMAGE=/vmlinuz-3.4.4-4.fc16.x86_64 root=/dev/mapper/luks-7250a42c-2809-48b5-9087-bb683c7b4740 ro rd.luks.uuid=luks-9e4540f7-03a0-4ce6-8eef-484c68121310 rd.luks.uuid=luks-d6179e9e-9869-4238-87b4-ecf580785816 rd.md=0 rd.dm=0 KEYTABLE=us rd.lvm.lv=vg_luna/lv_swap quiet rd.lvm.lv=vg_luna/lv_rootfs rd.luks.uuid=luks-7250a42c-2809-48b5-9087-bb683c7b4740 rhgb SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8

backtrace:
:[103510.260527] WARNING: at net/wireless/mlme.c:490 cfg80211_mlme_disassoc+0x114/0x120 [cfg80211]()
:[103510.260552] Hardware name: 4313CTU
:[103510.260554] Modules linked in: tcp_diag inet_diag fuse ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle bridge stp llc lockd be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter nf_conntrack_ipv4 ip6_tables nf_defrag_ipv4 xt_state nf_conntrack vhost_net macvtap macvlan tun kvm_intel kvm snd_hda_codec_hdmi snd_hda_codec_conexant snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm uinput thinkpad_acpi arc4 snd_timer snd soundcore iwlwifi mac80211 cfg80211 sunrpc rfkill iTCO_wdt iTCO_vendor_support snd_page_alloc coretemp uvcvideo videobuf2_core videodev media videobuf2_vmalloc videobuf2_memops joydev microcode i2c_i801 intel_ips e1000e tpm_tis tpm tpm_bios xts gf128mul dm_crypt crc32c_intel ghash_clmulni_intel sdhci_pci sdhci mmc_core 
:mxm_wmi wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:[103510.260792] Pid: 1474, comm: wpa_supplicant Tainted: G        W    3.4.4-4.fc16.x86_64 #1
:[103510.260800] Call Trace:
:[103510.260816]  [<ffffffff8105807f>] warn_slowpath_common+0x7f/0xc0
:[103510.260826]  [<ffffffff810580da>] warn_slowpath_null+0x1a/0x20
:[103510.260845]  [<ffffffffa0287a14>] cfg80211_mlme_disassoc+0x114/0x120 [cfg80211]
:[103510.260857]  [<ffffffff815fa03d>] ? mutex_lock+0x1d/0x50
:[103510.260875]  [<ffffffffa027972e>] nl80211_disassociate+0xbe/0xf0 [cfg80211]
:[103510.260890]  [<ffffffff81517a2a>] genl_rcv_msg+0x21a/0x2b0
:[103510.260899]  [<ffffffff81517810>] ? genl_rcv+0x40/0x40
:[103510.260908]  [<ffffffff815171d9>] netlink_rcv_skb+0xa9/0xd0
:[103510.260916]  [<ffffffff815177f5>] genl_rcv+0x25/0x40
:[103510.260924]  [<ffffffff81516bee>] netlink_unicast+0x1ae/0x1f0
:[103510.260933]  [<ffffffff81516eee>] netlink_sendmsg+0x2be/0x320
:[103510.260945]  [<ffffffff814d62a7>] sock_sendmsg+0x117/0x130
:[103510.260958]  [<ffffffff812a7b58>] ? blk_finish_plug+0x18/0x50
:[103510.260968]  [<ffffffff814d8ada>] ? move_addr_to_kernel+0x5a/0xa0
:[103510.260978]  [<ffffffff814e47b6>] ? verify_iovec+0x56/0xd0
:[103510.260988]  [<ffffffff814d7bc6>] __sys_sendmsg+0x396/0x3b0
:[103510.261000]  [<ffffffff81182ee2>] ? do_sync_write+0xd2/0x110
:[103510.261010]  [<ffffffff8119c98c>] ? destroy_inode+0x3c/0x70
:[103510.261022]  [<ffffffff811c02c4>] ? fsnotify+0x1e4/0x290
:[103510.261035]  [<ffffffff81272918>] ? selinux_file_permission+0xe8/0x130
:[103510.261045]  [<ffffffff814d9a19>] sys_sendmsg+0x49/0x90
:[103510.261056]  [<ffffffff816043e9>] system_call_fastpath+0x16/0x1b
Comment 1 Garrett Holmstrom 2012-07-13 17:06:54 EDT
After wireless net hung for around 20 seconds, the kernel gave three warnings over the span of about 10 seconds and then began reconnecting as usual.  The backtrace above was the first.  I will attach the complete sequence from dmesg shortly.
Comment 2 Garrett Holmstrom 2012-07-13 17:09:24 EDT
Created attachment 598183 [details]
Warning backtraces from wireless hang
Comment 3 Dave Jones 2012-07-16 17:11:42 EDT
*** Bug 836449 has been marked as a duplicate of this bug. ***
Comment 4 Dave Jones 2012-07-16 17:12:51 EDT

*** This bug has been marked as a duplicate of bug 834158 ***