Bug 834158 - [abrt]: WARNING: at net/wireless/mlme.c:490 cfg80211_mlme_disassoc+0x114/0x120 [cfg80211]()
[abrt]: WARNING: at net/wireless/mlme.c:490 cfg80211_mlme_disassoc+0x114/0x12...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
abrt_hash:916606d1718f0773b36ce623eb5...
:
: 840146 842157 862842 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 00:12 EDT by Flos Lonicerae
Modified: 2012-10-23 02:32 EDT (History)
15 users (show)

See Also:
Fixed In Version: kernel-3.6.3-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 02:32:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: smolt_data (3.48 KB, text/plain)
2012-06-21 00:12 EDT, Flos Lonicerae
no flags Details
mac80211_local_deauth_v3.6.patch (1.96 KB, text/plain)
2012-10-15 10:09 EDT, Stanislaw Gruszka
no flags Details

  None (edit)
Description Flos Lonicerae 2012-06-21 00:12:38 EDT
libreport version: 2.0.10
cmdline:        BOOT_IMAGE=/vmlinuz-3.4.2-1.fc16.x86_64 root=/dev/mapper/vg_local-lv_root ro rd.md=0 rd.dm=0 KEYTABLE=us quiet rd.lvm.lv=vg_local/lv_swap rhgb LANG=zh_CN.UTF-8 rd.luks=0 rd.lvm.lv=vg_local/lv_root loglevel=7

backtrace:
:WARNING: at net/wireless/mlme.c:490 cfg80211_mlme_disassoc+0x114/0x120 [cfg80211]()
:Hardware name: 4384BQ4
:Modules linked in: sha256_generic dm_crypt tcp_lp fuse ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat be2iscsi iscsi_boot_sysfs xt_CHECKSUM bnx2i iptable_mangle bridge stp lockd llc cnic uio cxgb4i cxgb4 cxgb3i rfcomm libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi bnep ip6t_REJECT nf_conntrack_ipv6 nf_conntrack_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 xt_state nf_conntrack ip6table_filter ip6_tables snd_hda_codec_hdmi btusb bluetooth snd_hda_codec_conexant uvcvideo snd_hda_intel snd_hda_codec snd_hwdep arc4 snd_seq snd_seq_device e1000e iwlwifi mac80211 videobuf2_core videodev media videobuf2_vmalloc videobuf2_memops snd_pcm cfg80211 coretemp vhost_net macvtap macvlan tun thinkpad_acpi iTCO_wdt kvm_intel iTCO_vendor_support i2c_i801 intel_ips joydev snd_timer tpm_tis tpm tpm_bios snd_page_alloc rfkill snd soundcore sunrpc kvm uinput microcode crc32c_intel ghash_clmulni_intel mxm_wmi 
:firewire_ohci firewire_core sdhci_pci sdhci crc_itu_t mmc_core wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 1372, comm: wpa_supplicant Not tainted 3.4.2-1.fc16.x86_64 #1
:Call Trace:
: [<ffffffff810579df>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff81057a3a>] warn_slowpath_null+0x1a/0x20
: [<ffffffffa02e59a4>] cfg80211_mlme_disassoc+0x114/0x120 [cfg80211]
: [<ffffffff815f5f7d>] ? mutex_lock+0x1d/0x50
: [<ffffffffa02d76be>] nl80211_disassociate+0xbe/0xf0 [cfg80211]
: [<ffffffff81513a2a>] genl_rcv_msg+0x21a/0x2b0
: [<ffffffff81513810>] ? genl_rcv+0x40/0x40
: [<ffffffff815131d9>] netlink_rcv_skb+0xa9/0xd0
: [<ffffffff815137f5>] genl_rcv+0x25/0x40
: [<ffffffff81512bee>] netlink_unicast+0x1ae/0x1f0
: [<ffffffff81512eee>] netlink_sendmsg+0x2be/0x320
: [<ffffffff814d22a7>] sock_sendmsg+0x117/0x130
: [<ffffffff812a3b88>] ? blk_finish_plug+0x18/0x50
: [<ffffffff814d4ada>] ? move_addr_to_kernel+0x5a/0xa0
: [<ffffffff814e07b6>] ? verify_iovec+0x56/0xd0
: [<ffffffff814d3bc6>] __sys_sendmsg+0x396/0x3b0
: [<ffffffff8117ef52>] ? do_sync_write+0xd2/0x110
: [<ffffffff811989fc>] ? destroy_inode+0x3c/0x70
: [<ffffffff811bc324>] ? fsnotify+0x1e4/0x290
: [<ffffffff8126e948>] ? selinux_file_permission+0xe8/0x130
: [<ffffffff814d5a19>] sys_sendmsg+0x49/0x90
: [<ffffffff81600329>] system_call_fastpath+0x16/0x1b
Comment 1 Flos Lonicerae 2012-06-21 00:12:43 EDT
Created attachment 593346 [details]
File: smolt_data
Comment 2 John W. Linville 2012-06-21 09:47:16 EDT
Can you provide some context as to what was happening when you observed this?
Comment 4 Flos Lonicerae 2012-06-24 23:51:43 EDT
1. wireless disconnected and NetworkManager ask for the password
2. abrt-applet pops up


Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 5 milady 2012-07-10 12:39:27 EDT
Connect to an "eduroam" wireless access point.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 6 Dave Jones 2012-07-16 17:12:51 EDT
*** Bug 840146 has been marked as a duplicate of this bug. ***
Comment 7 Josh Boyer 2012-07-23 09:05:19 EDT
*** Bug 842157 has been marked as a duplicate of this bug. ***
Comment 8 Josh Boyer 2012-09-26 11:42:03 EDT
*** Bug 860742 has been marked as a duplicate of this bug. ***
Comment 9 Ted 2012-10-01 10:15:16 EDT
Just opened Google Chrome.

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 10 Stanislaw Gruszka 2012-10-05 09:11:02 EDT
*** Bug 862842 has been marked as a duplicate of this bug. ***
Comment 11 Phil V 2012-10-05 14:38:35 EDT
Unclear cause. Laptop was using wireless and a few firefox windows. 

This is only ignorant speculation: Wireless password is requested by two different dialog boxes so maybe there is some conflict in the GNOME vs. linux network managers. 


Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 12 Petr Kubiznak 2012-10-10 08:21:57 EDT
Browsing web in Firefox. At the time of crash, there was no obvious operation in progress, neither I was doing anything.

Package: kernel
Architecture: i686
OS Release: Fedora release 16 (Verne)
Comment 13 Stanislaw Gruszka 2012-10-15 10:09:03 EDT
Created attachment 627456 [details]
mac80211_local_deauth_v3.6.patch

Possible fix for this problem. Kernel build (still compiling) with patch is here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4590829
Please test it and report back. Test is especially welcome from users, who can reproduce this problem reliably.
Comment 14 José Matos 2012-10-15 14:04:45 EDT
After upgrading to 3.6.1 I do not see the abr report that I have seen with 3.5.x kernels.

Regardless I am unable to connect to eduroam with both 3.6.1 and 3.6.2-2.cfg80211.fc17.x86_64, or more properly to get a stable connection to eduroam.

Sometimes the connection works at first but then it disconnects, time when the I get a dialog box from NetworkManager. After some tries it gets connected but soon enough it is kicked back.

As the original report says this only happens for eduroam networks and not for all of them, but when it happens it is consistent.

AFAIR this started with 3.5.x kernels (but I can be wrong).

I hope this helps.
Comment 15 Stanislaw Gruszka 2012-10-16 06:26:57 EDT
José, I reopened bug 860742 to track this network instability problem, since it is not related with WARNING we are tracking here.
Comment 16 Stanislaw Gruszka 2012-10-18 03:40:14 EDT
This bug should be addressed by the same patch as for bug 862168, which I request to apply to official Fedora kernels.
Comment 17 Stanislaw Gruszka 2012-10-23 02:32:54 EDT
Fix is already released:
https://admin.fedoraproject.org/updates/FEDORA-2012-16669/kernel-3.6.3-1.fc17

If problem will still occur, please reopen this bug report.

Note You need to log in before you can comment on or make changes to this bug.