Bug 855560

Summary: F18 Live Alpha : nVidia GeForce 8600M GT, graphic driver (nouveau): very poor performance (vesa is fluid)
Product: [Fedora] Fedora Reporter: Xavier Hourcade <public.oss>
Component: xorg-x11-drv-nouveauAssignee: Ben Skeggs <bskeggs>
Status: CLOSED ERRATA QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: acathrow, airlied, ajax, awilliam, bskeggs, erik-fedora, mhlavink, michele, public.oss, robatino, tflink
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
See Also: https://bugzilla.redhat.com/show_bug.cgi?id=855557
Whiteboard: RejectedBlocker
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-22 14:01:22 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
TC6 var-log folder, dmesg, free, ps aux and xsession-errors
none
alpha RC2/KDE/nouveau var-log, tmp, free, ps aux, lsmod, dmesg, xsession-errors
none
alpha RC2/KDE/vesa var-log, tmp, free, ps aux, lsmod, dmesg, xsession-errors
none
alpha RC2/Gnome/vesa var-log, tmp, free, ps aux, lsmod, dmesg none

Description Xavier Hourcade 2012-09-08 18:39:06 EDT
Created attachment 611097 [details]
TC6 var-log folder, dmesg, free, ps aux and xsession-errors

Description of problem:

  As soon as F18 Live KDE session as loaded, CPU is very highly used, while just moving or refreshing any window (90%). At idle it goes down. This makes the whole experience awful.

Version-Release number of selected component (if applicable):

  F18 Live KDE alpha TC5 and TC6

How reproducible:

  Always

Steps to Reproduce:

  1. Boot until KDE Session is launched
  2. Open any window, eg. Dolphin
  
Actual results:

  Just moving the window around, using the mouse :
  - with desktop effects : X 50% + kwin 40%
  - without desktop effects : X 50% + kwin 5%

Expected results:

  Anything reasonable :)

Additional info:

  Asus V1S laptop with nVidia GeForce 8600M GT (hence nouveau)
  F16 and F17 Live KDE, do not bring this issue
Comment 1 Adam Williamson 2012-09-10 00:43:22 EDT
Until Beta, we use a debug kernel, which performs much more poorly than a release kernel. Try with a non-debug kernel to see if that helps, if you can. Unless you try that, it's hard to know whether there's any other performance issue. The other thing to check would be that nouveau is actually loaded and acceleration is working (Xorg.0.log).
Comment 2 Adam Williamson 2012-09-10 12:23:42 EDT
Discussed at 2012-09-10 QA meeting, acting as a blocker review meeting. For now this is rejected on the grounds that poor performance is expected with Alpha due to the debug kernel. If there appears to be a significant problem over and above the influence of the debug kernel, please re-propose.
Comment 3 Xavier Hourcade 2012-09-12 10:13:05 EDT
More precisely : using *nouveau*, performance is so bad that performance can be felt even just moving the cursor around (redering makes some micro-pauses) or writing a text file in Kwrite (some of the keystrokes are getting "lost", 10% maybe).

Yesterday I tested both Gnome & KDE Live alpha RC2 isos : default boot gives the same results for both.

Then I also tried *vesa*, which I had not tried so far :

- under KDE, all is great during the whole session, perfectly fluid ! Even with Desktop Effects enabled, and despite high CPU usages even higher than I reported previously. X alone takes almost 100% while moving a Dolphin window around the 1024x768 screen, but there is no drastic experience penalty, it remains fluid. So, KDE over vesa just performs, at least, as well as anyone would expect on such hardware (T7500, 4GB RAM, 2007 GPU with 512 dedicated VRAM).

- under Gnome, vesa is as fluid as with KDE, but only at the very start of Gnome session. Then it gets slower and slower as the session lasts, up to the point the experience is comparable to that of nouveau described previously :s Since this is gradual, and while KDE behaves well, I assume that's a distinct issue.

Also, while booting vesa (please see bug 855557), animation loads in text mode/lowres (which is expected, this time ^^), but it *does* scales properly to full screen display, until GDM/KDM is launched (versus screen being drawn within the top left quarter of the LDC panel, and some [OK] messages appearing "at the last text line of the top right quarter").

Should I close bug 855557 as duplicate, and re-propose this one as a blocker ?
Comment 4 Xavier Hourcade 2012-09-12 10:21:27 EDT
Created attachment 612125 [details]
alpha RC2/KDE/nouveau var-log, tmp, free, ps aux, lsmod, dmesg, xsession-errors
Comment 5 Xavier Hourcade 2012-09-12 10:22:17 EDT
Created attachment 612126 [details]
alpha RC2/KDE/vesa var-log, tmp, free, ps aux, lsmod, dmesg, xsession-errors
Comment 6 Xavier Hourcade 2012-09-12 10:23:06 EDT
Created attachment 612127 [details]
alpha RC2/Gnome/vesa var-log, tmp, free, ps aux, lsmod, dmesg
Comment 7 Xavier Hourcade 2012-09-14 03:09:16 EDT
Applies to Alpha (RC3). See also bug 857300.
Comment 8 Adam Williamson 2012-09-17 20:33:21 EDT
Does the fix for 857300 improve this behaviour at all?
Comment 9 Andrew Cathrow 2012-09-24 18:37:43 EDT
Seeing the same issue on Thinkpad W520 - GF108 [Quadro 1000M) (rev a1)

Very poor performance - even mouse slow to move and/or jerky.
I'm running the kernel referenced in bug 857300 - 3.6.0-0.rc6.git0.2
xorg-x11-drv-nouveau-1.0.1-6
Comment 10 Martin 2012-09-25 18:08:22 EDT
(In reply to comment #9)
> Seeing the same issue on Thinkpad W520 - GF108 [Quadro 1000M) (rev a1)
> 
> Very poor performance - even mouse slow to move and/or jerky.
> I'm running the kernel referenced in bug 857300 - 3.6.0-0.rc6.git0.2
> xorg-x11-drv-nouveau-1.0.1-6

I think llvmpipe is used as OpenGL rendered on your machine. Check glxinfo and try to boot this machine with "nouveau.noaccel=0".
Comment 11 Adam Williamson 2012-09-25 18:22:32 EDT
oh, for anyone who comes across this bug, if you started X with 'startx', you are almost certainly seeing https://bugzilla.redhat.com/show_bug.cgi?id=806491 . boot runlevel 5, or use 'startx -- vt01'.
Comment 12 Adam Williamson 2012-10-04 13:15:31 EDT
Discussed at 2012-10-04 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-04/f18-beta-blocker-review-2.1.2012-10-04-16.00.log.txt .  We agreed we need more information on what's going on before we can evaluate this. Can you please test it with Beta TC1 or TC2 when available ( http://dl.fedoraproject.org/pub/alt/stage/ ), and advise exactly what kernel you're using for each test? Can you please provide the output of glxinfo as well so we can check whether nouveau or llvmpipe is being used? Thanks.
Comment 13 Adam Williamson 2012-10-10 13:52:50 EDT
Discussed at 2012-10-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-10/f18beta-blocker-review-3.2012-10-10-16.05.log.txt . As we haven't received a reply to the above question, and we haven't seen more people reporting this issue either here or on the list or in the forums, we're considering this to be an issue with fairly narrow impact and rejecting as a blocker for now. If more information comes to light it can be re-proposed.
Comment 14 Xavier Hourcade 2012-10-22 14:01:22 EDT
This appears to be fixed, tested Fedora-18-Beta-TC6-x86_64-Live-KDE.iso
Thanks!