Bug 857300 - Graphical environment doesn't appear or appears corrupted on certain NVIDIA adapters with plymouth 0.8.7
Graphical environment doesn't appear or appears corrupted on certain NVIDIA a...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
All All
unspecified Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs, Patch
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-09-14 00:35 EDT by Adam Williamson
Modified: 2012-10-22 14:30 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-23 01:03:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
F18 Alpha Live KDE, loading sessiion (220.05 KB, image/jpeg)
2012-09-14 02:02 EDT, Xavier Hourcade
no flags Details
F18 Alpha Live KDE, session ready (Device notifier offering usb stick) (216.45 KB, image/jpeg)
2012-09-14 02:04 EDT, Xavier Hourcade
no flags Details

  None (edit)
Description Adam Williamson 2012-09-14 00:35:34 EDT
This bug splits off the problem described in comments #12 through #20 of https://bugzilla.redhat.com/show_bug.cgi?id=848305 . After plymouth was updated to 0.8.7 - partly to fix that bug - a serious issue showed up with several NVIDIA adapters: when booting normally to a desktop, runlevel '5', plymouth enabled, all as normal, either the DM doesn't really appear at all (though it claims to be running), or it appears but somewhat corrupted; if you can get through the DM to the desktop, it will also be corrupted.

Booting to runlevel 3 and starting the DM service manually, or dropping 'rhgb' from the kernel parameters, acts as a workaround.

airlied says he has found the fix for this: https://patchwork.kernel.org/patch/1455231/ . He plans to run it by Ben and then submit it upstream.
Comment 1 Adam Williamson 2012-09-14 00:38:18 EDT
Proposing as Beta blocker (conditional infringement of the 'live must boot' and 'installed system must boot' criteria in the case of certain NVIDIA adapters. We should commonbugs this for Alpha, as Alpha has the bug.
Comment 2 Xavier Hourcade 2012-09-14 02:02:37 EDT
Created attachment 612728 [details]
F18 Alpha Live KDE, loading sessiion
Comment 3 Xavier Hourcade 2012-09-14 02:04:34 EDT
Created attachment 612729 [details]
F18 Alpha Live KDE, session ready (Device notifier offering usb stick)
Comment 4 Xavier Hourcade 2012-09-14 02:45:58 EDT
Captures made on Asus V1S laptop with GeForce 8600M GT (512MB VRAM).

Alpha (RC3) is the first of GNOME/KDE Live TCs/RCs to run plymouth charge correctly on this hardware (bug 855557), despite leading to the present defect. Dropping 'rhgb' from the kernel parameters, acts as a workaround as you mentioned (raw tty messaging instead of any animation, then no graphic corruption, KDE loads fine and Desktop Effects are enabled by default).

Safe graphics (vesa) acts as yet another workaround, loading plymouth text animation. All other routes -- except vesa -- lead to extreme slowness (bug 855560) on this hardware, for both GNOME and KDE Live spins. LXDE Live Alpha (RC3) just works as default, without any workaround, running plymouth charge. Is the present defect, only affecting desktop acceleration ?
Comment 5 Patrick Talbert 2012-09-14 13:54:50 EDT
I had this issue when installing TC5 and could not make heads of tails of it. I stumbled on a fix when I installed F17 and then "upgraded" to F18. When I boot with the old F17 kernel (3.5.3-1.fc17.x86_64) everything works perfectly, but with the F18 3.6 kernels I am lucky to get to a GDM and if I do it is a horrid mess. Booting to runlevel 3 and then launching the GDM did not help.
Comment 6 Adam Williamson 2012-09-14 14:48:54 EDT
I've tested airlied's fix and it works for me. The scratch build I used to test is here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4482706

feel free to grab it before it expires and check that it works for you too. thanks!
Comment 7 Josh Boyer 2012-09-16 09:13:12 EDT
Patch is picked up in kernel-3.6.0-0.rc5.git3.1.fc18
Comment 8 Kamil Páral 2012-09-17 04:59:35 EDT
On an installed system I never reproduced the graphics corruption, the system froze instead after login. kernel-3.6.0-0.rc5.git3.1.fc18 fixed the issue for me.
Comment 9 Fedora Update System 2012-09-17 15:28:16 EDT
kernel-3.6.0-0.rc6.git0.2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.6.0-0.rc6.git0.2.fc18
Comment 10 Fedora Update System 2012-09-18 15:21:21 EDT
Package kernel-3.6.0-0.rc6.git0.2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.6.0-0.rc6.git0.2.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14273/kernel-3.6.0-0.rc6.git0.2.fc18
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-09-23 01:03:35 EDT
kernel-3.6.0-0.rc6.git0.2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Xavier Hourcade 2012-10-22 14:30:02 EDT
May I confirm too, this is fixed on the hardware I reported.
Tested Fedora-18-Beta-TC6-x86_64-Live-KDE.iso
Thanks!

Note You need to log in before you can comment on or make changes to this bug.