Bug 865355

Summary: IOError: [Errno 2] No such file or directory: '/mnt/sysimage/etc/sysconfig/network-scripts/ifcfg-wlan0'
Product: [Fedora] Fedora Reporter: Kamil Páral <kparal>
Component: anacondaAssignee: Vratislav Podzimek <vpodzime>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: anaconda-maint-list, awilliam, g.kaviyarasu, jonathan, ljozsa, obmun.h, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
See Also: https://bugzilla.redhat.com/show_bug.cgi?id=860791
Whiteboard: abrt_hash:fa8c2d80bab139cbd01e342de6e45a946bcb34091043ba25806212f107803877
Fixed In Version: anaconda-18.16-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-11-22 23:46:30 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
File: anaconda-tb
none
File: product
none
File: type
none
File: ifcfg.log
none
File: storage.log
none
File: version
none
File: environ
none
File: anaconda.log
none
File: syslog
none
File: hashmarkername
none
File: packaging.log
none
File: cmdline_file
none
File: release
none
File: program.log none

Description Kamil Páral 2012-10-11 05:42:24 EDT
Description of problem:
This happened after trying updates.img from bug 862801 comment 43

Version-Release number of selected component:
anaconda-18.14

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.14 exception report
:Traceback (most recent call first):
:  File "/tmp/updates/pyanaconda/simpleconfig.py", line 77, in read
:    with open(filename) as f:
:  File "/tmp/updates/pyanaconda/simpleconfig.py", line 187, in read
:    SimpleConfigFile.read(self, self.path)
:  File "/tmp/updates/pyanaconda/network.py", line 285, in loadIfcfgFile
:    IfcfgFile.read(self)
:  File "/tmp/updates/pyanaconda/network.py", line 766, in get_ifcfg_value
:    dev.loadIfcfgFile()
:  File "/tmp/updates/pyanaconda/installclasses/fedora.py", line 121, in setNetworkOnbootDefault
:    if network.get_ifcfg_value(devName, "ONBOOT", ROOT_PATH) == "yes":
:  File "/tmp/updates/pyanaconda/network.py", line 881, in writeNetworkConf
:    instClass.setNetworkOnbootDefault(ksdata)
:  File "/tmp/updates/pyanaconda/install.py", line 63, in doConfiguration
:    writeNetworkConf(storage, ksdata, instClass)
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/tmp/updates/pyanaconda/threads.py", line 87, in run
:    threading.Thread.run(self, *args, **kwargs)
:IOError: [Errno 2] No such file or directory: '/mnt/sysimage/etc/sysconfig/network-scripts/ifcfg-wlan0'
Comment 1 Kamil Páral 2012-10-11 05:42:31 EDT
Created attachment 625441 [details]
File: anaconda-tb
Comment 2 Kamil Páral 2012-10-11 05:42:33 EDT
Created attachment 625442 [details]
File: product
Comment 3 Kamil Páral 2012-10-11 05:42:35 EDT
Created attachment 625443 [details]
File: type
Comment 4 Kamil Páral 2012-10-11 05:42:37 EDT
Created attachment 625444 [details]
File: ifcfg.log
Comment 5 Kamil Páral 2012-10-11 05:42:40 EDT
Created attachment 625445 [details]
File: storage.log
Comment 6 Kamil Páral 2012-10-11 05:42:42 EDT
Created attachment 625446 [details]
File: version
Comment 7 Kamil Páral 2012-10-11 05:42:44 EDT
Created attachment 625447 [details]
File: environ
Comment 8 Kamil Páral 2012-10-11 05:42:46 EDT
Created attachment 625448 [details]
File: anaconda.log
Comment 9 Kamil Páral 2012-10-11 05:42:49 EDT
Created attachment 625449 [details]
File: syslog
Comment 10 Kamil Páral 2012-10-11 05:42:51 EDT
Created attachment 625450 [details]
File: hashmarkername
Comment 11 Kamil Páral 2012-10-11 05:42:54 EDT
Created attachment 625451 [details]
File: packaging.log
Comment 12 Kamil Páral 2012-10-11 05:42:56 EDT
Created attachment 625452 [details]
File: cmdline_file
Comment 13 Kamil Páral 2012-10-11 05:42:58 EDT
Created attachment 625453 [details]
File: release
Comment 14 Kamil Páral 2012-10-11 05:43:01 EDT
Created attachment 625454 [details]
File: program.log
Comment 15 Kamil Páral 2012-10-11 05:47:13 EDT
This seems to be really similar to bug 860791.
Comment 16 Vratislav Podzimek 2012-10-11 05:53:03 EDT
(In reply to comment #15)
> This seems to be really similar to bug 860791.
It's another similar issue.

Please try this updates.img

http://vpodzime.fedorapeople.org/f18tc3_wifi.img
Comment 17 Kamil Páral 2012-10-11 06:12:39 EDT
Hey ho, that works!
Comment 18 Fedora Update System 2012-10-11 21:05:46 EDT
anaconda-18.16-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.16-1.fc18
Comment 19 Ladislav Jozsa 2012-10-12 09:02:59 EDT
This exception has occured during 'Writing network configuration' phase in the default install with encrypted disk / autopart.

Package: anaconda-18.14
OS Release: Fedora release 18-Beta-TC3
Comment 20 Jacobo Cabaleiro 2012-10-12 13:43:27 EDT
Similar to Ladislav, exception raised on F18 Beta TC3 686 when "Writing network configuration". Have bug report data, but I'll try first with the updates.img and will report back.
Comment 21 Fedora Update System 2012-10-12 13:55:07 EDT
Package anaconda-18.16-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.16-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16018/anaconda-18.16-1.fc18
then log in and leave karma (feedback).
Comment 22 Jacobo Cabaleiro 2012-10-12 15:02:47 EDT
Tested with Vratislav updates and the exception is no longer raised in my case. Solved for me.
Comment 23 Fedora Update System 2012-10-16 23:08:53 EDT
anaconda-18.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.17-1.fc18
Comment 24 Fedora Update System 2012-10-17 22:37:50 EDT
anaconda-18.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.18-1.fc18
Comment 25 Fedora Update System 2012-10-19 21:33:35 EDT
anaconda-18.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.19-1.fc18
Comment 26 Adam Williamson 2012-11-22 23:46:30 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

(ref comment #22)