Bug 862801 - Anaconda hangs when 'Configuring installed system'
Anaconda hangs when 'Configuring installed system'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Dan Mashal
AcceptedBlocker
:
: 860533 864547 864760 (view as bug list)
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-10-03 11:05 EDT by Martin Krizek
Modified: 2012-10-23 09:00 EDT (History)
19 users (show)

See Also:
Fixed In Version: anaconda-18.16-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 918776 (view as bug list)
Environment:
Last Closed: 2012-10-23 09:00:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (7.54 KB, text/plain)
2012-10-03 11:06 EDT, Martin Krizek
no flags Details
ifcfg.log (2.61 KB, text/plain)
2012-10-03 11:07 EDT, Martin Krizek
no flags Details
packaging.log (142 bytes, text/plain)
2012-10-03 11:07 EDT, Martin Krizek
no flags Details
program.log (292.71 KB, text/plain)
2012-10-03 11:08 EDT, Martin Krizek
no flags Details
storage.log (279.03 KB, text/plain)
2012-10-03 11:08 EDT, Martin Krizek
no flags Details
syslog (KVM install) (67.04 KB, text/plain)
2012-10-05 11:37 EDT, Jurgen Kramer
no flags Details
all logs tarred for good measure (78.08 KB, application/x-gzip)
2012-10-05 11:42 EDT, Jurgen Kramer
no flags Details
Logs from Lenovo ThinkPad X230 (57.24 KB, application/octet-stream)
2012-10-06 16:33 EDT, Felix Kaechele
no flags Details
anaconda.log (16.66 KB, text/plain)
2012-10-08 06:11 EDT, Kamil Páral
no flags Details
program.log (366.88 KB, text/plain)
2012-10-08 06:12 EDT, Kamil Páral
no flags Details
storage.log (613.60 KB, text/plain)
2012-10-08 06:12 EDT, Kamil Páral
no flags Details
messages (253.61 KB, text/plain)
2012-10-08 06:12 EDT, Kamil Páral
no flags Details
Threading code changes used for a test (9.21 KB, patch)
2012-10-09 09:31 EDT, Martin Sivák
no flags Details | Diff
strace from anaconda (4.61 MB, text/plain)
2012-10-09 09:37 EDT, Petr Schindler
no flags Details
anaconda.log (6.56 KB, text/plain)
2012-10-10 10:04 EDT, Marcos Mello
no flags Details
program.log (21.40 KB, text/plain)
2012-10-10 10:05 EDT, Marcos Mello
no flags Details
storage.log (68.90 KB, text/plain)
2012-10-10 10:06 EDT, Marcos Mello
no flags Details

  None (edit)
Description Martin Krizek 2012-10-03 11:05:44 EDT
Description of problem:
When state 'Configuring installed system' is reached, Anaconda hangs consuming 100% of cpu. Fedora 18 Beta TC1 Desktop Live x86_64 on USB stick (copied using dd) was used. When rebooted manually, the system seems to be installed just fine though. I hit this on bare metal, wasn't able to reproduce it in VM. Logs attached.

Version-Release number of selected component (if applicable):
anaconda-18.11-1.fc18.x86_64

How reproducible:
always

Steps to Reproduce:
1. Boot Fedora 18 Beta TC1 Live and select default installation
  
Actual results:
Anaconda hangs.

Expected results:
Anaconda completes the installation.
Comment 1 Martin Krizek 2012-10-03 11:06:42 EDT
Created attachment 620980 [details]
anaconda.log
Comment 2 Martin Krizek 2012-10-03 11:07:12 EDT
Created attachment 620981 [details]
ifcfg.log
Comment 3 Martin Krizek 2012-10-03 11:07:42 EDT
Created attachment 620982 [details]
packaging.log
Comment 4 Martin Krizek 2012-10-03 11:08:02 EDT
Created attachment 620983 [details]
program.log
Comment 5 Martin Krizek 2012-10-03 11:08:27 EDT
Created attachment 620984 [details]
storage.log
Comment 6 Martin Krizek 2012-10-03 11:10:59 EDT
Proposing as a Beta blocker per (Alpha) criterion: "The installer must be able to complete an installation using the text, graphical and VNC installation interfaces."
Comment 7 Jesse Keating 2012-10-03 12:58:42 EDT
Did you boot this install with selinux=0 or did you disable selinux in some other way?
Comment 8 satellitgo 2012-10-03 15:18:16 EDT
saw this on f18-Beta-TC1 DVD and netinstall CD's
Install to USB HD
System booted fine afterwards
Comment 9 Adam Williamson 2012-10-03 15:23:37 EDT
Discussed at 2012-10-03 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-03/f18-beta-blocker-review-2.2012-10-03-16.00.log.txt . There are indications that more than one system has hit this - I think I hit it myself once, but don't recall the details - but we don't yet have it nailed down. There's a possibility this affects enough systems to be a blocker, so we are leaving it open to collect more data and re-evaluate later.
Comment 10 Adam Williamson 2012-10-03 15:24:15 EDT
note that we think satellit's case sounds more like https://bugzilla.redhat.com/show_bug.cgi?id=860791 than this bug.
Comment 11 Martin Krizek 2012-10-04 02:41:37 EDT
(In reply to comment #7)
> Did you boot this install with selinux=0 or did you disable selinux in some
> other way?

No, I did not.
Comment 12 Chris Lumens 2012-10-04 10:08:24 EDT
Can we also get the syslog?
Comment 13 Jens Petersen 2012-10-05 02:21:18 EDT
Might be good to retest with 18.12 in Beta TC2.
Comment 14 Kamil Páral 2012-10-05 10:20:33 EDT
This seems to hit more people:
http://lists.fedoraproject.org/pipermail/test/2012-October/110648.html
Comment 15 Jurgen Kramer 2012-10-05 11:36:32 EDT
I had already destroyed the F18 Beta TC2 VM as networking was not working and somehow /sbin/ifconfig was missing (?). I did a reinstall and got the same systems, anaconda hanging at 'Configuring installed system'.


I'll attach syslog.
Comment 16 Jurgen Kramer 2012-10-05 11:37:46 EDT
Created attachment 622284 [details]
syslog (KVM install)
Comment 17 Jurgen Kramer 2012-10-05 11:42:52 EDT
Created attachment 622287 [details]
all logs tarred for good measure
Comment 18 satellitgo 2012-10-05 11:50:47 EDT
Installed gnome3.6.0 with F18_Beta-TC2-x86_64 DVD last night
Anaconda install hung with "Configuring installed system"
after 1 hour I powered off system. Install booted to firstboot and gdm login fine
_ missing signal for reboot message in anaconda could be the the problem?
FYI https://bugzilla.redhat.com/show_bug.cgi?id=860791 occured at the same point in install in TC1 is this related?
Comment 19 Felix Kaechele 2012-10-06 16:33:09 EDT
Created attachment 622807 [details]
Logs from Lenovo ThinkPad X230

Here are some logs from real hardware. Lenovo ThinkPad X230 (Model 2325-2DG).
Tested with Beta TC2.
Also tested with anaconda 18.13 from koji. Same problem but did not keep the logs.
Comment 20 Kamil Páral 2012-10-08 06:11:44 EDT
I've encountered this too, on a bare metal machine with Beta TC2. Adding logs.
Comment 21 Kamil Páral 2012-10-08 06:11:59 EDT
Created attachment 623378 [details]
anaconda.log
Comment 22 Kamil Páral 2012-10-08 06:12:04 EDT
Created attachment 623379 [details]
program.log
Comment 23 Kamil Páral 2012-10-08 06:12:09 EDT
Created attachment 623380 [details]
storage.log
Comment 24 Kamil Páral 2012-10-08 06:12:15 EDT
Created attachment 623381 [details]
messages
Comment 25 Vratislav Podzimek 2012-10-09 07:40:22 EDT
In pdb and gdb sessions we found out it hangs in isys.isWirelessDevice. It might be related to Gdk threads locks we use.
Comment 26 Jan Sedlák 2012-10-09 08:15:14 EDT
I have tried "textinstall" several times and I hadn't encountered this bug.
Comment 27 Martin Sivák 2012-10-09 09:31:33 EDT
Created attachment 624104 [details]
Threading code changes used for a test

Also strace reports SIGSEGV signal somewhere (not in Anaconda as it is still running) so we are trying to figure out the relationship between libnm-glib (called from isys), GObject and Gdk locks and Gtk vs. Glib (used to process udev events) mainloop.

The hang happened in Writing network configuration step even when the attached patch was applied (uses Gdk.threads_enter only when necessary and fixes thread initialization).
Comment 28 Petr Schindler 2012-10-09 09:37:07 EDT
Created attachment 624106 [details]
strace from anaconda
Comment 29 Chris Lumens 2012-10-09 10:47:56 EDT
*** Bug 864547 has been marked as a duplicate of this bug. ***
Comment 30 Dan Mashal 2012-10-09 23:40:19 EDT
Reproduced in beta TC3 DVD install
Comment 31 Jens Petersen 2012-10-10 03:13:06 EDT
For me it hangs when installing onto my T500 but not in virt-manager guests.
Comment 32 Kamil Páral 2012-10-10 05:07:57 EDT
With F18 Beta TC3 Live, it now hangs during "Writing network configuration", that means one step further. But it might just be a glitch.
Comment 33 Martin Sivák 2012-10-10 05:36:04 EDT
Yep, it always hangs at that spot. Gtk sometimes doesn't redraw the screen fast enough.
Comment 34 Vratislav Podzimek 2012-10-10 07:42:24 EDT
Okay, I've found out that the hang happens on the following line:
>    client = nm_client_new();
>(pyanaconda/isys/iface.c:635)
which tries to get new instance of NMClient over DBus. We have also found out that this is probably the only place where we use DBus from a non-main thread. While main thread is running Gtk main loop the separate thread tries to use the same loop for dbus calls which probably causes the hang. It also explains why the issue does not happen in text mode.

We have been doing a revision of Gdk/GLib threading initialization and usage in anaconda. Let's hope it will help.
Comment 35 Marcos Mello 2012-10-10 10:02:45 EDT
Having this too with Beta TC3 when "Configuring installed system".
Comment 36 Marcos Mello 2012-10-10 10:04:42 EDT
Created attachment 624880 [details]
anaconda.log
Comment 37 Marcos Mello 2012-10-10 10:05:33 EDT
Created attachment 624881 [details]
program.log
Comment 38 Marcos Mello 2012-10-10 10:06:40 EDT
Created attachment 624888 [details]
storage.log
Comment 39 Adam Williamson 2012-10-10 13:27:06 EDT
Discussed at 2012-10-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-10/f18beta-blocker-review-3.2012-10-10-16.05.log.txt . Accepted as a blocker per criterion "The installer must be able to complete an installation using the text, graphical and VNC installation interfaces" (even though it turns out the installed system boots, it's certainly true that the install does not 'complete').
Comment 40 Chris Lumens 2012-10-10 22:19:25 EDT
*** Bug 864760 has been marked as a duplicate of this bug. ***
Comment 41 Dan Mashal 2012-10-11 00:43:36 EDT
Not fixed in smoke 7 build netinst.

However, rebooting now during that phase gets you firstboot upon reboot.
Comment 42 Adam Williamson 2012-10-11 00:59:45 EDT
if you weren't getting firstboot before, that was https://bugzilla.redhat.com/show_bug.cgi?id=863886 . nothing to do with this bug. this bug is not expected to be fixed yet. it's still set NEW and has no 'fixed in version' set.
Comment 43 Vratislav Podzimek 2012-10-11 05:06:19 EDT
Updates image with the patch that seems to resolve this issue is available at:
http://vpodzime.fedorapeople.org/f18_tc3_hang.img

Kamil, could you please test it?
Comment 44 Kamil Páral 2012-10-11 05:43:35 EDT
(In reply to comment #43)
> Updates image with the patch that seems to resolve this issue is available
> at:
> http://vpodzime.fedorapeople.org/f18_tc3_hang.img
> 
> Kamil, could you please test it?

With the updates.img I stumbled upon bug 865355.
Comment 45 Martin Krizek 2012-10-11 06:19:44 EDT
The updates.img works for me (note: on a machine with no wifi).
Comment 46 Vratislav Podzimek 2012-10-11 06:48:27 EDT
(In reply to comment #44)
> (In reply to comment #43)
> > Updates image with the patch that seems to resolve this issue is available
> > at:
> > http://vpodzime.fedorapeople.org/f18_tc3_hang.img
> > 
> > Kamil, could you please test it?
> 
> With the updates.img I stumbled upon bug 865355.
Yeah, but this means it went through the potential hang without any problems.
Comment 47 Dan Mashal 2012-10-11 18:20:28 EDT
This seemed to be fixed on smoke7 it just took a really long time.
Comment 48 satellitgo 2012-10-11 19:53:38 EDT
I did a netinstall of MATE with http://dl.fedoraproject.org/pub/alt/qa/18/20121010_f18b-smoke7/Fedora-18b-smoke7-x86_64-netinst.iso last night. 

(anaconda 18.15) It exited to a black screen after "installing bootloader" screen. There was no screen saying completed and asking for a reboot.

cold boot went to firstboot and sucessful login
Comment 49 Fedora Update System 2012-10-11 21:05:52 EDT
anaconda-18.16-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.16-1.fc18
Comment 50 Vratislav Podzimek 2012-10-12 03:48:37 EDT
(In reply to comment #48)
> I did a netinstall of MATE with
> http://dl.fedoraproject.org/pub/alt/qa/18/20121010_f18b-smoke7/Fedora-18b-
> smoke7-x86_64-netinst.iso last night. 
> 
> (anaconda 18.15) It exited to a black screen after "installing bootloader"
> screen. There was no screen saying completed and asking for a reboot.
This is the other possible result of this bug. Please try some build with anaconda-18.16-1.fc18 or the updates.img mentioned in commend #43 [1]

[1] http://fedoraproject.org/wiki/Anaconda/Updates#Updates_from_the_Network
Comment 51 Robert Knight 2012-10-12 05:06:11 EDT
updates.img works for me on conventional hardware.
Comment 52 Fedora Update System 2012-10-12 13:55:16 EDT
Package anaconda-18.16-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.16-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16018/anaconda-18.16-1.fc18
then log in and leave karma (feedback).
Comment 53 satellitgo 2012-10-14 22:12:45 EDT
anaconda 18.16 in TC4 lives, DVD and netinstall x86_64 goes to reboot screen and has warning to set root password while installing.
Comment 54 Kamil Páral 2012-10-16 07:30:02 EDT
*** Bug 860533 has been marked as a duplicate of this bug. ***
Comment 55 Kamil Páral 2012-10-16 07:31:05 EDT
This no longer happens in Beta TC4.
Comment 56 Fedora Update System 2012-10-16 23:08:59 EDT
anaconda-18.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.17-1.fc18
Comment 57 Fedora Update System 2012-10-17 13:30:40 EDT
Package anaconda-18.17-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.17-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16295/anaconda-18.17-1.fc18
then log in and leave karma (feedback).
Comment 58 Adam Williamson 2012-10-17 20:05:28 EDT
Back to VERIFIED.
Comment 59 Fedora Update System 2012-10-17 22:37:56 EDT
anaconda-18.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.18-1.fc18
Comment 60 Fedora Update System 2012-10-18 11:30:16 EDT
Package anaconda-18.18-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.18-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16402/anaconda-18.18-1.fc18
then log in and leave karma (feedback).
Comment 61 Adam Williamson 2012-10-18 17:32:46 EDT
aaaand again.
Comment 62 Fedora Update System 2012-10-19 21:33:41 EDT
anaconda-18.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.19-1.fc18
Comment 63 Fedora Update System 2012-10-19 23:51:52 EDT
Package anaconda-18.19-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.19-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16528/anaconda-18.19-1.fc18
then log in and leave karma (feedback).
Comment 64 Kamil Páral 2012-10-23 09:00:11 EDT
This is fixed, anaconda is stable, closing.

Note You need to log in before you can comment on or make changes to this bug.