Bug 860791 - IOError: [Errno 2] No such file or directory: '/etc/sysconfig/network-scripts/ifcfg-wlan0'
IOError: [Errno 2] No such file or directory: '/etc/sysconfig/network-scripts...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
abrt_hash:b275383e83a6ae4afd782e00587...
:
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-09-26 13:46 EDT by Ladislav Jozsa
Modified: 2012-12-14 06:50 EST (History)
9 users (show)

See Also:
Fixed In Version: anaconda-18.12-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-08 10:35:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: ifcfg.log (1.31 KB, text/plain)
2012-09-26 13:46 EDT, Ladislav Jozsa
no flags Details
File: anaconda-tb (492.95 KB, text/plain)
2012-09-26 13:46 EDT, Ladislav Jozsa
no flags Details
File: product (6 bytes, text/plain)
2012-09-26 13:46 EDT, Ladislav Jozsa
no flags Details
File: type (9 bytes, text/plain)
2012-09-26 13:46 EDT, Ladislav Jozsa
no flags Details
File: environ (761 bytes, text/plain)
2012-09-26 13:47 EDT, Ladislav Jozsa
no flags Details
File: storage.log (206.72 KB, text/plain)
2012-09-26 13:47 EDT, Ladislav Jozsa
no flags Details
File: version (2 bytes, text/plain)
2012-09-26 13:47 EDT, Ladislav Jozsa
no flags Details
File: program.log (63.19 KB, text/plain)
2012-09-26 13:47 EDT, Ladislav Jozsa
no flags Details
File: anaconda.log (7.51 KB, text/plain)
2012-09-26 13:47 EDT, Ladislav Jozsa
no flags Details
File: syslog (130.60 KB, text/plain)
2012-09-26 13:47 EDT, Ladislav Jozsa
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-09-26 13:47 EDT, Ladislav Jozsa
no flags Details
File: packaging.log (37.00 KB, text/plain)
2012-09-26 13:47 EDT, Ladislav Jozsa
no flags Details
File: cmdline_file (85 bytes, text/plain)
2012-09-26 13:47 EDT, Ladislav Jozsa
no flags Details
File: release (24 bytes, text/plain)
2012-09-26 13:47 EDT, Ladislav Jozsa
no flags Details
File: description (1.22 KB, text/plain)
2012-09-26 13:47 EDT, Ladislav Jozsa
no flags Details

  None (edit)
Description Ladislav Jozsa 2012-09-26 13:46:49 EDT
Version-Release number of selected component:
anaconda-18.8

Additional info:
libreport version: 2.0.12
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.0-0.rc6.git0.2.fc18.i686
Comment 1 Ladislav Jozsa 2012-09-26 13:46:51 EDT
Created attachment 617679 [details]
File: ifcfg.log
Comment 2 Ladislav Jozsa 2012-09-26 13:46:55 EDT
Created attachment 617680 [details]
File: anaconda-tb
Comment 3 Ladislav Jozsa 2012-09-26 13:46:57 EDT
Created attachment 617681 [details]
File: product
Comment 4 Ladislav Jozsa 2012-09-26 13:46:59 EDT
Created attachment 617682 [details]
File: type
Comment 5 Ladislav Jozsa 2012-09-26 13:47:01 EDT
Created attachment 617683 [details]
File: environ
Comment 6 Ladislav Jozsa 2012-09-26 13:47:04 EDT
Created attachment 617684 [details]
File: storage.log
Comment 7 Ladislav Jozsa 2012-09-26 13:47:06 EDT
Created attachment 617685 [details]
File: version
Comment 8 Ladislav Jozsa 2012-09-26 13:47:09 EDT
Created attachment 617686 [details]
File: program.log
Comment 9 Ladislav Jozsa 2012-09-26 13:47:13 EDT
Created attachment 617687 [details]
File: anaconda.log
Comment 10 Ladislav Jozsa 2012-09-26 13:47:15 EDT
Created attachment 617688 [details]
File: syslog
Comment 11 Ladislav Jozsa 2012-09-26 13:47:17 EDT
Created attachment 617689 [details]
File: hashmarkername
Comment 12 Ladislav Jozsa 2012-09-26 13:47:20 EDT
Created attachment 617690 [details]
File: packaging.log
Comment 13 Ladislav Jozsa 2012-09-26 13:47:22 EDT
Created attachment 617691 [details]
File: cmdline_file
Comment 14 Ladislav Jozsa 2012-09-26 13:47:24 EDT
Created attachment 617692 [details]
File: release
Comment 15 Ladislav Jozsa 2012-09-26 13:47:29 EDT
Created attachment 617693 [details]
File: description
Comment 16 Jens Petersen 2012-09-30 23:41:39 EDT
In Live install after installing bootloader this backtrace happened

Package: anaconda-18.10-1.fc18.x86_64
Architecture: x86_64
OS Release: Fedora release 18
Comment 17 Kamil Páral 2012-10-02 08:15:39 EDT
I just started installation (from PXE) with previous F17 installation on the disk.

Package: anaconda-18.8
OS Release: Fedora release 18
Comment 18 Kamil Páral 2012-10-02 08:44:42 EDT
Correction, this happens after the installation is complete, in the "Configuring installed system" step.
Comment 19 Radek Vykydal 2012-10-02 17:03:35 EDT
Patch posted for review.

You can check updates image with fix:
http://rvykydal.fedorapeople.org/updates.860791.img
Comment 20 Jens Petersen 2012-10-03 04:57:23 EDT
(Just for the record the system does boot after this backtrace.)
Comment 21 Adam Williamson 2012-10-03 13:52:58 EDT
Discussed at 2012-10-03 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-03/f18-beta-blocker-review-2.2012-10-03-16.00.log.txt . We agreed this looks like a serious issue - even though the installed system boots, crashes during the install process are always bad and it means some late system configuration steps probably didn't happen - but we don't have enough data on exactly what the circumstances are that trigger this bug to make a decision on blocker status. If people can isolate the triggering circumstances more precisely we will re-evaluate this at the next meeting, if it has not already been closed by then.
Comment 22 satellitgo 2012-10-03 15:48:31 EDT
install from live ,DVD;netinstall to HD
occurs at end of install


Package: anaconda-18.11-1.fc18.x86_64
OS Release: Fedora release 18
Comment 23 Fedora Update System 2012-10-03 20:57:03 EDT
anaconda-18.12-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.12-1.fc18
Comment 24 satellitgo 2012-10-04 13:50:23 EDT
install sugar-desktop DE from F18-Beta-TC1 DVD x86_64
occurs in configuring system


Package: anaconda-18.11
OS Release: Fedora release 18-Beta-TC1
Comment 25 Fedora Update System 2012-10-04 13:50:46 EDT
Package anaconda-18.12-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.12-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15378/anaconda-18.12-1.fc18
then log in and leave karma (feedback).
Comment 26 satellitgo 2012-10-04 18:56:10 EDT
f18-Beta-TC2-x86_64  Netinstall hangs on final step
"Configuring Installed System"
no error message but seems to be same error seen on TC1 Netinstall

Wish anaconda would allow deleting the autodetected wlan0 (wireless entry) as I suspect that this is the cause of the error
Comment 27 Jens Petersen 2012-10-05 01:49:24 EDT
(In reply to comment #26)
> f18-Beta-TC2-x86_64  Netinstall hangs on final step
> "Configuring Installed System"
> no error message but seems to be same error seen on TC1 Netinstall
> 
> Wish anaconda would allow deleting the autodetected wlan0 (wireless entry)
> as I suspect that this is the cause of the error

Did you have an existing partition on the HD?

I found with current anaconda installs only start/succeed
if I delete any existing partition before booting to install.

Anyway I can confirm that with anaconda-18.12 install
no longer hangs or crashes for me because of wlan0.
Comment 28 Kamil Páral 2012-10-08 08:11:25 EDT
I no longer see this issue, but now, with anaconda 18.12, the wired network is disabled by default after installation (I used LiveCD). It is very likely related to the recent fix. Should I report a new bug or will we handle it here?
Comment 29 Radek Vykydal 2012-10-08 08:28:50 EDT
(In reply to comment #28)
> I no longer see this issue, but now, with anaconda 18.12, the wired network
> is disabled by default after installation (I used LiveCD). It is very likely
> related to the recent fix. Should I report a new bug or will we handle it
> here?

Please report a new bug. Thanks.
Comment 30 Kamil Páral 2012-10-08 10:35:58 EDT
(In reply to comment #29)
> Please report a new bug. Thanks.

OK, bug 864087.

This one is fixed and pushed stable (and part of F18 Beta TC2), closing.
Comment 31 derrien 2012-12-14 06:50:09 EST
Same thing with anaconda 18.29.2 kickstart install and noipv6 boot option :

anaconda 18.29.2 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/simpleconfig.py", line 77, in read
    with open(filename) as f:
  File "/usr/lib64/python2.7/site-packages/pyanaconda/simpleconfig.py", line 187, in read
    SimpleConfigFile.read(self, self.path)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 285, in loadIfcfgFile
    IfcfgFile.read(self)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 769, in get_ifcfg_value
    dev.loadIfcfgFile()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 811, in <genexpr>
    for dev in getDevices())):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 811, in disableIPV6
    for dev in getDevices())):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 877, in writeNetworkConf
    disableIPV6(ROOT_PATH)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 71, in doConfiguration
    writeNetworkConf(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
    threading.Thread.run(self, *args, **kwargs)
IOError: [Errno 2] No such file or directory: '/etc/sysconfig/network-scripts/ifcfg-wlan0'

Local variables in innermost frame:
self: 
filename: /etc/sysconfig/network-scripts/ifcfg-wlan0

Note You need to log in before you can comment on or make changes to this bug.