Bug 870371

Summary: abrt always found a different bug as a duplicate
Product: [Fedora] Fedora Reporter: Yann Droneaud <yann>
Component: abrtAssignee: abrt <abrt-devel-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: abrt-devel-list, dvlasenk, iprikryl, jfilak, jmoskovc, kklic, mmilata, mtoman
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-26 05:47:12 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
ABRT spool directory for the crash none

Description Yann Droneaud 2012-10-26 05:39:27 EDT
Created attachment 633777 [details]
ABRT spool directory for the crash

A lot of crashes are reported against gvfs-smb from Fedora 15 instead of gvfs from Fedora 16 and/or Fedora 17.

This is reported as bug #723076 which is closed with WONTFIX resolution since it apply to Fedora 15. Crashes are still common on Fedora 17, but can't be reported since abrt always find bug #723076 as a duplicate.

It is expected that abrt fill a new bug against the correct package and correct distribution version.

Note: this problem is looking like bug #656735
Comment 1 Jakub Filak 2012-10-26 05:47:12 EDT
Thanks for the report!

*** This bug has been marked as a duplicate of bug 849833 ***
Comment 2 Yann Droneaud 2012-10-26 05:59:16 EDT
(In reply to comment #1)
> Thanks for the report!
> 
> *** This bug has been marked as a duplicate of bug 849833 ***


When looking at the different backtrace, I'm really not sure the problem is about a same bug in different distribution version".


Eg, the initial bug report is about:

"_dbus_warn_check_failed (format=0x3c5d2313a8 "The last reference on a connection was dropped without closing the connection. This is a bug in an application. See dbus_connection_unref() documentation for details.\n%s") at dbus-internals.c:289"


While my backtrace is about:

" _dbus_warn_check_failed (format=
    0x3520236290 "arguments to %s() were incorrect, assertion \"%s\" failed in file %s line %d.\nThis is normally a bug in some application using the D-Bus library.\n") at dbus-internals.c:289"

The most recent part of the backtraces are the same: in the end "raise()" is called but it's not for the same reason. So why it is considered a duplicate ?

Could you please check this in the reports. Regards.
Comment 3 Yann Droneaud 2012-10-26 06:08:41 EDT
Additionally the initial backtrace of bug #723076 is about gvfsd-smb while mine is about gvfsd-cdda.
Comment 4 Jakub Filak 2012-10-26 07:06:39 EDT
D'oh, you are right. Thank you! It is a duplicate of bug 845097 and it is caused by limitation of the ABRT server for deduplication. The simplified crash reporting [1] should fix this issues.

[1] : https://fedoraproject.org/wiki/Features/SimplifiedCrashReporting

*** This bug has been marked as a duplicate of bug 845097 ***