Bug 875028

Summary: Gnome Shell extensions in F18 repo are not compatible
Product: [Fedora] Fedora Reporter: Martin <mholec>
Component: gnome-shell-extensionsAssignee: Rahul Sundaram <metherid>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: asrv01, bugzilla, collura, emc986, finaglesghost, lars, metherid, michel, pikachu.2014, rebus, tpelka, vbenes
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-02-05 07:57:26 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Martin 2012-11-09 06:30:08 EST
Description of problem:
Gnome Shell extensions in F18 repo are not compatible

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install gnome-tweak-tool and gnome-shell-extension-*
2. Open gnome-tweak-tool or https://extensions.gnome.org/
3. Look for installed extensions.
  
Actual results:
Installed extensions are not available.
Comment 1 Mohamed El Morabity 2012-11-09 07:55:42 EST
What are the versions of GNOME Shell and installed extensions? Launch the following command to the them:
> rpm -qa gnome-shell\*
Comment 2 Mohamed El Morabity 2012-11-09 15:30:41 EST
*** Bug 875030 has been marked as a duplicate of this bug. ***
Comment 3 Martin 2012-11-12 11:02:13 EST
gnome-shell-extension-native-window-placement-3.6.1-1.fc18.noarch
gnome-shell-extension-remove-volume-icon-0.4.0-2.fc18.noarch
gnome-shell-extension-noripple-2.0-2.fc18.noarch
gnome-shell-extension-noim-1.0-5.fc18.noarch
gnome-shell-extension-remove-accessibility-icon-20111008-4.fc18.noarch
gnome-shell-extension-icon-manager-0-0.7.git37fbd9a.fc18.noarch
gnome-shell-extension-remove-bluetooth-icon-0.3.0-2.fc18.noarch
gnome-shell-extension-calc-0-0.4.git2fca097.fc18.noarch
gnome-shell-extension-fedmsg-0.1.0-3.fc18.noarch
gnome-shell-extension-dock-3.6.1-1.fc18.noarch
gnome-shell-extension-pomodoro-0-0.3.git13030cd.fc17.noarch
gnome-shell-extension-workspace-indicator-3.6.1-1.fc18.noarch
gnome-shell-extension-places-menu-3.6.1-1.fc18.noarch
gnome-shell-extension-presentation-mode-0-0.4.gitc3ce6b2.fc18.noarch
gnome-shell-3.6.1-3.fc18.x86_64
gnome-shell-extension-xrandr-indicator-3.6.1-1.fc18.noarch
gnome-shell-extension-systemMonitor-3.6.1-1.fc18.noarch
gnome-shell-extension-drive-menu-3.6.1-1.fc18.noarch
gnome-shell-extension-user-theme-3.6.1-1.fc18.noarch
gnome-shell-extension-sustmi-historymanager-prefix-search-3.0-7.git72282ce.fc18.noarch
gnome-shell-extension-iok-0.20121107-3.fc18.noarch
gnome-shell-extension-alternative-status-menu-3.6.1-1.fc18.noarch
gnome-shell-extension-righthotcorner-1.0-3.fc18.noarch
gnome-shell-extension-workspacesmenu-0-3.fc18.noarch
gnome-shell-extension-cpu-temperature-0-0.8.gite1777e6.fc18.noarch
gnome-shell-extension-alternate-tab-3.6.1-1.fc18.noarch
gnome-shell-extension-weather-0-0.9.gitf7c4aea.fc18.noarch
gnome-shell-extension-auto-move-windows-3.6.1-1.fc18.noarch
gnome-shell-extension-pidgin-0-0.8.git87fc23433d.fc18.x86_64
gnome-shell-extension-gpaste-2.9-1.fc18.noarch
gnome-shell-extension-mediaplayers-0-0.4.git1225d49.fc18.noarch
gnome-shell-extension-windowsNavigator-3.6.1-1.fc18.noarch
gnome-shell-extension-sustmi-windowoverlay-icons-3.0-7.git72282ce.fc18.noarch
gnome-shell-extension-common-3.6.1-1.fc18.noarch
gnome-shell-extension-apps-menu-3.6.1-1.fc18.noarch
gnome-shell-extension-pidgin-debuginfo-0-0.8.git87fc23433d.fc18.x86_64
Comment 4 Mohamed El Morabity 2012-12-29 21:00:04 EST
Sorry for this late answer. Did you refresh GNOME Shell once the extensions installed? It's a necessary step since Fedora 16/GNOME 3.2 to make available freshly installed extensions by yum. Unfortunately we don't have yet any post-install trigger to make available such extensions to the current user session without relaunching GNOME Shell.
Comment 5 Steve 2013-01-20 07:07:21 EST
I can confirm this bug.
Comment 6 Erik 2013-01-27 17:31:43 EST
I can confirm this bug too.

Regardless of refreshing gnome shell, restarting the X server and restarting entirely.

Also can't seem to turn off fedmsg.
Comment 7 collura 2013-01-31 03:03:27 EST
the related bug for gnome-shell-extension-cpu-temperature:

  https://bugzilla.redhat.com/show_bug.cgi?id=906090

had a handy way to check if an extension was actually up to date by checking the gnome version number listed in its configuration files.
Comment 8 Michal Ambroz 2013-02-01 13:23:37 EST
I can confirm this bug in Fedora 18.
Issue is even reported by the gnome-shell when restarted.

      JS LOG: Extension "mediasplayers@ycdref" had error: Error: extension is not compatible with current GNOME Shell and/or GJS version
      JS LOG: Extension "presentationmode@ampad.de" had error: Error: extension is not compatible with current GNOME Shell and/or GJS version
      JS LOG: Extension "calc@patapon.info" had error: Error: extension is not compatible with current GNOME Shell and/or GJS version
      JS LOG: Extension "pidgin-conversation-integration@kagesenshi.org" had error: Error: extension is not compatible with current GNOME Shell and/or GJS version
      JS LOG: Extension "icon-manager@krajniak.info" had error: Error: extension is not compatible with current GNOME Shell and/or GJS version
      JS LOG: Extension "noim@fpmurphy.com" had error: Error: extension is not compatible with current GNOME Shell and/or GJS version
      JS LOG: Extension "righthotcorner@fpmurphy.com" had error: Error: extension is not compatible with current GNOME Shell and/or GJS version
      JS LOG: Extension "remove-volume-icon@affolter-engineering.ch" had error: Error: extension is not compatible with current GNOME Shell and/or GJS version
      JS LOG: Extension "windowoverlay-icons@sustmidown.centrum.cz" had error: Error: extension is not compatible with current GNOME Shell and/or GJS version
      JS LOG: loading default theme (Adwaita)
      JS LOG: Extension "historymanager-prefix-search@sustmidown.centrum.cz" had error: Error: extension is not compatible with current GNOME Shell and/or GJS version
      JS LOG: Extension "remove-bluetooth-icon@affolter-engineering.ch" had error: Error: extension is not compatible with current GNOME Shell and/or GJS version
      JS LOG: Extension "remove-accessibility-icon@martin-weusten.de" had error: Error: extension is not compatible with current GNOME Shell and/or GJS version
      JS LOG: Extension "workspacesmenu@fpmurphy.com" had error: Error: extension is not compatible with current GNOME Shell and/or GJS version
      JS LOG: Extension "noripple@fpmurphy.com" had error: Error: extension is not compatible with current GNOME Shell and/or GJS version
      JS LOG: Extension "temperature@xtranophilist" had error: Error: extension is not compatible with current GNOME Shell and/or GJS version

---------------------
$locate mediasplayers@ycdref
/usr/share/gnome-shell/extensions/mediasplayers@ycdref
/usr/share/gnome-shell/extensions/mediasplayers@ycdref/extension.js
/usr/share/gnome-shell/extensions/mediasplayers@ycdref/metadata.json
/usr/share/gnome-shell/extensions/mediasplayers@ycdref/stylesheet.css

---------------------
$ rpm -qf /usr/share/gnome-shell/extensions/mediasplayers@ycdref
gnome-shell-extension-mediaplayers-0-0.4.git1225d49.fc18.noarch
$ rpm -qf /usr/share/gnome-shell/extensions/presentationmode@ampad.de
gnome-shell-extension-presentation-mode-0-0.4.gitc3ce6b2.fc18.noarch
$ rpm -qf /usr/share/gnome-shell/extensions/calc@patapon.info
gnome-shell-extension-calc-0-0.4.git2fca097.fc18.noarch
$ rpm -qf /usr/share/gnome-shell/extensions/pidgin-conversation-integration@kagesenshi.org
gnome-shell-extension-pidgin-0-0.8.git87fc23433d.fc18.x86_64
$ rpm -qf /usr/share/gnome-shell/extensions/icon-manager@krajniak.info
gnome-shell-extension-icon-manager-0-0.7.git37fbd9a.fc18.noarch
$ rpm -qf /usr/share/gnome-shell/extensions/noim@fpmurphy.com
gnome-shell-extension-noim-1.0-5.fc18.noarch
$ rpm -qf /usr/share/gnome-shell/extensions/righthotcorner@fpmurphy.com
gnome-shell-extension-righthotcorner-1.0-3.fc18.noarch
$ rpm -qf /usr/share/gnome-shell/extensions/remove-volume-icon@affolter-engineering.ch
gnome-shell-extension-remove-volume-icon-0.4.0-2.fc18.noarch
$ rpm -qf /usr/share/gnome-shell/extensions/windowoverlay-icons@sustmidown.centrum.cz
gnome-shell-extension-sustmi-windowoverlay-icons-3.0-7.git72282ce.fc18.noarch
$ rpm -qf /usr/share/gnome-shell/extensions/historymanager-prefix-search@sustmidown.centrum.cz
gnome-shell-extension-sustmi-historymanager-prefix-search-3.0-7.git72282ce.fc18.noarch
$ rpm -qf /usr/share/gnome-shell/extensions/remove-bluetooth-icon@affolter-engineering.ch
gnome-shell-extension-remove-bluetooth-icon-0.3.0-2.fc18.noarch
$ rpm -qf /usr/share/gnome-shell/extensions/remove-accessibility-icon@martin-weusten.de
gnome-shell-extension-remove-accessibility-icon-20111008-4.fc18.noarch
$ rpm -qf /usr/share/gnome-shell/extensions/workspacesmenu@fpmurphy.com
gnome-shell-extension-workspacesmenu-0-3.fc18.noarch
$ rpm -qf /usr/share/gnome-shell/extensions/noripple@fpmurphy.com
gnome-shell-extension-noripple-2.0-2.fc18.noarch
$ rpm -qf /usr/share/gnome-shell/extensions/temperature@xtranophilist
gnome-shell-extension-cpu-temperature-0-0.8.gite1777e6.fc18.noarch
Comment 9 Mohamed El Morabity 2013-02-01 13:31:09 EST
(In reply to comment #8)
> I can confirm this bug in Fedora 18.
> Issue is even reported by the gnome-shell when restarted.
> 
>       JS LOG: Extension "mediasplayers@ycdref" had error: Error: extension
> is not compatible with current GNOME Shell and/or GJS version
>       JS LOG: Extension "presentationmode@ampad.de" had error: Error:
> extension is not compatible with current GNOME Shell and/or GJS version
>       JS LOG: Extension "calc@patapon.info" had error: Error: extension is
> not compatible with current GNOME Shell and/or GJS version
>       JS LOG: Extension "pidgin-conversation-integration@kagesenshi.org" had
> error: Error: extension is not compatible with current GNOME Shell and/or
> GJS version
>       JS LOG: Extension "icon-manager@krajniak.info" had error: Error:
> extension is not compatible with current GNOME Shell and/or GJS version
>       JS LOG: Extension "noim@fpmurphy.com" had error: Error: extension is
> not compatible with current GNOME Shell and/or GJS version
>       JS LOG: Extension "righthotcorner@fpmurphy.com" had error: Error:
> extension is not compatible with current GNOME Shell and/or GJS version
>       JS LOG: Extension "remove-volume-icon@affolter-engineering.ch" had
> error: Error: extension is not compatible with current GNOME Shell and/or
> GJS version
>       JS LOG: Extension "windowoverlay-icons@sustmidown.centrum.cz" had
> error: Error: extension is not compatible with current GNOME Shell and/or
> GJS version
>       JS LOG: loading default theme (Adwaita)
>       JS LOG: Extension "historymanager-prefix-search@sustmidown.centrum.cz"
> had error: Error: extension is not compatible with current GNOME Shell
> and/or GJS version
>       JS LOG: Extension "remove-bluetooth-icon@affolter-engineering.ch" had
> error: Error: extension is not compatible with current GNOME Shell and/or
> GJS version
>       JS LOG: Extension "remove-accessibility-icon@martin-weusten.de" had
> error: Error: extension is not compatible with current GNOME Shell and/or
> GJS version
>       JS LOG: Extension "workspacesmenu@fpmurphy.com" had error: Error:
> extension is not compatible with current GNOME Shell and/or GJS version
>       JS LOG: Extension "noripple@fpmurphy.com" had error: Error: extension
> is not compatible with current GNOME Shell and/or GJS version
>       JS LOG: Extension "temperature@xtranophilist" had error: Error:
> extension is not compatible with current GNOME Shell and/or GJS version

None of these extensions are provided by the gnome-shell-extensions source packaeg. Please fill a bug for each of them, using the appropriate component field.
Comment 10 Fedora End Of Life 2013-12-21 04:20:36 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 11 Fedora End Of Life 2014-02-05 07:57:29 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.