Bug 906090 - gnome-shell-extension-cpu-temperature enablement is not possible in gnome 3.6
gnome-shell-extension-cpu-temperature enablement is not possible in gnome 3.6
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-shell-extension-cpu-temperature (Show other bugs)
18
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabian Affolter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-30 14:58 EST by Tomasz Chilinski
Modified: 2014-05-01 05:19 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 957384 (view as bug list)
Environment:
Last Closed: 2013-11-22 02:41:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomasz Chilinski 2013-01-30 14:58:21 EST
Description of problem:
It's not possible to enable this extension in gnome 3.6.

Version-Release number of selected component (if applicable):
0-0.8.gite1777e6.fc18

How reproducible:
Install and try to enable in gnome tweak tool.

Actual results:
unable to use it gnome 3.6

Expected results:
should work in gnome 3.6

Additional info:
Change the following fragment in metadata.json file from:
"shell-version": ["3.2", "3.3", "3.4"]
to:
"shell-version": ["3.2", "3.3", "3.4", "3.5", "3.6"]
and it starts working.
Comment 1 collura 2013-01-31 02:37:23 EST
thank you.

path to file is:

  /usr/share/gnome-shell/extensions/temperature@xtranophilist/metadata.json

then after you modify the line <alt><f2> for window manager command window popup and type 'restart' and press <enter> to restart the window manager and temperature popped up in toolbar :')
Comment 2 Fedora Update System 2013-02-26 06:35:04 EST
gnome-shell-extension-cpu-temperature-1.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnome-shell-extension-cpu-temperature-1.1-1.fc18
Comment 3 Steve 2013-02-26 06:48:08 EST
gnome-shell-extension-cpu-temperature is now capable of being activated but not visible
Comment 4 Fedora Update System 2013-02-26 21:42:17 EST
Package gnome-shell-extension-cpu-temperature-1.1-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-shell-extension-cpu-temperature-1.1-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3135/gnome-shell-extension-cpu-temperature-1.1-1.fc18
then log in and leave karma (feedback).
Comment 5 Oli Wade 2013-03-04 14:44:12 EST
1.1-1 version can be enabled but does not show ("Error loading extension").
Comment 6 collura 2013-04-19 03:12:59 EDT
on a previous version after i added the gnome version 3.6 part (which made things work) i had then tried to pretify the metadata.json file with linebreaks and spacing but that broke it so i removed the pretification and it worked again.

however, the current version 

 gnome-shell-extensions-cpu-temperature-1.1-1.fc18.x86_64

didnt work for me but it had a pretified metadata.json file 
so i tried to unpretify it but that didnt fix it. :'(
Comment 7 collura 2013-07-02 03:50:05 EDT
not working for me with:

   gnome-shell-3.8.3-3.fc19.x86_64

   gnome-shell-extension-cpu-temperature-1.1-1.fc19.x86_64

snippet of .xsession-errors:

"JS ERROR: !!!   WARNING:
 'assignment to undeclared variable type'
    JS ERROR: !!!   WARNING: file '/usr/share/gnome-shell/extensions/temperature@xtranophilist/extension.js' line 213 exception 
0 number 156
    JS ERROR: !!!   WARNING: 'assignment to undeclared variable r'
    JS ERROR: !!!   WARNING: file '/usr/share/gnome-shell/extensions/temperature@xtranophilist/extension.js' line 325 exception 
0 number 156
"
Comment 8 Gianluca Cecchi 2013-07-04 14:16:03 EDT
Hello,
I see that right now trying to install gnome-shell-extension-cpu-temperature in F18 I get

Dependencies Resolved

===========================================================================================================================
 Package                                         Arch             Version                           Repository        Size
===========================================================================================================================
Installing:
 gnome-shell-extension-cpu-temperature           noarch           0-0.8.gite1777e6.fc18             fedora           8.4 k

Transaction Summary
===========================================================================================================================
Install  1 Package

Total download size: 8.4 k
Installed size: 16 k

SO probably the update package was removed?

And then I can successfully use the workaround as detailed in the main bug submission section:

"shell-version": ["3.2", "3.3", "3.4", "3.5", "3.6"]
 
My packages are now
gnome-shell-3.6.3.1-1.fc18.x86_64

and the plugin is correctly enabled and values seems to match "sensors" output from console.

Wouldn't be better so to patch 0-0.8.gite1777e6.fc18 committing the change to 
/usr/share/gnome-shell/extensions/temperature@xtranophilist/metadata.json

otherwise a normal user without coming to this specific bugzilla would get an awful experience.. ?

Gianluca
Comment 9 Steve 2013-07-04 15:15:07 EDT
In F19, the /usr/share/gnome-shell/extensions/temperature@xtranophilist/metadata.json is also missing the entry '"shell-version": ["3.8"]'.

However, the extension is not working.

gnome-shell-3.8.3-3.fc19.x86_64
gnome-shell-extension-cpu-temperature-1.1-1.fc19.noarch
Comment 10 Tomasz Chilinski 2013-07-04 15:25:37 EDT
AFAIK upstream project has changed its name to gnome-shell-extensions-sensors.
More hardware sensor values are also displayed.
Comment 12 John L Magee 2013-09-15 18:45:59 EDT
These three lines fix Fedora 19 

sed s/3.6\"/3.6\",\\n\"3.8\"/  /usr/share/gnome-
shell/extensions/temperature@xtranophilist/metadata.json -i

curl -L -s  "https://raw.github.com/lmacken/gnome-shell-extension-cpu-temperature/master/schemas/org.gnome.shell.extensions.cpu-temperature.gschema.xml" -o  /usr/share/glib-2.0/schemas/org.gnome.shell.extensions.cpu-temperature.gschema.xml

/usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas &> /dev/null


It is not clear why it is taking so long for this to be resolved in the packages
Comment 13 Steve 2013-09-16 01:23:03 EDT
(In reply to John L Magee from comment #12)
> These three lines fix Fedora 19 
> 
> sed s/3.6\"/3.6\",\\n\"3.8\"/  /usr/share/gnome-
> shell/extensions/temperature@xtranophilist/metadata.json -i
> 
> curl -L -s 
> "https://raw.github.com/lmacken/gnome-shell-extension-cpu-temperature/master/
> schemas/org.gnome.shell.extensions.cpu-temperature.gschema.xml" -o 
> /usr/share/glib-2.0/schemas/org.gnome.shell.extensions.cpu-temperature.
> gschema.xml
> 
> /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas &> /dev/null
> 
> 
> It is not clear why it is taking so long for this to be resolved in the
> packages

I can confirm that this is working. Thank you!
Comment 14 Gianluca Cecchi 2013-09-19 06:46:44 EDT
I confirm it works for me too in Fedora 19 with
gnome-shell-extension-cpu-temperature-1.1-1.fc19.noarch
Comment 15 Fabian Affolter 2013-11-22 02:41:39 EST
Package is retired.
Comment 16 Hin-Tak Leung 2014-05-01 05:19:09 EDT
Hmm, "Package is retired" - any replacements? In fact it was still working for me in Fedora 20, until yesterday, when I decided to get the gnome 3.12 copr.


gnome 3.12 needs a bit of tweaking not currently upstream:
https://github.com/xtranophilist/gnome-shell-extension-sensors/issues/104

With the tweak, it is working with gnome 3.12 too.

Note You need to log in before you can comment on or make changes to this bug.