Bug 877947

Summary: [ALL_LANG][GUI] - Error messages are handled and being shown Erroneously - [SAM Web GUI]
Product: Subscription Asset Manager Reporter: Satyabrata Maitra <smaitra>
Component: katelloAssignee: Tom McKay <tomckay>
Status: CLOSED NOTABUG QA Contact: SAM QE List <sam-qe-list>
Severity: high Docs Contact:
Priority: high    
Version: 1.2CC: bkearney, eng-i18n-bugs, lijli, omaciel, qe-i18n-bugs, smaitra, tkolhar, tomckay
Target Milestone: rcKeywords: i18n, Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Removed erroneous error messages
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-07-03 10:25:22 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 833466    
Attachments:
Description Flags
error message stacks one after another vertically. none

Description Satyabrata Maitra 2012-11-19 05:10:07 EST
Created attachment 647656 [details]
error message stacks one after another vertically.

Description of problem:
In the SAM Web GUI, the error messages which are showing, is actually showing erroneously, one after another, without disappearing the earlier one, resulting the whole page with the queue of error messages. User not able to view the web page content.

Version-Release number of selected component (if applicable):
katello-headpin-all-1.2.5-1h.el6_3
Subscription Asset Manager Version: 1.2.5-1h.el6_3

How reproducible:
Always.

Steps to Reproduce:
1. Open SAM Web GUI
2. Click on Content Tab
3. The Search option, under the Subscription Heading, type "Red Hat" and Click 
   on Search icon.
4. Now, click on the search results one by one.
5. Observe the error messages making a stack or queue.
OR
Produce more than one error message from anywhere else in the whole web page.
  
Actual results:
The error messages are making a vertical queue, without disappearing the earlier one, in case of more than one error message are showing.

Expected results:
Before showing the another error message, the earlier message which is currently showing on the screen, should automatically disappear rather than prompting the user to click on the Cross button(x) in the error message box to remove that message.

Additional info: Screen Shot attached.
Comment 1 Lijun Li 2012-11-19 05:40:24 EST
Seems a same issue bug: Bug 877956 - [ja_JP][SAM Web GUI] Error messages occurred after deleting the manifest.
Comment 2 Satyabrata Maitra 2012-11-19 06:04:56 EST
Hi Robert
From your bug report, it seems your bug referred to import, upload, delete of manifest all together and speaks about the post delete activities. Hard to say it is same.

Still, if you think, it is same, please close the bug reported later one #877956 as duplicate of #877947.
Comment 3 Satyabrata Maitra 2012-11-19 06:07:01 EST
From the screen shot attached with the bug #877956, it looks the bug is same with this one. So, please close bug #877956.
Comment 4 Tom McKay 2012-11-27 14:38:20 EST
*** Bug 877956 has been marked as a duplicate of this bug. ***
Comment 5 Tom McKay 2012-11-27 15:13:48 EST
*** Bug 878429 has been marked as a duplicate of this bug. ***
Comment 6 Tom McKay 2012-12-04 13:24:01 EST
  Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: c2a2f4bef05375567cc8181111f78023084896d0
      https://github.com/Katello/katello/commit/c2a2f4bef05375567cc8181111f78023084896d0
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2012-12-04 (Tue, 04 Dec 2012)

The cause of the error messages has been fixed: When a manifest was deleted, the search engine was not being cleared of those entries so they would remain visible in the left-hand list.

Note that the error messages "stacking up" in the UI is working as designed. Error notices do not automatically fade out like the green informational ones do, they must be explicitly closed.
Comment 8 Og Maciel 2013-01-07 16:24:14 EST
Deleting a manifest was not deleting the entry from the left side of the subscriptions list. Reloading the page cleared it but if you clicked on the entry, then you'd get a traceback error notification.

* candlepin-0.7.23-1.el6_3.noarch
* candlepin-tomcat6-0.7.23-1.el6_3.noarch
* elasticsearch-0.19.9-5.el6_3.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.2.1-1h.el6_3.noarch
* katello-cli-1.2.1-11h.el6_3.noarch
* katello-cli-common-1.2.1-11h.el6_3.noarch
* katello-common-1.2.1-12h.el6_3.noarch
* katello-configure-1.2.3-1h.el6_3.noarch
* katello-glue-candlepin-1.2.1-12h.el6_3.noarch
* katello-headpin-1.2.1-12h.el6_3.noarch
* katello-headpin-all-1.2.1-12h.el6_3.noarch
* katello-selinux-1.2.1-2h.el6_3.noarch
* thumbslug-0.0.28-1.el6_3.noarch
* thumbslug-selinux-0.0.28-1.el6_3.noarch
Comment 9 Og Maciel 2013-01-09 13:30:30 EST
*** Bug 874391 has been marked as a duplicate of this bug. ***
Comment 10 Tom McKay 2013-07-03 10:25:22 EDT
As noted in earlier comment, the error message stacking is working as intended.