Bug 879845

Summary: [abrt] qemu-system-x86-1.2.0-23.fc18: spice_logv: Process /usr/bin/qemu-kvm was killed by signal 6 (SIGABRT)
Product: [Fedora] Fedora Reporter: M. Edward (Ed) Borasky <znmeb>
Component: spiceAssignee: Hans de Goede <hdegoede>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: alevy, alexl, amit.shah, berrange, cfergeau, crobinso, dwmw2, hdegoede, itamar, jforbes, knoel, marcandre.lureau, pbonzini, petersen, rjones, sandmann, scottt.tw, virt-maint, william, znmeb
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:8c28e50d96e5e738091eb9a86af1767b505782ce
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-11 18:20:02 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: backtrace
none
File: build_ids
none
File: cgroup
none
File: core_backtrace
none
File: dso_list
none
File: environ
none
File: limits
none
File: maps
none
File: open_fds
none
File: proc_pid_status
none
File: var_log_messages
none
Output of 'yum history info' for the update that I ran just before the crash none

Description M. Edward (Ed) Borasky 2012-11-24 15:11:27 EST
Description of problem:
I was running a Fedora 18 guest on a Fedora 18 host. I paused the guest machine and saved its state. Then I did a software update on the host, rebooted the host and then started Virtual Machine Manager back up. Then I restored the guest VM state and resumed the guest. It came up and started processing, then qemu-kvm crashed. I'll attach a yum log of the updates to the bug report after it's created.

Version-Release number of selected component:
qemu-system-x86-1.2.0-23.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/bin/qemu-kvm -name Fedora18K -S -M pc-1.2 -enable-kvm -m 1536 -smp 1,sockets=1,cores=1,threads=1 -uuid 93ad1a04-98e5-2b56-0a64-707a74f615d6 -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/Fedora18K.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x5 -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/var/lib/libvirt/images/Fedora18K.img,if=none,id=drive-virtio-disk0,format=qcow2 -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x6,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -drive if=none,id=drive-ide0-1-0,readonly=on,format=raw -device ide-cd,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=24,id=hostnet0,vhost=on,vhostfd=25 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:04:dd:0e,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -device usb-tablet,id=input0 -spice port=5900,addr=127.0.0.1,disable-ticketing -vga qxl -global qxl-vga.vram_size=67108864 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -incoming fd:22 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7
crash_function: spice_logv
executable:     /usr/bin/qemu-kvm
kernel:         3.6.7-5.fc18.x86_64
remote_result:  NOTFOUND
uid:            107

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 spice_logv at log.c:109
 #3 spice_log at log.c:123
 #4 lz_usr_error at red_worker.c:5467
 #5 lz_encode at lz.c:524
 #6 red_lz_compress_image at red_worker.c:6038
 #7 red_marshall_image at red_worker.c:8600
 #8 display_channel_send_item at red_worker.c:8911
 #9 red_channel_client_send_item at red_channel.c:507
 #10 red_channel_client_push at red_channel.c:1088
 #12 red_push_surface_image at red_worker.c:5095
Comment 1 M. Edward (Ed) Borasky 2012-11-24 15:11:32 EST
Created attachment 651199 [details]
File: backtrace
Comment 2 M. Edward (Ed) Borasky 2012-11-24 15:11:34 EST
Created attachment 651200 [details]
File: build_ids
Comment 3 M. Edward (Ed) Borasky 2012-11-24 15:11:35 EST
Created attachment 651201 [details]
File: cgroup
Comment 4 M. Edward (Ed) Borasky 2012-11-24 15:11:37 EST
Created attachment 651202 [details]
File: core_backtrace
Comment 5 M. Edward (Ed) Borasky 2012-11-24 15:11:39 EST
Created attachment 651203 [details]
File: dso_list
Comment 6 M. Edward (Ed) Borasky 2012-11-24 15:11:40 EST
Created attachment 651204 [details]
File: environ
Comment 7 M. Edward (Ed) Borasky 2012-11-24 15:11:42 EST
Created attachment 651205 [details]
File: limits
Comment 8 M. Edward (Ed) Borasky 2012-11-24 15:11:44 EST
Created attachment 651206 [details]
File: maps
Comment 9 M. Edward (Ed) Borasky 2012-11-24 15:11:46 EST
Created attachment 651207 [details]
File: open_fds
Comment 10 M. Edward (Ed) Borasky 2012-11-24 15:11:47 EST
Created attachment 651208 [details]
File: proc_pid_status
Comment 11 M. Edward (Ed) Borasky 2012-11-24 15:11:56 EST
Created attachment 651209 [details]
File: var_log_messages
Comment 12 M. Edward (Ed) Borasky 2012-11-24 15:19:17 EST
Created attachment 651221 [details]
Output of 'yum history info' for the update that I ran just before the crash
Comment 13 Cole Robinson 2012-12-18 18:04:22 EST
*** Bug 887872 has been marked as a duplicate of this bug. ***
Comment 14 Hans de Goede 2012-12-19 04:29:53 EST
(In reply to comment #12)
> Created attachment 651221 [details]
> Output of 'yum history info' for the update that I ran just before the crash

Ok, this does not seem to contain anything related to qemu and/or spice.

Looking at the backtrace it seems that our lz code hits an assert, moving this over to yonit.
Comment 16 Hans de Goede 2012-12-19 10:19:20 EST
Good! So it really is time to do a 0.12.2 release upstream and get that into Fedora-18 !
Comment 17 Hans de Goede 2012-12-20 14:47:51 EST
I'm currently building 0.12.2 for F-18, assigning this back to me.
Comment 18 Fedora Update System 2012-12-20 16:05:28 EST
spice-0.12.2-1.fc18,spice-protocol-0.12.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/spice-0.12.2-1.fc18,spice-protocol-0.12.3-1.fc18
Comment 19 Fedora Update System 2012-12-20 20:32:30 EST
Package spice-0.12.2-1.fc18, spice-protocol-0.12.3-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing spice-0.12.2-1.fc18 spice-protocol-0.12.3-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20735/spice-0.12.2-1.fc18,spice-protocol-0.12.3-1.fc18
then log in and leave karma (feedback).
Comment 20 Cole Robinson 2013-01-06 09:17:22 EST
*** Bug 892075 has been marked as a duplicate of this bug. ***
Comment 21 Fedora Update System 2013-01-11 18:20:05 EST
spice-0.12.2-1.fc18, spice-protocol-0.12.3-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Jens Petersen 2013-01-18 03:05:55 EST
Perhaps I should try to reboot but:

$ qemu-kvm -m 1024 -vga qxl -usb -localtime -k en-us -boot d -cdrom Fedora-18-x86_64-Live-Desktop.iso

still backtraces during boot for me.
Comment 23 Jens Petersen 2013-01-18 03:07:21 EST
(I came here from https://retrace.fedoraproject.org/faf/reports/33683/ )
Comment 24 Jens Petersen 2013-01-18 03:09:55 EST
Anyway I can run F18 Live via virt-manager as a workaround.
Comment 25 Jens Petersen 2013-01-18 03:10:47 EST
If someone else can confirm ie still reproduce then I think this should be reopened.
Comment 26 Hans de Goede 2013-01-18 09:21:04 EST
Hi,

(In reply to comment #22)
> Perhaps I should try to reboot but:
> 
> $ qemu-kvm -m 1024 -vga qxl -usb -localtime -k en-us -boot d -cdrom
> Fedora-18-x86_64-Live-Desktop.iso
> 
> still backtraces during boot for me.

I can reproduce with the provided commandline, thanks. This is likely fixed by the following
upstream commit, checking that now:
http://cgit.freedesktop.org/spice/qemu/commit/?h=spice.v66&id=938b8a36b65e44c44ca29245437f8d7ac0f826e8

Part of the reason we missed this still being  a problem, and closed this bug, is that bug 892075, which :
https://retrace.fedoraproject.org/faf/reports/33683/
Refers to was marked as a dup of this one, while it actually has a quite different backtrace, and is not a different bug. Re-opening 892075 to track this further.

Regards,

Hans