Bug 880758

Summary: Unable to login to cinnamon on Fedora 18 beta
Product: [Fedora] Fedora Reporter: Caner Çuhac <ccuhac>
Component: cinnamonAssignee: leigh scott <leigh123linux>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: leigh123linux, me
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-11-28 12:37:06 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
Screenshot that I got after entering login info. none

Description Caner Çuhac 2012-11-27 13:29:58 EST
Created attachment 653013 [details]
Screenshot that I got after entering login info.

Description of problem:

On Fedora 18 beta, choose cinnamon DE during install. After a fresh installation, first login screen does not log me in. The screenshot that I have is attached.

Version-Release number of selected component (if applicable):

Fedora 18 beta - cinnamon

How reproducible:


Steps to Reproduce:
1. Install Fedora 18 beta with cinnamon DE.
2. After the install enter your login info.
3. The login manager fails to proceed further. (Screenshot attached)
  
Actual results:
Normal login.

Expected results:
Can not login.

Additional info:
Screenshot attached.
Comment 1 leigh scott 2012-11-27 16:57:43 EST
I have no issues here running F18 beta in vbox on F17 or F18 hosts.
Judging by the messed up screenshot it looks like there is a video driver issue on the host machine.
Comment 2 Caelum 2012-11-28 12:02:49 EST
I'm having the exact same issue. The host machine is a fully updated Windows 8 x64 installation with the latest nvidia (non-beta) drivers, running the latest stable version of Virtualbox. I'm using EMET as well on the host machine (DEP, ASLR & SEHOP enabled system-wide).

Virtualbox settings for the host machine:
-7 out of 16 vCPUs assigned to the guest machine. Host machine running an i7 2600k
-2 GB out of 8 GB of RAM assigned to the guest machine
-VT-x, nested paging, IO APIC and 3D acceleration enabled
-64 MB of video memory assigned
-20 GB virtual harddrive for the guest machine, dynamically allocated

I'm using a GTX 560 Ti that's otherwise fully functional and I have absolutely no issues with. My hardware is fine, honest.

Steps taken during installation:
1. Start installer as normal
2. Choose Cinnamon desktop in installer, use English (US, alternative international) keyboard layout, no encryption, and automatic partitioning
3. Set "Test" as both root password and main account password, as well as username (lowercase) and account name
4. Login manager will claim you're currently logged in after entering correct password, but there's no way to proceed past the login manager, and it displays various graphical glitches.

FWIW, Cinnamon on a Linux Mint guest with identical settings works fine, and I haven't had this issue in either Xfce or Gnome DEs in F18.
Comment 3 leigh scott 2012-11-28 12:19:16 EST
Are you using the dvd media?, if so you could be hitting a similar issue to this

http://fedoraproject.org/wiki/Common_F18_bugs#MATE_installation_is_broken_from_the_DVD_media


Cinnamon isn't on the dvd media so it probably isn't installed
Comment 4 Caelum 2012-11-28 12:25:45 EST
Ah, that'd explain a lot. I am using the dvd media, yeah.
Comment 5 leigh scott 2012-11-28 12:37:06 EST

*** This bug has been marked as a duplicate of bug 878985 ***
Comment 6 leigh scott 2012-11-28 12:39:23 EST
If you use the VT you could run

yum install @Cinnamon