Bug 878985 - Not enough space on F18 i386 DVD for MATE DE
Not enough space on F18 i386 DVD for MATE DE
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pungi (Show other bugs)
18
All All
urgent Severity urgent
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 880758 (view as bug list)
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept 883052
  Show dependency treegraph
 
Reported: 2012-11-21 12:38 EST by satellitgo
Modified: 2014-01-21 18:04 EST (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-05 02:16:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
addendum to patch (629 bytes, patch)
2012-12-18 17:19 EST, Bill Nottingham
no flags Details | Diff
kickstart with MATE (2.53 KB, application/octet-stream)
2012-12-21 01:04 EST, Dan Mashal
no flags Details
new kickstart with cinnamon and mate for i386 DVD (3.92 KB, application/octet-stream)
2012-12-24 16:10 EST, Dan Mashal
no flags Details

  None (edit)
Description satellitgo 2012-11-21 12:38:10 EST
Description of problem:
MATE entry on RC1 i386 DVD install results in an incomplete mate-desktop (openbox login only) please remove mate from DVD left list

Version-Release number of selected component (if applicable):
RC1 i386 DVD

How reproducible:
select Mate on DVD software install

Steps to Reproduce:
1.
2.
3.
  
Actual results:
non-working mate-desktop

Expected results:


Additional info:
yum install @mate results in 54 files and mate 1.4.1 login
Comment 1 Bill Nottingham 2012-11-21 13:26:13 EST
Oh, hrm. MATE isn't on the DVD, so we either need to filter the environments shown on the DVD (versus network install), or drop them entirely.
Comment 2 Adam Williamson 2012-11-24 14:01:34 EST
nirik remarks that this used to happen regularly when Xfce wasn't 'officially' on the DVD. The way the package group display code works, apparently, is that a group is shown in the list if *any* package in that group is available, which causes the problem - but if you change that, you have the problem that if you drop some trivial package from the GNOME group to save room on the DVD or something, GNOME suddenly won't be available...seems like a rather difficult problem to tract.
Comment 3 Dan Mashal 2012-11-24 14:20:35 EST
I thought this shouldn't appear on the DVD? I belive imsettings-mate was dropped as a package.
Comment 4 Adam Williamson 2012-11-24 17:21:07 EST
must be something else snuck onto RC1 somehow.
Comment 5 Bill Nottingham 2012-11-26 15:38:40 EST
Adam, what you're describing in comment #2 is the behavior for *groups*, which still exists. However, the 'environments' (the options on the left hand side of package selection) don't have any such filtering at the moment, so they'll be shown even if they have no packages.
Comment 6 Bill Nottingham 2012-11-26 15:39:56 EST
Moving back to anaconda for the moment, will have to investigate if this filtering can be simply done with a patch there. Other options would be hacking the rel-eng scripts to modify the comps file on the dvd.
Comment 7 Dan Mashal 2012-11-26 16:11:11 EST
Can we just add MATE back to the DVD? It's like 200MB worth of packages?
Comment 8 Andre Robatino 2012-11-26 16:40:22 EST
(In reply to comment #7)
> Can we just add MATE back to the DVD? It's like 200MB worth of packages?

Both 18 Beta RC1 DVDs are less than 200 MB from the 4.7 GB size limit:

Fedora-18-Beta-i386-DVD.iso : 4626317312 bytes (4.626 GB)
Fedora-18-Beta-x86_64-DVD.iso : 4543479808 bytes (4.543 GB)
Comment 9 leigh scott 2012-11-28 12:37:06 EST
*** Bug 880758 has been marked as a duplicate of this bug. ***
Comment 10 satellitgo 2012-11-28 13:17:16 EST
cinnamon works from f18 Beta DVD and netinstall  why remove it?
Comment 11 leigh scott 2012-11-28 14:13:02 EST
(In reply to comment #10)
> cinnamon works from f18 Beta DVD and netinstall  why remove it?

How can you remove something that was never on the DVD?
Comment 12 satellitgo 2012-11-28 15:18:28 EST
I am installing cinnamon with BETA DVD x86_64  to VirtualBox with wired network off. installs 1001 files.
It HAS to be on the DVD
Comment 13 satellitgo 2012-11-28 15:40:30 EST
(In reply to comment #12)
> I am installing cinnamon with BETA DVD x86_64  to VirtualBox with wired
> network off. installs 1001 files.
> It HAS to be on the DVD

opps it does not start after gdm login :  (
 my bad
Comment 14 Chris Lumens 2012-12-03 21:48:13 EST
I don't believe we've had to do this kind of filtering in the past.  I'd be more inclined to say this should be fixed on the media - the repo metadata really shouldn't contain information about packages that are not present in the repo itself.  That's just weird.
Comment 15 Bill Nottingham 2012-12-10 16:02:15 EST
Moving to pungi. Patch posted at:
  http://lists.fedoraproject.org/pipermail/buildsys/2012-December/004033.html
Comment 16 Bill Nottingham 2012-12-10 16:03:01 EST
I'm willing to shepherd a pungi build through the system, but I'd like a bit of review on the patch first.
Comment 17 Bill Nottingham 2012-12-18 17:19:21 EST
Created attachment 665804 [details]
addendum to patch

This addition to the patch fixes a potential issue with langsupport groups. It shouldn't amount to much in how they currently exist in Fedora, but it's worth keeping.
Comment 18 Adam Williamson 2012-12-18 19:46:38 EST
I'm definitely +1 NTH on this one, we should get it accepted. I might even fight for it as +1 blocker on polish grounds, it's pretty crappy to release a final release whose DVD claims to be able to install desktops it does not contain.
Comment 19 Kevin Fenzi 2012-12-18 19:52:39 EST
+1 NTH here, but we should get it in asap.
Comment 20 Andre Robatino 2012-12-18 19:58:27 EST
+1 NTH
Comment 21 Tim Flink 2012-12-18 20:06:14 EST
+1 NTH

I count +4 NTH in total, moving to accepted.
Comment 22 Adam Williamson 2012-12-18 20:12:29 EST
Bill, are you still waiting for review of your patch here, or can you/we go ahead and get a pungi build done?
Comment 23 Bill Nottingham 2012-12-18 23:27:56 EST
Dennis pulled the patch into his repo, he was working on another (unrelated) pungi fix before building.
Comment 24 Dan Mashal 2012-12-19 01:59:33 EST
Guys,

I am getting a lot of bug reports about people not installing MATE properly because they used some live image or the DVD. How do we avoid this going forward?
Comment 25 Adam Williamson 2012-12-19 13:38:43 EST
looks like we're just waiting on dgilmore doing a pungi build, i'll poke him today.
Comment 26 Dan Mashal 2012-12-21 00:58:40 EST
I just composed 2 DVDs one with MATE one without. This is literally 100MB of RPMs:

Without MATE: 4,572,839,936 Dec 20 21:46 Fedora-18-x86_64-DVD.iso
With MATE:    4,671,406,080 bytes 

Used the latest fedora-install-fedora from here:

http://git.fedorahosted.org/cgit/spin-kickstarts.git/plain/fedora-install-fedora.ks?h=f18

Removed:

 --exclude mate-* --exclude imsettings-mate
and --exclude mate-*

Added:

## MATE
@mate

Do you think we could please add this to the DVD?
Comment 27 Dan Mashal 2012-12-21 01:04:09 EST
Created attachment 667103 [details]
kickstart with MATE
Comment 28 Dan Mashal 2012-12-21 01:04:50 EST
Attached the kickstart, verified that the ISO generated boots, and installs MATE desktop successfully, and works properly.
Comment 29 Adam Williamson 2012-12-21 02:01:15 EST
those sizes precisely match the size of the smoke8 and smoke9 images, so it seems like a reliable test. Our byte limit is 4,700,000,000 , so 'with MATE' is very close but below the cutoff.
Comment 30 leigh scott 2012-12-21 03:03:37 EST
(In reply to comment #26)

> Do you think we could please add this to the DVD?

Why would they add Mate in it's broken state?
Comment 31 leigh scott 2012-12-21 03:05:12 EST
(In reply to comment #29)
> those sizes precisely match the size of the smoke8 and smoke9 images, so it
> seems like a reliable test. Our byte limit is 4,700,000,000 , so 'with MATE'
> is very close but below the cutoff.

Could cinnamon be added it's smaller than Mate and is in a shippable state .
Comment 32 Dan Mashal 2012-12-21 04:18:02 EST
As per conversation in #fedora-qa:

The i686 ISO comes in at 4,745,854,976 bytes which is barely over the limit using the attached kickstart. 

The reason for this is due to i686 DVD including both non-PAE and PAE kernels.

I would like to propose dropping the PAE kernel.

As per the following link:

http://askubuntu.com/questions/151068/for-a-32-bit-kernel-what-are-the-pros-cons-of-pae-vs-non-pae

The PAE kernel offers very minimal benefits and is slower than non-PAE. 

In addition it is very hard to find a 32bit motherboard that supports more than 4GB of RAM. 

Is it really needed?

Or could we make some groups optional instead of mandatory? I.E. @gnome-games?

If anything an x86_64 DVD with MATE and an i686 DVD without it would suffice.

Thanks in advance.
Comment 33 Dan Mashal 2012-12-21 06:35:08 EST
Adding jforbes for his 2 cents. Sorry for the spam. Want to get this sorted while time ticks.
Comment 34 Bill Nottingham 2012-12-21 13:52:46 EST
While I appreciate your enthusiasm here, I don't think adding MATE to the DVD at this point is the right answer, for a variety of reasons:

1) It doesn't solve the problem for other cases (see: Cinnamon)
2) It leads to the same "me too" discussions in those cases (see: comment #31)
3) It involves changes to existing, standard DVD functionality that's been in all the milestones (re: gnome-games, or kernel-PAE)
4) It involves the idea of architecture-specific composes, which we don't do

The right fix is the pungi fix to filter the groups that are displayed on DVD installs to match the content on the DVD... we just need to get it built and the composes composed with it. Dennis?
Comment 35 Dan Mashal 2012-12-21 15:56:20 EST
(In reply to comment #34)
> While I appreciate your enthusiasm here, I don't think adding MATE to the
> DVD at this point is the right answer, for a variety of reasons:
> 
> 1) It doesn't solve the problem for other cases (see: Cinnamon)

Not to minimize Cinnamon whatsoever but it wasn't advertised or proposed as an official feature, isn't getting press coverage and I don't know how many bugs Leigh is getting about not being able to install off the DVD, but with wide amount of press MATE has received as a feature no one at Red Hat seems to care about this issue. 

> 2) It leads to the same "me too" discussions in those cases (see: comment
> #31)

See #1

> 3) It involves changes to existing, standard DVD functionality that's been
> in all the milestones (re: gnome-games, or kernel-PAE)

See link pointing out the fact that the PAE kernel is needed in very rare cases.

> 4) It involves the idea of architecture-specific composes, which we don't do
> 
> The right fix is the pungi fix to filter the groups that are displayed on
> DVD installs to match the content on the DVD... we just need to get it built
> and the composes composed with it. Dennis?

That wasn't a proposal, merely a thought if nothing else could be done.
Comment 36 Andre Robatino 2012-12-22 00:50:16 EST
In

smoke12 (anaconda-18.37.8-1, pungi-2.13-1): http://dl.fedoraproject.org/pub/alt/qa/20121221_f18-smoke12/

the following 3 items are in the netinst Software Selection menu: Cinnamon Desktop, MATE Desktop, and Basic X Window System. The corresponding DVD menu is the same except for these 3 items missing. Presumably fixing this bug accounts for the first two, but why Basic X? If Basic X Window System is selected in the netinst menu, there is no Cinnamon or MATE option in the right column, so I don't see why it should be different on the netinst vs. the DVD.
Comment 37 Nelson Marques 2012-12-22 12:39:14 EST
My humble opinion,

- MATE 1.5 (development for 1.6) drops most of the GNOME2 infra-structure, replacing it for GNOME3 infra-structure packages. With this move almost 20 packages were removed from MATE, many of them things we all are happy to see go away, ex: libmate (libgnome), ORBit implementation, bonobo, etc. This to say that around 60Mb of upstream dropped stuff are being installed because of two packages: mate-terminal and mate-utils. Since the underneath technology bellow MATE 1.5 is the one of GNOME3, this components (terminal and utils) can easilly be replaced with it's GNOME counter-parts dropping 60Mb in useless dependencies.

- Now as I can see it, we can still save 20Mb more by dropping mate-wallpapers and mate-themes and thus using fedora branding. We can drop the wallpapers and we can drop themes and use Fedora wallpaper and Adwaita as main theme. Since many users will want some GTK3 apps (ex: brasero, totem, gedit, etc) using Adwaita provides supported themes for either GTK2 and GTK3 (and highlight the awesome work made by GNOME upstream with GTK2 theme in Adwaita 3.6). So we can cut off almost 80Mb from the install.

- Suspend/Hibernate is now working properly with the updates blocked on the freeze, the panel crashes were fixed and a few other minor issues issues in the last days. We're starting to rush up on this, being the main delay Bhodi/Karma at the moment. Very good improvements were achieved in the last 2 days.

- The pattern can be improved also, it requires a bit of work.

Regarding the DVD, it isn't really my choice and given the freeze, I would clearly favor not to include it at the current stage, but I would like to ask kindly that we can do a LiveCD under the Fedora umbrella once we have achieved a more stable release, maybe official 1.6 ? :)

I think it is important that the community recognizes the effort of Dan which has been one manning this project, facing all sorts of problems and his commitment has never faulted. Maybe MATE isn't yet ready for a mass release with Fedora, but please in the future (F19) if this problems are sorted I would love to see a bit more of compreension and a small effort to make MATE avaible in official Fedora media, as I for instance would be one of the consumers.
Comment 38 Dan Mashal 2012-12-22 23:48:03 EST
Thank you Nelson, I've trimmed the MATE base group in f18 comps and am testing a DVD compose now. I will then create a mate-extra group.
Comment 39 Wolfgang Ulbrich 2012-12-23 16:58:25 EST
(In reply to comment #37)
> My humble opinion,
> 
> - MATE 1.5 (development for 1.6) drops most of the GNOME2 infra-structure,
> replacing it for GNOME3 infra-structure packages. With this move almost 20
> packages were removed from MATE, many of them things we all are happy to see
> go away, ex: libmate (libgnome), ORBit implementation, bonobo, etc. This to
> say that around 60Mb of upstream dropped stuff are being installed because
> of two packages: mate-terminal and mate-utils. Since the underneath
> technology bellow MATE 1.5 is the one of GNOME3, this components (terminal
> and utils) can easilly be replaced with it's GNOME counter-parts dropping
> 60Mb in useless dependencies.
You better use terminal from xfce instead of gnome-terminal to avoid unnecessary gnome dependencies ;)
Comment 40 satellitgo 2012-12-23 17:03:19 EST
xterm also works
Comment 41 Dan Mashal 2012-12-23 17:38:09 EST
> (In reply to comment #37)
> > My humble opinion,
> > 
> > - MATE 1.5 (development for 1.6) drops most of the GNOME2 infra-structure,
> > replacing it for GNOME3 infra-structure packages. With this move almost 20
> > packages were removed from MATE, many of them things we all are happy to see
> > go away, ex: libmate (libgnome), ORBit implementation, bonobo, etc. This to
> > say that around 60Mb of upstream dropped stuff are being installed because
> > of two packages: mate-terminal and mate-utils. Since the underneath
> > technology bellow MATE 1.5 is the one of GNOME3, this components (terminal
> > and utils) can easilly be replaced with it's GNOME counter-parts dropping
> > 60Mb in useless dependencies.
> You better use terminal from xfce instead of gnome-terminal to avoid
> unnecessary gnome dependencies ;)

+1

(In reply to comment #40)
> xterm also works

We are using xterm temporarily. mate-terminal is almost done being ported to gsettings. Looks like comps finally picked it up. I just created a live cd and it got my changes. Will try to compose a new i386 DVD and see the size
Comment 42 Dan Mashal 2012-12-24 02:43:54 EST
I was able to compose an F18 i386 DVD under 4.7GB. There is no reason to block it off the DVD.

-rw-r--r--. 1 root root 4687134720 Dec 23 23:34 Fedora-18-i386-DVD.iso 

Will test and attach kickstart.
Comment 43 Dan Mashal 2012-12-24 16:08:07 EST
I have composed a new i386 DVD ISO with Cinnamon AND MATE, tested, installs both successfully and under the 4.7GB limit:

<mock-chroot>[root@localhost iso]# ls -lb
total 4918268
-rw-r--r--. 1 root root        236 Dec 24 12:24 Fedora-18-i386-CHECKSUM
-rw-r--r--. 1 root root 4696571904 Dec 24 12:23 Fedora-18-i386-DVD.iso
-rw-r--r--. 2 root root  340787200 Dec 24 12:18 Fedora-18-i386-netinst.iso
Comment 44 Dan Mashal 2012-12-24 16:10:24 EST
Created attachment 668603 [details]
new kickstart with cinnamon and mate for i386 DVD

attached new kickstart
Comment 45 Fedora Update System 2012-12-24 16:20:33 EST
pungi-2.13-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-20843/pungi-2.13-1.fc18
Comment 46 Fedora Update System 2013-01-05 02:16:09 EST
pungi-2.13-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.