Bug 883138

Summary: [custom part usability] Confusion introduced by 'create new mount points below with the + icon' text in custom part
Product: [Fedora] Fedora Reporter: Adam Williamson <awilliam>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 18CC: anaconda-maint-list, bugs.michael, duffy, g.kaviyarasu, jonathan, sbueno, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-04-04 17:37:13 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Adam Williamson 2012-12-03 16:14:14 EST
As discussed in https://lists.fedoraproject.org/pipermail/test/2012-December/112124.html , it seems the combination in newUI custom partitioning of the left-hand pane layout, the possible operations, and the instruction text can have a rather confusing effect.

So we have a chunk of text:

"Or, create new mount points below with the '+' icon."

We have two generally-possible operations:

* Create a new partition and assign a mount point to it
* Assign a mount point for the new install to an existing partition from one of the 'existing installation' groups

We have two candidates for "'+' icon" status:

* The big + button at the bottom of the pane (this is what the text actually means)
* The little + expanders next to each 'existing installation' group (these are also arguably 'icons', and are closer to the text, and *do* expose things with 'mount point' as a property: you can 'create a mount point' from here just as much as you can from the + button)

The result of this, at least in mschwendt's case, was considerable confusion. We don't have a precise plan as to the best way to deal with this yet, but at least one thing that seems to be on the table is to tweak the text somewhat. We could refer to "the '+' button" rather than "the '+' icon". We could look at referring to 'partitions' rather than 'mount points' in some text, though clumens points out that technically sometimes it will be an LV (LVM) or a volume / subvol (btrfs), not a 'partition' (though we might be able to rely on people to make the necessary mental leap there). In my three-pane mockup, I added explict text to say '...or assign mount points to existing partitions below' at the end. All of these are possibilities, and there may be more.
Comment 1 Steve Tyler 2012-12-03 16:40:23 EST
(In reply to comment #0)
> ... We could look at referring to 'partitions' rather than 'mount points'
> in some text, though clumens points out that technically sometimes it will
> be an LV (LVM) or a volume / subvol (btrfs), not a 'partition' (though we
> might be able to rely on people to make the necessary mental leap there).
...

That's part of the problem. The GUI conflates different models of disk and file system layout. And there is no uniform terminology to cover everything.

The user creates mount points, but mount points are neither partitions, nor logical volumes, nor file systems. Mount points are directory names in a file system.

A swap space is not ever mounted, yet "swap" is referred to as a mount point.

"LVM" is the name for the entire technology -- there is an existing term for what is being used where "LVM" appears: "logical volume".

And the user has no idea what is going on WRT volume groups. Only by experiment could I discover that if I created a new logical volume from free space on a disk that had a preexisting volume group, I got a _new_ volume group. That may or may not be what a user wants.
Comment 2 Steve Tyler 2012-12-03 17:33:59 EST
Indeed, the name of the Manual Partitioning dialog is misleading. The dialog permits the user to create logical volumes, which are not partitions, and file systems, which are not partitions either.

The title Custom Disk Configuration would avoid those problems, although a USB stick is not really a disk.

An alternative would be Custom Storage Configuration ...
Comment 3 Steve Tyler 2012-12-03 17:48:16 EST
(In reply to comment #1)
...
> And the user has no idea what is going on WRT volume groups. Only by
> experiment could I discover that if I created a new logical volume from free
> space on a disk that had a preexisting volume group, I got a _new_ volume
> group. That may or may not be what a user wants.

That was referring to anaconda-18.29.2-1.
anaconda-18.34-1 has volume group support. Thanks.
Comment 4 Michael Schwendt 2012-12-03 17:57:53 EST
> Custom Storage Configuration 

Good.

Although, to differ between "Automatic" and "Manual" would be very concise. In general, "customization" can also be automatic, for example. Same as with "configuration".

Manual Configuration - Installation Storage
Manual Configuration - Storage Media
Manual Configuration - Storage Usage
...
[Manual Configuration - Networking]
Comment 5 Adam Williamson 2012-12-03 21:02:38 EST
*sigh*

This is *exactly* what I meant when I said 'please don't discuss unrelated bugs'. I am trying to keep these reports focused. This report is about what's described in my initial report. It is not about the title of the screen. If you want to discuss the title of the screen, please file a separate bug.
Comment 6 Steve Tyler 2012-12-03 21:27:17 EST
In Comment 1, I was responding to what you had already done -- expand the topic beyond whatever the scope of this bug is supposed to be by opening the question of terminology in the user interface.

BTW, in my experience, bug reports about user interface design problems are closed immediately and never reopened. I hope you have a better experience.

PS, please don't send me personal email. I can read your comments here just fine.
Comment 7 Adam Williamson 2012-12-03 22:11:39 EST
"xpand the topic beyond whatever the scope of this bug is supposed to be by opening the question of terminology in the user interface."

the question of terminology *is* the scope of this bug. But it is specific terminology in specific places, not 'any terminology anywhere you come across it'. It is about the text "Or, create new mount points below with the '+' icon." and its associated UI elements. It is not about anything else.
Comment 8 Steve Tyler 2012-12-03 22:38:10 EST
OK, then we agree that there is a problem with the terminology. :-)

The next step is to agree that the terminology needs to be consistent throughout the dialog and consistent with accepted technical usage of such terms as "mount point", "partition", "logical volume", "file system", etc.

Maybe the scope of this bug is bigger than you realized ... :-)
Comment 9 Michael Schwendt 2012-12-04 03:36:44 EST
Hmm, I'm removing myself from the Cc field then, ... 

... because IMO it makes no sense to discuss the terminology used on the current "Manual partitioning" screen (that's what it's called - bug 882542) outside its context. Remember what the user has read and clicked to arrive on that screen. If you give the screen the title "Manual partitioning", the stuff on it ought to be related. If you find a more general title, it could be much more easy to use different terminology.

The "confusion" (and initial cluelessness) had started on the previous screen and dialog already where I had to click buttons in trial-and-error fashion rather than intuitively.

In either case, the multiple '+' signs (whether buttons or icons) are ambiguous. Referring to "below" is rather vague, too, since one reads from top to bottom, and the '+' in front of the unfoldable sections may be the first '+' one will notice. It didn't matter what '+' I used. By unfolding one '+' section I got access to a user interface I could use to do what needed to be done.

In that section on that screen I created mount-points and assigned storage to them, *or* I assigned mount-points to existing storage ("storage devices", "storage units", ...). That's what the text at the top refers to: creating mount-points. Nowhere on the screen did I do anything to "partitions". The screen even tries to hide partition device names except in the "Unknown" section. It didn't give a hint whether the "Root" I reused was the logical volume I actually wanted to reuse or the logical partition I wanted to keep.

The actual '+'/'-' buttons near the bottom, I cannot comment on [yet] beyond the added feedback on test list (the most essential functions probably being hidden in later options one does not see in the initial dialog, and confusing warnings like "removing all data on ..." when clicking the '-' button).
Comment 10 Adam Williamson 2012-12-04 13:06:27 EST
Michael: please don't (remove yourself from CC). The scope of the bug is as I defined it. We can just ignore Steve's attempts to broaden it out.
Comment 11 Chris Lumens 2013-03-26 15:33:00 EDT
First, it now says "by clicking the '+' button".  Second, the GTK theme now shows the expanders are little grey triangles instead of [+] boxes.  I see only one plus sign on the whole screen.  Good?
Comment 12 Máirín Duffy 2013-03-27 12:21:56 EDT
Chris, didn't you also remove the expander from custom partitioning for the fs/device type stuff? So no expander left at this point on this screen anymore :)
Comment 13 Chris Lumens 2013-03-27 12:38:17 EDT
Yes, I have also removed that expander.  The only expanders remaining are on the accordion on the left hand side of the screen, and they do not have a plus sign anywhere.
Comment 14 Adam Williamson 2013-03-27 19:12:33 EDT
Yeah, it looks good to me in F19. Michael, does the above description and/or F19 Alpha TC2 look good to you (if you can make it to custom partitioning - try the live image if it fails on netinst/DVD)? Thanks!
Comment 15 Adam Williamson 2013-03-28 13:16:33 EDT
clumens: if we don't get a reply from Michael in the next few days I'd be fine with closing this then.
Comment 16 Michael Schwendt 2013-03-28 17:58:26 EDT
Cannot promise anything atm.

* I've downloaded TC2, copied it onto an USB stick (since I cannot afford losing time with testing DVD image on HDD based installs during the next few weeks). 

* I've booted via USB, but couldn't figure out how to proceed. I've been stuck at the main screen with a yellow exclamation mark telling me that I still need to select a disk, but I've visited that item several times, selected the only HDD and have been tried the dialog with the "Custom partitioning" and "Reclaim space" buttons, too. Gone back and forth for a few minutes, then Anaconda locked up hard with a grey empty screen.

Will try again, of course, but not at the top of my todo list.
Comment 17 Adam Williamson 2013-03-28 18:03:13 EDT
oh, duh. I forgot custom part is busted in TC2. Sorry :/ https://bugzilla.redhat.com/show_bug.cgi?id=926926

should be fixed in TC3.

You can probably try with TC1.
Comment 18 Adam Williamson 2013-04-04 17:37:13 EDT
Let's just close this, I think it's fine. If Michael disagrees when he gets a TC to custom part - Michael, TC4 is out now and ought to be able to make it there at least - leave us a note and we'll re-open, thanks!
Comment 19 Michael Schwendt 2013-04-05 08:34:46 EDT
Confirmed. TC4 looks less confusing, but I still cannot spend much time on this or react quickly to needinfo queries. Also please note that I haven't opened this ticket.
Comment 20 Adam Williamson 2013-04-05 15:12:36 EDT
Right, but I opened it based largely on your feedback, so I wanted to take your input into account before closing it if possible.