This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 926926 - Anaconda is not allowing continuation when custom partitioning is selected.
Anaconda is not allowing continuation when custom partitioning is selected.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 927927 927951 (view as bug list)
Depends On:
Blocks: F19Beta/F19BetaBlocker fedora19rtt
  Show dependency treegraph
 
Reported: 2013-03-24 04:36 EDT by John Dulaney
Modified: 2014-06-18 05:06 EDT (History)
16 users (show)

See Also:
Fixed In Version: anaconda-19.14-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-05 14:49:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (6.80 KB, text/plain)
2013-03-26 08:02 EDT, Martin Banas
no flags Details
packaging.log (460.49 KB, text/plain)
2013-03-26 08:02 EDT, Martin Banas
no flags Details
program.log (14.69 KB, text/plain)
2013-03-26 08:02 EDT, Martin Banas
no flags Details
step1.png (58.89 KB, image/png)
2013-03-26 08:02 EDT, Martin Banas
no flags Details
step2.png (89.83 KB, image/png)
2013-03-26 08:02 EDT, Martin Banas
no flags Details
step3.png (66.25 KB, image/png)
2013-03-26 08:02 EDT, Martin Banas
no flags Details
storage.log (83.12 KB, text/plain)
2013-03-26 08:03 EDT, Martin Banas
no flags Details
syslog (77.21 KB, text/plain)
2013-03-26 08:03 EDT, Martin Banas
no flags Details

  None (edit)
Description John Dulaney 2013-03-24 04:36:48 EDT
Description of problem:
Select custom partitioning, Anaconda returns to hub screen, but does not allow any option to continue.


How reproducible:
Always

Steps to Reproduce:
1. Click on select disk button in main hub
2. Select install disk
3. Click Done
4. Click Custom Partition button
  
Actual results:
Anaconda does not present any options to continue the installation or select custom partitioning.

Expected results:
To be able to continue to a custom partitioning screen of some sort.

Additional info:
Proposing as a Beta blocker under the following criteria:

10.   The installer's custom partitioning mode must be capable of the following:

    Creating, destroying and assigning mount points to partitions of any specified size using most commonly-used filesystem types
    Creating encrypted partitions
    Rejecting obviously invalid operations without crashin
Comment 1 Chris Lumens 2013-03-25 10:03:05 EDT
Please attach a picture showing what you mean.
Comment 2 Adam Williamson 2013-03-25 10:59:29 EDT
I do not see this in TC1 live...
Comment 3 Martin Banas 2013-03-26 08:01:46 EDT
John, I tried to reproduce your issue. Please confirm if it's what you see.. Thanks.

Reproduced on TC2:

1. Select all disks, click on Done (step1.png)
2. Click on Custom partitioning (step2.png)

Result:
Anaconda jumps directly to main hub (step3.png)
Comment 4 Martin Banas 2013-03-26 08:02:31 EDT
Created attachment 716463 [details]
anaconda.log
Comment 5 Martin Banas 2013-03-26 08:02:36 EDT
Created attachment 716464 [details]
packaging.log
Comment 6 Martin Banas 2013-03-26 08:02:41 EDT
Created attachment 716465 [details]
program.log
Comment 7 Martin Banas 2013-03-26 08:02:46 EDT
Created attachment 716466 [details]
step1.png
Comment 8 Martin Banas 2013-03-26 08:02:53 EDT
Created attachment 716467 [details]
step2.png
Comment 9 Martin Banas 2013-03-26 08:02:58 EDT
Created attachment 716468 [details]
step3.png
Comment 10 Martin Banas 2013-03-26 08:03:02 EDT
Created attachment 716469 [details]
storage.log
Comment 11 Martin Banas 2013-03-26 08:03:08 EDT
Created attachment 716470 [details]
syslog
Comment 12 Chris Lumens 2013-03-26 10:20:57 EDT
*** Bug 927927 has been marked as a duplicate of this bug. ***
Comment 13 Chris Lumens 2013-03-26 10:44:38 EDT
Here's the problem:

11:55:14,397 ERR anaconda: Failed to import module in collect: cannot import name gtk_thread_wait
Comment 14 Chris Lumens 2013-03-26 10:48:52 EDT
*** Bug 927951 has been marked as a duplicate of this bug. ***
Comment 15 dominique 2013-03-26 14:20:01 EDT
I have same issue with anaconda when I want install Fedora-19-alpha TC2.

1. Select one disk (I have just one disk), click on Done 
2. Click on Custom partitioning 
And I return on step3.png
Comment 16 Mukundan Ragavan 2013-03-26 14:35:53 EDT
same here on netinstall, F19-TC2. Custom partitioning returns to hub.

Adding myself to cc.
Comment 17 John Dulaney 2013-03-26 15:18:26 EDT
Confirming that screenshots show what happened.
Comment 18 Tao Wu 2013-03-27 08:54:41 EDT
Reproduced on my test of F19 Alpha TC2 i386 which is installed into kvm.
Comment 19 Adam Williamson 2013-03-27 12:26:53 EDT
tc2 doesn't have the fix for this, there wasn't a new anaconda build yet.
Comment 20 dominique 2013-03-27 12:34:10 EDT
when tc3 (or other fixing this bug) will be available ?
Comment 21 Adam Williamson 2013-03-27 19:15:14 EDT
not sure precisely, but not very long.
Comment 22 Ľuboš Kardoš 2013-04-05 05:27:18 EDT
Verified on Fedora 19 TC 5.
Comment 23 Adam Williamson 2013-04-05 14:49:45 EDT
19.14 went stable, so closing (this was OK in TC3).

Note You need to log in before you can comment on or make changes to this bug.