Bug 885139

Summary: TypeError: not enough arguments for format string
Product: [Fedora] Fedora Reporter: Bill Peck <bpeck>
Component: yumAssignee: Fedora Packaging Toolset Team <packaging-team>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: admiller, amcnabb, awilliam, ffesti, g.kaviyarasu, jonathan, kwizart, larryoleary, packaging-team, sbueno, tla, vanmeeuwen+fedora, zpavlas
Target Milestone: ---Keywords: CommonBugs
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:e534de7fc8bd341d9487ffca14463d6ed003f8a7b7d8d80709ee5b34887da0f7 https://fedoraproject.org/wiki/Common_F18_bugs#repos-with-spaces
Fixed In Version: yum-3.4.3-48.fc18 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-28 10:19:30 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
File: release
none
File: product
none
File: type
none
File: storage.log
none
File: version
none
File: environ
none
File: executable
none
File: anaconda.log
none
File: syslog
none
File: hashmarkername
none
File: packaging.log
none
File: cmdline_file
none
File: ks.cfg
none
File: anaconda-tb
none
File: program.log none

Description Bill Peck 2012-12-07 10:16:46 EST
Description of problem:
Trying to do a network install from kickstart.  Using additional repos.  Before this I was informed that package X is not available (even though it was in the repos I added from kickstart), do I want to continue?  I said yes.  I did this for several more packages before getting this error report.

Thanks


Version-Release number of selected component:
anaconda-18.35

Additional info:
libreport version: 2.0.18
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.9-4.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.35 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/logging/__init__.py", line 328, in getMessage
:    msg = msg % self.args
:  File "/usr/lib64/python2.7/logging/__init__.py", line 464, in format
:    record.message = record.getMessage()
:  File "/usr/lib64/python2.7/logging/__init__.py", line 723, in format
:    return fmt.format(record)
:  File "/usr/lib64/python2.7/logging/handlers.py", line 791, in emit
:    msg = self.format(record) + '\000'
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/anaconda_log.py", line 114, in emit
:    SysLogHandler.emit(self, record)
:  File "/usr/lib64/python2.7/logging/__init__.py", line 748, in handle
:    self.emit(record)
:  File "/usr/lib64/python2.7/logging/__init__.py", line 1308, in callHandlers
:    hdlr.handle(record)
:  File "/usr/lib64/python2.7/logging/__init__.py", line 1268, in handle
:    self.callHandlers(record)
:  File "/usr/lib64/python2.7/logging/__init__.py", line 1258, in _log
:    self.handle(record)
:  File "/usr/lib64/python2.7/logging/__init__.py", line 1184, in critical
:    self._log(CRITICAL, msg, args, **kwargs)
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 3656, in selectGroup
:    self.logger.critical(_('Group %s does have %u conditional packages, which may get installed.'), count_cond_test)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1056, in _selectYumGroup
:    self._yum.selectGroup(groupid, group_package_types=pkg_types)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1179, in _applyYumSelections
:    self._selectYumGroup(group.name, default=default, optional=optional)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1209, in checkSoftwareSelection
:    self._applyYumSelections()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1294, in preInstall
:    self.checkSoftwareSelection()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 125, in doInstall
:    payload.preInstall(packages=packages, groups=payload.languageGroups(ksdata.lang.lang))
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
:    threading.Thread.run(self, *args, **kwargs)
:TypeError: not enough arguments for format string
Comment 1 Bill Peck 2012-12-07 10:16:50 EST
Created attachment 659439 [details]
File: release
Comment 2 Bill Peck 2012-12-07 10:16:51 EST
Created attachment 659440 [details]
File: product
Comment 3 Bill Peck 2012-12-07 10:16:53 EST
Created attachment 659441 [details]
File: type
Comment 4 Bill Peck 2012-12-07 10:16:55 EST
Created attachment 659442 [details]
File: storage.log
Comment 5 Bill Peck 2012-12-07 10:17:37 EST
Created attachment 659443 [details]
File: version
Comment 6 Bill Peck 2012-12-07 10:17:39 EST
Created attachment 659444 [details]
File: environ
Comment 7 Bill Peck 2012-12-07 10:17:40 EST
Created attachment 659445 [details]
File: executable
Comment 8 Bill Peck 2012-12-07 10:17:42 EST
Created attachment 659446 [details]
File: anaconda.log
Comment 9 Bill Peck 2012-12-07 10:17:44 EST
Created attachment 659447 [details]
File: syslog
Comment 10 Bill Peck 2012-12-07 10:17:45 EST
Created attachment 659448 [details]
File: hashmarkername
Comment 11 Bill Peck 2012-12-07 10:17:47 EST
Created attachment 659449 [details]
File: packaging.log
Comment 12 Bill Peck 2012-12-07 10:17:56 EST
Created attachment 659450 [details]
File: cmdline_file
Comment 13 Bill Peck 2012-12-07 10:17:57 EST
Created attachment 659451 [details]
File: ks.cfg
Comment 14 Bill Peck 2012-12-07 10:18:00 EST
Created attachment 659452 [details]
File: anaconda-tb
Comment 15 Bill Peck 2012-12-07 10:18:02 EST
Created attachment 659453 [details]
File: program.log
Comment 16 Chris Lumens 2012-12-07 10:27:12 EST
This looks like the error line in question:

self.logger.critical(_('Group %s does have %u conditional packages, which may get installed.'), count_cond_test)
Comment 17 Bill Peck 2012-12-07 10:30:18 EST
Looking at the anaconda.log did show me a problem with the custom repos I added.

10:12:21,785 WARN yum.YumBase: Bad id for repo: Adobe Flash, byte =   5
10:12:21,785 WARN yum.YumBase: Bad id for repo: RPM Fusion for Fedora 18 - Free, byte =   3
10:12:21,786 WARN yum.YumBase: Bad id for repo: RPM Fusion for Fedora 18 - Nonfree, byte =   3

Byte 3 and 5 show a space.  I went into the ks.cfg and replaced all " " with "_" and I no longer get the missing package errors.  But I still get the same traceback.

Should I file a bug about the space issue?  That used to work with F17, I'm using the same kickstarts.
Comment 18 Bill Peck 2012-12-08 12:23:57 EST
Same error happens with Test Compose 1 as well.
Comment 19 Zdeněk Pavlas 2012-12-10 03:01:00 EST
http://yum.baseurl.org/gitweb?p=yum.git;a=commitdiff;h=4687ffe

Fixed upstream, will build -48.fc18 if necessary.
Comment 20 Zdeněk Pavlas 2013-01-07 07:17:26 EST
*** Bug 889608 has been marked as a duplicate of this bug. ***
Comment 21 Zdeněk Pavlas 2013-01-16 09:04:12 EST
*** Bug 895741 has been marked as a duplicate of this bug. ***
Comment 22 Fedora Update System 2013-01-16 09:34:57 EST
yum-3.4.3-48.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/yum-3.4.3-48.fc18
Comment 23 Fedora Update System 2013-01-18 15:46:47 EST
Package yum-3.4.3-48.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-3.4.3-48.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0959/yum-3.4.3-48.fc18
then log in and leave karma (feedback).
Comment 24 Fedora Update System 2013-01-28 10:19:32 EST
yum-3.4.3-48.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 Nicolas Chauvet (kwizart) 2013-01-28 18:02:36 EST
I would like to add this issue as a commonbug

Here is a IRC report on #fedora-devel

<bakers> Did the options for including/excluding packages in kickstart change? I can't add a package in kickstart. I get errors that the package doesn't exist when I KNOW it does
<bakers> Here is my file: [...]
<bakers> I'm just trying to install postfix at the time of install
<kwizart> bakers, try not to have space in "repo' names
<bakers> kwizart: repo --name="Fedora 18 - x86_64" you mean that?
<kwizart> there is a yum issue related to that
...
<bakers> kwizart: SOB! I think that was it!
<bakers> I've been working on this for a week!

The workaround is to remove space from the name of the repo.

There is already a kickstart bug listed as commonbug and it should be rather common for kickstart users to list several additional repositories including fedora ones for their installs. Also the experienced error doesn't explicitly point to the solution as if the problem when the kickstart was parsed.
Comment 26 Zdeněk Pavlas 2013-01-29 10:43:57 EST
*** Bug 904702 has been marked as a duplicate of this bug. ***