Bug 885850

Summary: RHEVH iSCSI initiator name change not persistent until a reboot
Product: Red Hat Enterprise Linux 6 Reporter: Brett Thurber <bthurber>
Component: ovirt-nodeAssignee: Fabian Deutsch <fdeutsch>
Status: CLOSED ERRATA QA Contact: Virtualization Bugs <virt-bugs>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 6.3CC: acathrow, agrover, bsarathy, cboyle, coughlan, cpelland, cshao, gouyang, hadong, jboggs, leiwang, mburns, mgoldboi, ovirt-bugs, ovirt-maint, ycui
Target Milestone: rcKeywords: ZStream
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Previously, changing the iSCSI initiator name on the hypervisor console did not take effect until the hypervisor was rebooted. Now, the iSCSI daemon is automatically restarted when changes are made in the hypervisor console, so changes to the initiator name are persistent.
Story Points: ---
Clone Of:
: 902586 902592 (view as bug list) Environment:
Last Closed: 2014-01-21 14:16:49 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1022783    
Bug Blocks: 902586, 902592, 913686    

Description Brett Thurber 2012-12-10 14:39:47 EST
Description of problem:
In RHEVH console, under Remote Storage Configuration, change the intiator name on the RHEVH host.  Without rebooting RHEVH, try and connect to a iSCSI target.  Initiator name on the storage device is identified as the original name for the RHEVH host, not the updated name.  A reboot of the RHEVH host resolves this.

Version-Release number of selected component (if applicable):
3.1 GA
RHEV Hypervisor - 6.3 - 20121121.0.el6_3

How reproducible:
Every time.

Steps to Reproduce:
1.  Change the initiator name on the RHEVH host.
2.  Connect to a iSCSI target.  Observe the initiator name used was the original, not the new name. 
3.  Reboot RHEVH host to resolve initiator name change.
  
Actual results:
Initiator name change in RHEV console does not take affect until a reboot.

Expected results:
Initiator name change in RHEV console should be immediately persistent without a reboot.

Additional info:
N/A
Comment 1 Mike Burns 2012-12-11 11:47:46 EST
NOTE:  this is for filing upstream ovirt-node bugs, not RHEV-H bugs.  Those should go through a support case with Red Hat.

The bug itself will likely apply to ovirt-node iso images as well, so I'll keep it open.

Joey -- probably just a matter of restarting the right iscsi daemon after making the change.
Comment 2 Joey Boggs 2013-01-21 22:22:56 EST
looks to be a problem with the iscsi service starting and only in RHEV-H moving there

[root@localhost ~]# service iscsi status
No active sessions
[root@localhost ~]# service iscsi restart
Stopping iscsi:                                            [  OK  ]
[root@localhost ~]# service iscsi status
iscsi is stopped

-----------------
commenting out the below and finishing out the init script start function

    # if no nodes are setup to startup automatically exit cleanly
#    grep -qrs "node.startup = automatic" /var/lib/iscsi/nodes
#    [ $? -eq 0 ] || exit 0



-------------------
[root@localhost ~]# service iscsi restart
Stopping iscsi:                                            [  OK  ]
Starting iscsi: iscsiadm: No records found
                                                           [  OK  ]
[root@localhost ~]# service iscsi status
No active sessions
Comment 6 Chris Leech 2013-01-24 20:07:06 EST
I'm guessing that all the management console is doing is editing /etc/iscsi/initiatorname.iscsi ?  Unfortunately iscsid will not pick up changes without a restart.

Also, in comment #2 there are references to the iscsi service.  The iscsi service is for bringing up persistent sessions configures as automatic.  What needs to be restarted is the iscsid service.
Comment 8 Joey Boggs 2013-01-24 20:59:17 EST
*** Bug 902592 has been marked as a duplicate of this bug. ***
Comment 16 Charlie 2013-11-11 23:54:37 EST
Reviewed text
Comment 18 errata-xmlrpc 2014-01-21 14:16:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html