Bug 88957

Summary: Installer crashes when trying to format drives
Product: [Retired] Red Hat Linux Reporter: Brendan Gray <bgray2>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED DUPLICATE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: i586   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:52:42 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Description Flags
crash dump from anaconda during install none

Description Brendan Gray 2003-04-15 18:04:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461)

Description of problem:
During text based installation, after going through disk druid, installer 
crashed while trying to format the swap space.  I had it set to check for bad 
blocks during format.

It also happens on RedHat 8, RH 7.3, and 7.2.

The machine was running RedHat 7.0 fine when I tried to do a fresh install.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.start linux text install
2.follow all steps
3.installer will crash when either trying to format hard drive, or when ready 
to begin package install

Actual Results:  If I tell disk druid to check for bad blocks, it will crash 
quicker than if I don't.  If I don't tell it to check for bad blocks, it won't 
crash until after package selection, and when its formatting and getting ready 
to install packages.

Additional info:

Compaq Deskpro 2000 5200MMX
Pentium 200 MMX
64 meg RAM
3 gig HD

I collected the crash dump onto a floppy.
It was running RedHat 7.0 fine, and when trying to do a fresh install of RH 9 I 
got this error.  I got the same errors when trying RedHat 8, RH 7.3, and RH 7.2.

Comment 1 Brendan Gray 2003-04-15 18:07:56 UTC
Created attachment 91144 [details]
crash dump from anaconda during install

Comment 2 Brendan Gray 2003-04-17 18:22:08 UTC
I found a workable solution to my install problem.  I first installed RedHat 
7.0, then did a upgrade to RedHat 9, instead of trying a fresh install.  It 
worked perfectly as it should have.  So RedHat 9 (and also RedHat 8) won't 
install fresh on a Compaq Deskpro 2000 5200MMX, but RedHat 7.0 will.

Comment 3 Michael Fulbright 2003-04-22 15:42:43 UTC
It appears you were getting read errors from one of your CDs when the above
error occurred. Apparently the read error is sporatic if you were able to
upgrade with the same CDs.

*** This bug has been marked as a duplicate of 75008 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:52:42 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.