Bug 890644

Summary: Installing "Identity Management Server" failing dependencies
Product: Red Hat Enterprise Linux 6 Reporter: W. de Heiden <wdh>
Component: ipaAssignee: Rob Crittenden <rcritten>
Status: CLOSED DUPLICATE QA Contact: Namita Soman <nsoman>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.4CC: abokovoy, asn, dpal, mkosek, sbose, ssorce
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 891874 (view as bug list) Environment:
Last Closed: 2013-01-14 07:27:36 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 891874    
Attachments:
Description Flags
Screenshot failed installation none

Description W. de Heiden 2012-12-28 07:10:26 EST
Created attachment 669806 [details]
Screenshot failed installation

Description of problem:
Installing "Identiy Management Server" from the RHEL 6.4 (x86_64) beta DVD will complain about samba4-common and samba4-winbind.


Version-Release number of selected component (if applicable):
RHEL 6.4 beta

How reproducible:


Steps to Reproduce:
1. Start RHEL 6 installation from DVD
2. Select "Identity Management Server" to install
3. When resolving dependencies, it will complain
  
Actual results:
Can't continue installing unless "Identity Management Server" is deselected

Expected results:
RHEL 6.4 with IPA installed

Additional info:
Comment 2 RHEL Product and Program Management 2013-01-01 01:47:35 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 W. de Heiden 2013-01-01 09:31:42 EST
This answere surprises me: "if still desired, for consideration in
the next release of Red Hat Enterprise Linux"

This just cannot be a feature request; it is a "normal bug" in the installion DVD. OK, it is a beta release and therefor this bug report. There is a dependency problem since the de (group package) installation of "Identity Server Manager" is expecting some Samba4 packages which of course are not there.

Please take a brief look at the attachment.
Comment 4 Dmitri Pal 2013-01-01 22:19:53 EST
(In reply to comment #3)
> This answere surprises me: "if still desired, for consideration in
> the next release of Red Hat Enterprise Linux"
> 
> This just cannot be a feature request; it is a "normal bug" in the
> installion DVD. OK, it is a beta release and therefor this bug report. There
> is a dependency problem since the de (group package) installation of
> "Identity Server Manager" is expecting some Samba4 packages which of course
> are not there.
> 
> Please take a brief look at the attachment.

Sorry, this is a bug bot reply. It kicked in because of the holidays and no one was around to look at the bug. I will see what can be done.
Comment 9 Martin Kosek 2013-01-04 05:23:45 EST
We had a discussion with Sumit Bose and we agreed on the following proposed solution:

As ipa-server-trust-ad is not required for basic IPA server function (only when AD trusts are being configured), move it to list of Optional Packages in Identity Management Server to avoid this kind of conflicts

Conflicting group configuration:

Group: Identity Management Server
 Description: Centralized management of users, servers and authentication policies.
 Default Packages:
   389-ds-base
   ipa-admintools
   ipa-pki-ca-theme
   ipa-pki-common-theme
   ipa-server
   ipa-server-trust-ad    <- requires samba4 packages
   mod_revocator
   pki-ca
   pki-silent
 Optional Packages:
   nuxwdog
   slapi-nis

Group: CIFS file server
 Description: Share files between Linux and Microsoft Windows systems.
 Mandatory Packages:
   samba
 Optional Packages:
   tdb-tools

The Bugzilla will be cloned for releng and current Bugzilla will only be used to file a release note.
Comment 10 Martin Kosek 2013-01-14 07:27:36 EST
Closing as duplicate to 891874 as the samba4-* requirement and related conflict has been described in Doc Text for Bug 766179 (ipa AD Trust feature RFE).

*** This bug has been marked as a duplicate of bug 891874 ***