Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 890644 - Installing "Identity Management Server" failing dependencies
Summary: Installing "Identity Management Server" failing dependencies
Keywords:
Status: CLOSED DUPLICATE of bug 891874
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Rob Crittenden
QA Contact: Namita Soman
URL:
Whiteboard:
Depends On:
Blocks: 891874
TreeView+ depends on / blocked
 
Reported: 2012-12-28 12:10 UTC by W. de Heiden
Modified: 2013-01-14 12:27 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 891874 (view as bug list)
Environment:
Last Closed: 2013-01-14 12:27:36 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot failed installation (154.35 KB, image/png)
2012-12-28 12:10 UTC, W. de Heiden
no flags Details

Description W. de Heiden 2012-12-28 12:10:26 UTC
Created attachment 669806 [details]
Screenshot failed installation

Description of problem:
Installing "Identiy Management Server" from the RHEL 6.4 (x86_64) beta DVD will complain about samba4-common and samba4-winbind.


Version-Release number of selected component (if applicable):
RHEL 6.4 beta

How reproducible:


Steps to Reproduce:
1. Start RHEL 6 installation from DVD
2. Select "Identity Management Server" to install
3. When resolving dependencies, it will complain
  
Actual results:
Can't continue installing unless "Identity Management Server" is deselected

Expected results:
RHEL 6.4 with IPA installed

Additional info:

Comment 2 RHEL Program Management 2013-01-01 06:47:35 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 3 W. de Heiden 2013-01-01 14:31:42 UTC
This answere surprises me: "if still desired, for consideration in
the next release of Red Hat Enterprise Linux"

This just cannot be a feature request; it is a "normal bug" in the installion DVD. OK, it is a beta release and therefor this bug report. There is a dependency problem since the de (group package) installation of "Identity Server Manager" is expecting some Samba4 packages which of course are not there.

Please take a brief look at the attachment.

Comment 4 Dmitri Pal 2013-01-02 03:19:53 UTC
(In reply to comment #3)
> This answere surprises me: "if still desired, for consideration in
> the next release of Red Hat Enterprise Linux"
> 
> This just cannot be a feature request; it is a "normal bug" in the
> installion DVD. OK, it is a beta release and therefor this bug report. There
> is a dependency problem since the de (group package) installation of
> "Identity Server Manager" is expecting some Samba4 packages which of course
> are not there.
> 
> Please take a brief look at the attachment.

Sorry, this is a bug bot reply. It kicked in because of the holidays and no one was around to look at the bug. I will see what can be done.

Comment 9 Martin Kosek 2013-01-04 10:23:45 UTC
We had a discussion with Sumit Bose and we agreed on the following proposed solution:

As ipa-server-trust-ad is not required for basic IPA server function (only when AD trusts are being configured), move it to list of Optional Packages in Identity Management Server to avoid this kind of conflicts

Conflicting group configuration:

Group: Identity Management Server
 Description: Centralized management of users, servers and authentication policies.
 Default Packages:
   389-ds-base
   ipa-admintools
   ipa-pki-ca-theme
   ipa-pki-common-theme
   ipa-server
   ipa-server-trust-ad    <- requires samba4 packages
   mod_revocator
   pki-ca
   pki-silent
 Optional Packages:
   nuxwdog
   slapi-nis

Group: CIFS file server
 Description: Share files between Linux and Microsoft Windows systems.
 Mandatory Packages:
   samba
 Optional Packages:
   tdb-tools

The Bugzilla will be cloned for releng and current Bugzilla will only be used to file a release note.

Comment 10 Martin Kosek 2013-01-14 12:27:36 UTC
Closing as duplicate to 891874 as the samba4-* requirement and related conflict has been described in Doc Text for Bug 766179 (ipa AD Trust feature RFE).

*** This bug has been marked as a duplicate of bug 891874 ***


Note You need to log in before you can comment on or make changes to this bug.