Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.

Bug 912707

Summary: rhsmd Calling Deprecated hasNow Function
Product: Red Hat Enterprise Linux 5 Reporter: Devan Goodwin <dgoodwin>
Component: subscription-managerAssignee: Bryan Kearney <bkearney>
Status: CLOSED DUPLICATE QA Contact: IDM QE LIST <seceng-idm-qe-list>
Severity: low Docs Contact:
Priority: unspecified    
Version: 5.10CC: bkearney, fsharath, jgalipea, jsefler, pmutha
Target Milestone: beta   
Target Release: 5.10   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-04-30 15:27:02 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 840995, 920191    

Description Devan Goodwin 2013-02-19 08:24:43 EST
Some functionality was deprecated in python-rhsm, at the same time we replaced it's usage in subscription-manager but one call was missed in rhsmd:


/usr/libexec/rhsmd -s
/usr/lib64/python2.4/site-packages/rhsm/certificate.py:123: DeprecationWarning: Call to deprecated function: hasNow
  category=DeprecationWarning)



This should be updated to the new certificate2 module, I believe the method would be is_valid.
Comment 3 Bryan Kearney 2013-02-21 13:20:46 EST
commit 5557f0bec9b582582a51d5207712c48c00d03d9d
Author: Bryan Kearney <bkearney@redhat.com>
Date:   Wed Feb 20 14:39:33 2013 -0500

    912707: Remove a use of the deprecated hasNow() function.
Comment 4 RHEL Product and Program Management 2013-04-09 16:54:51 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 Sharath Dwaral 2013-04-30 15:23:57 EDT
# rpm -qa | egrep "subscription-manager|python-rhsm"
python-rhsm-1.8.9-1.git.7.214419e.el5
subscription-manager-migration-data-1.11.2.7-1.git.0.1dfd00e.el5
subscription-manager-gui-1.8.6-1.git.7.96019b0.el5
subscription-manager-firstboot-1.8.6-1.git.7.96019b0.el5
subscription-manager-migration-1.8.6-1.git.7.96019b0.el5
subscription-manager-1.8.6-1.git.7.96019b0.el5


# /usr/libexec/rhsmd -s

No longer throws any warning.


VERIFIED
Comment 6 Sharath Dwaral 2013-04-30 15:27:02 EDT

*** This bug has been marked as a duplicate of bug 913118 ***