Bug 914002

Summary: felix-osgi-foundation: FTBFS in rawhide
Product: [Fedora] Fedora Reporter: Dennis Gilmore <dennis>
Component: felix-osgi-foundationAssignee: Mikolaj Izdebski <mizdebsk>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: high    
Version: rawhideCC: mat.booth, mizdebsk
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 1.2.0-12 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-26 03:06:46 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 914651    
Bug Blocks: 913825    

Description Dennis Gilmore 2013-02-22 04:23:13 EST
Your package felix-osgi-foundation failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=4960943

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/943/4960943/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/943/4960943/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/943/4960943/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
Comment 1 Mikolaj Izdebski 2013-02-22 07:33:18 EST
So far this package doesn't build in rawhide because
of broken bouncycastle-main, see bug #914574 for more details.

I am adding dependency on bug #914574 and I will investigate
the real cause of the FTBFS once bouncycastle-mail is fixed.
Comment 2 Mikolaj Izdebski 2013-02-22 07:36:57 EST
In comment #1 I meant bug #914651, not bug #914574.
Fixing bug dependency. Sorry.
Comment 3 Mikolaj Izdebski 2013-02-25 11:00:40 EST
Fixed in felix-osgi-foundation-1.2.0-12
Comment 4 Mikolaj Izdebski 2013-02-26 03:06:46 EST
I believe that this bug is fixed in felix-osgi-foundation-1.2.0-12,
which is available in Fedora Rawhide, so I am closing this bug now.
Thank you for reporting it.  You are welcome to submit any further reports.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=398250