Bug 914651 - This package has a broken dependency on bouncycastle = 1.46 in f19 rawhide
This package has a broken dependency on bouncycastle = 1.46 in f19 rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bouncycastle-mail (Show other bugs)
19
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Mat Booth
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 913869 913878 913879 913921 914001 914002 914029 914030 914078 914081 914098 914100 914101 914165 914167 914169 914171 914176 914177 914199 914229 914574 914577 914579 914580 914621 966051
  Show dependency treegraph
 
Reported: 2013-02-22 07:12 EST by Mat Booth
Modified: 2014-03-14 12:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-14 12:39:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this might help (2.07 KB, patch)
2013-05-22 09:50 EDT, Caolan McNamara
no flags Details | Diff

  None (edit)
Description Mat Booth 2013-02-22 07:12:25 EST
Bouncycastle was updated to 1.48, but this package has a hard dependency on bouncycastle = 1.46.

See this log extract:
http://koji.fedoraproject.org/koji/watchlogs?taskID=5043080

Getting requirements for woden-1.0-0.4.M9.fc19.src
 --> 1:java-1.7.0-openjdk-devel-1.7.0.9-2.3.7.0.fc19.x86_64
 --> jpackage-utils-1.7.5-24.fc19.noarch
 --> maven-local-0.12.2-1.fc19.noarch
 --> XmlSchema-1.4.7-2.fc18.noarch
 --> apache-commons-logging-1.1.1-23.fc19.noarch
 --> log4j-1.2.17-8.fc19.noarch
 --> xerces-j2-2.11.0-12.fc19.noarch
 --> axiom-1.2.12-5.fc19.noarch
Error: Package: bouncycastle-mail-1.46-7.fc19.noarch (build)
           Requires: bouncycastle = 1.46
           Available: bouncycastle-1.48-1.fc19.noarch (build)
               bouncycastle = 1.48-1.fc19
Error: Package: bouncycastle-mail-1.46-7.fc19.noarch (build)
           Requires: bouncycastle = 1.46
           Installing: bouncycastle-1.48-1.fc19.noarch (build)
               bouncycastle = 1.48-1.fc19
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 1 Mat Booth 2013-03-02 16:43:44 EST
The build of bouncycastle that was causing this problem seems to have been trashcan'd for now:

http://koji.fedoraproject.org/koji/buildinfo?buildID=397452
Comment 2 Fedora End Of Life 2013-04-03 11:31:43 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 3 Caolan McNamara 2013-05-22 09:50:49 EDT
Created attachment 751729 [details]
this might help
Comment 4 Caolan McNamara 2013-05-24 11:31:31 EDT
Digging around it seems upstream split bouncycastle-mail "bcmail" in 1.48 into bcmail and a new bcpkix package which contains the extra java packages now needed to bump bouncycastle-mail to 1.48 to get it to rebuild to clear the original report entered here, i.e. a new package required.
Comment 5 Fedora Admin XMLRPC Client 2013-09-25 09:44:15 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Mat Booth 2014-03-14 12:39:35 EDT
This has been fixed in rawhide/F21, the whole bouncycastle suite of packages is now up to date at 1.50.

Note You need to log in before you can comment on or make changes to this bug.