Bug 914176

Summary: maven-toolchains-plugin: FTBFS in rawhide
Product: [Fedora] Fedora Reporter: Dennis Gilmore <dennis>
Component: maven-toolchains-pluginAssignee: Mikolaj Izdebski <mizdebsk>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: high    
Version: rawhideCC: java-sig-commits, mizdebsk, msrb, sochotni, tradej
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 1.0-7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-03-11 07:50:44 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 914651    
Bug Blocks: 913825    

Description Dennis Gilmore 2013-02-22 04:44:07 EST
Your package maven-toolchains-plugin failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=4968024

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/8024/4968024/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/8024/4968024/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/8024/4968024/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
Comment 1 Mikolaj Izdebski 2013-02-22 07:33:17 EST
So far this package doesn't build in rawhide because
of broken bouncycastle-main, see bug #914574 for more details.

I am adding dependency on bug #914574 and I will investigate
the real cause of the FTBFS once bouncycastle-mail is fixed.
Comment 2 Mikolaj Izdebski 2013-02-22 07:36:56 EST
In comment #1 I meant bug #914651, not bug #914574.
Fixing bug dependency. Sorry.
Comment 3 Mikolaj Izdebski 2013-02-28 08:05:18 EST
I just sis a scratch build and this package still
fails to build from source in rawhide:

Package maven-toolchains-plugin (5064101):
  noarch (5064126):
    build.log           : http://kojipkgs.fedoraproject.org/work/tasks/4126/5064126/build.log
    state.log           : http://kojipkgs.fedoraproject.org/work/tasks/4126/5064126/state.log
    mock_output.log     : http://kojipkgs.fedoraproject.org/work/tasks/4126/5064126/mock_output.log
    root.log            : http://kojipkgs.fedoraproject.org/work/tasks/4126/5064126/root.log
Comment 4 Mikolaj Izdebski 2013-02-28 08:24:34 EST
Incompatible Plexus version.
Comment 5 Mikolaj Izdebski 2013-03-08 07:53:02 EST
Fixed in maven-toolchains-plugin-1.0-7
Comment 6 Mikolaj Izdebski 2013-03-11 07:50:44 EDT
I believe that this bug is fixed in maven-toolchains-plugin-1.0-7,
which is available in Fedora Rawhide, so I am closing this bug now.
Thank you for reporting it.  You are welcome to submit any further reports.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=401009