Bug 951596

Summary: Rebase spice-vdagent to latest upstream
Product: Red Hat Enterprise Linux 6 Reporter: Hans de Goede <hdegoede>
Component: spice-vdagentAssignee: Hans de Goede <hdegoede>
Status: CLOSED ERRATA QA Contact: Desktop QE <desktop-qa-list>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.4CC: acathrow, cfergeau, dblechte, lnovich, mkrcmari
Target Milestone: rcKeywords: Rebase
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: spice-vdagent-0.14.0-1.el6 Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Important: if this rebase instead contains *only bug fixes,* or *only enhancements*, select the correct option from the Doc Type drop-down list. Rebase package(s) to version: 0.14.0 Highlights, important fixes, or notable enhancements: * Multi-monitor and arbritary resolution support bugfixes * Add support for file transfers from client to guest * Add support for setups with multiple Screens (multiple qxl devices each mapped to their own screen, rhbz#904082), limitations: -Max one monitor per Screen / qxl device -All monitors / Screens must have the same resolution -No client -> guest resolution syncing * Add spice-vdagent -X cmdline option, which runtime disables console-kit / systemd-logind integration for setups where these are not used (rhbz#904084) * Add manpages for spice-vdagent and spice-vdagentd
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-11-21 06:25:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 904082, 904084    

Description Hans de Goede 2013-04-12 14:22:35 UTC
Currently we are carrying a ton of patches for the new dynamic resolution and monitor support. For 6.5 we likely also want to fix bug 904082 and bug 904084 which means adding yet more patches.

Therefor I would like to rebase spice-vdagent to the latest upstream, which will bring in all the patches we are already carrying + fixes for bug 904082 and bug 904084.

The only thing it adds which we don't already have is client -> guest file transfer support (through drag and drop on the client window), which is something which we likely want to support soon anyways.

Comment 5 Hans de Goede 2013-06-26 06:49:20 UTC
This is fixed in spice-vdagent-0.14.0-1.el6 moving to MODIFIED,

Comment 9 errata-xmlrpc 2013-11-21 06:25:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1560.html