Bug 974080

Summary: Can't save exception report as a file
Product: [Fedora] Fedora Reporter: Kamil Páral <kparal>
Component: libreportAssignee: abrt <abrt-devel-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 19CC: abrt-devel-list, dvlasenk, jfilak, jmoskovc, mlichvar, mmilata, mtoman, robatino
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-06-13 12:12:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 834090    
Attachments:
Description Flags
libreport configuration
none
libreport error
none
journal from the running system, after libreport failed none

Description Kamil Páral 2013-06-13 11:52:02 UTC
Description of problem:
I used https://fedoraproject.org/wiki/QA:Testcase_Anaconda_save_traceback_to_bugzilla to trigger a fake exception on F19 TC3 DVD x86_64. I tried to save it to a file. It failed with error:

> No processing for event 'report_Uploader' is defined

Reporting to Bugzilla works.

Version-Release number of selected component (if applicable):
F19 TC3 DVD x86_64

How reproducible:
always

Steps to Reproduce:
1. kill -USR1 `cat /var/run/anaconda.pid`
2. "upload data to server"
3. use "file:///tmp/" location
4. confirm everything, see said error

Comment 1 Kamil Páral 2013-06-13 11:52:36 UTC
Created attachment 760630 [details]
libreport configuration

Comment 2 Kamil Páral 2013-06-13 11:52:45 UTC
Created attachment 760631 [details]
libreport error

Comment 3 Kamil Páral 2013-06-13 11:53:04 UTC
Created attachment 760632 [details]
journal from the running system, after libreport failed

Comment 4 Kamil Páral 2013-06-13 11:54:48 UTC
We have the following criterion:
"The installer must be able to report failures to Bugzilla, with appropriate information included. "
http://fedoraproject.org/wiki/Fedora_19_Alpha_Release_Criteria#Failure_reporting

However, we might consider saving to a file equally important. Some organizations may not want to save errors to Fedora Bugzilla.

Comment 5 Kamil Páral 2013-06-13 11:55:53 UTC
I confirmed that "scp://" fails with the same error as "file://".

Comment 6 Kamil Páral 2013-06-13 12:12:03 UTC

*** This bug has been marked as a duplicate of bug 971117 ***